Znaleziono 10 wyników

autor: P4tryk
pn cze 22, 2020 5:22 pm
Forum: Pomoc
Temat: Arduino ssrpc_in_queue_push error
Odpowiedzi: 6
Odsłony: 567

Re: Arduino ssrpc_in_queue_push error

Niestety bez zmian. Urządzenie rejestruje się do cloud-a. Nawet co kilka sekund zmienia się data ostatniego połączenia wyświetlana w cloud-zie ale ogólnie jest cały czas ROZŁĄCZONO.
autor: P4tryk
ndz cze 21, 2020 12:15 pm
Forum: Pomoc
Temat: Arduino ssrpc_in_queue_push error
Odpowiedzi: 6
Odsłony: 567

Re: Arduino ssrpc_in_queue_push error

Niestety, dalej nic. Usunąłem kanały i zostawiłem tylko 2 DS-y, usunąłem urządzenie z cloud-a. Urządzenie się rejestruje jednak nie ma odczytów.
Dalej:
Register in progress
ssrpc_in_queue_push error
Iterate fail
Proszę o jakieś wskazówki.
autor: P4tryk
ndz cze 21, 2020 8:35 am
Forum: Pomoc
Temat: Arduino ssrpc_in_queue_push error
Odpowiedzi: 6
Odsłony: 567

Re: Arduino ssrpc_in_queue_push error

Biblioteka najnowsza dostępna ze strony supla.org na dzień 20-06-2020 - w library.properties jest version=1.5 Płytka MEGA Ilość kanałów: 2x DHT22 3x DS18B20 2x przekaźnik, łącznie 7 Dodam iż przed aktualizacją działało to poprawnie, wcześniej było 4-5 kanałów później dodałem 7 i były problemy z wyśw...
autor: P4tryk
sob cze 20, 2020 12:42 pm
Forum: Pomoc
Temat: Arduino ssrpc_in_queue_push error
Odpowiedzi: 6
Odsłony: 567

Arduino ssrpc_in_queue_push error

Witam Pojawił mi się problem po zaktualizowaniu bibliotek środowiska Arduino jak i samego środowiska. Aktualizowałem również biblioteki SUPLA. Niestety skutek jest taki: Not connected Register in progress ssrpc_in_queue_push error Iterate fail Próbowałem przywracać starsze biblioteki, jednak zaktual...
autor: P4tryk
śr paź 25, 2017 8:56 pm
Forum: Pomoc
Temat: ROW-01 jak przekazuje stan do Supli
Odpowiedzi: 5
Odsłony: 1561

Re: ROW-01 jak przekazuje stan do Supli

Znowu problem. funkcja channelValueChanged jest typu protected i nie mogę jej wywołać - lub nie umiem ? jedyną ciekawą funkcją typu public zdatną do moich potrzeb jest channelSetValue(TSD_SuplaChannelNewValue *new_value). Jeśli dobrze rozumiem kod, wywoła ona w trakcie swojego działania i tak funkcj...
autor: P4tryk
wt paź 24, 2017 8:25 pm
Forum: Pomoc
Temat: ROW-01 jak przekazuje stan do Supli
Odpowiedzi: 5
Odsłony: 1561

Re: ROW-01 jak przekazuje stan do Supli

Rozumiem że powinienem wywołać te funkcje, ale przynajmniej z dwoma parametrami, pierwszy channel_number i drugi v. Nie mogę zrozumieć co jest przekazywane w tym v? W jakiś sposób zapisany właśnie stan w zmiennej char? Proszę o kolejną wskazówkę :)
autor: P4tryk
ndz paź 22, 2017 4:43 pm
Forum: Pomoc
Temat: ROW-01 jak przekazuje stan do Supli
Odpowiedzi: 5
Odsłony: 1561

ROW-01 jak przekazuje stan do Supli

Witam Zamontowałem włącznik ROW-01 i zauważyłem że przekazuje on stan włączenia żarówki do Supli, tak że po włączeniu ręcznym (przy pomocy włącznika/kontaktu) aplikacja na telefonie pokazuje również zmianę stanu włączenia żarówki. Jak to mogę zrealizować z poziomu arduino ? Gdy włączałem z poziomu p...
autor: P4tryk
ndz paź 22, 2017 4:36 pm
Forum: ZAMEL ROW-01
Temat: ROW-01 ręczne włączanie
Odpowiedzi: 8
Odsłony: 10551

ROW-01 ręczne włączanie

Witam Zainstalowałem urządzenie ROW-01 Zamel-a i działa poprawnie jeżeli chodzi o stronę Supli. Mam tylko problem z częstą koniecznością podwójnego włączania "ręcznym" włącznikiem. Po przełączeniu włącznika często żarówka tylko mignie i dopiero drugie przełączenie włącza na stałe żarówkę. Mam zwykły...
autor: P4tryk
pn lut 13, 2017 4:46 pm
Forum: Pomoc
Temat: Supla+Arduino+odczyt_temperatury
Odpowiedzi: 3
Odsłony: 1184

Re: Supla+Arduino+odczyt_temperatury

Dziękuję, faktycznie działa. Jak często jednak powinny odbywać się zmiany temperatury, lub komunikacja z serwerem SuplaDevice.iterate(); ? Mam tą czynność w pętli z opóźnieniem delay(3000) i znikają mi odczyty (---), a później pojawiają się po jakimś czasie. Czy powodem będzie to opóźnienie, lub prz...
autor: P4tryk
pn sty 23, 2017 4:40 pm
Forum: Pomoc
Temat: Supla+Arduino+odczyt_temperatury
Odpowiedzi: 3
Odsłony: 1184

Supla+Arduino+odczyt_temperatury

Witam Testuję odczyt temperatury z DS18B20 przy pomocy Supla+Arduino. Przykładowa funkcja działa poprawnie gdy pod zmienną t podstawiam wartość odczytaną z DS18B20. Gdy do zmiennej t przypiszę ręcznie wartość - całość nie działa - Supla nie pokazuje temperatury, jedynie trzy kreski. Poniżej przykład...

Wyszukiwanie zaawansowane