Page 5 of 8

Re: Supla Button 4 direct links

Posted: Sun Feb 10, 2019 4:13 pm
by miko1282
elmaya wrote:
Sun Feb 10, 2019 3:53 pm
miko1282 wrote:
Sun Feb 10, 2019 3:39 pm
Hi, why configuration are not the saved after unplugging the power and connecting them?
:D
which software,which esp,arduino or Bin?
on esp8266 from the bin 6x and 4x file

##EDIT##
Thanks to elmaya, he wrote to me and helped me, everything works perfectly, thanks!

Re: Supla Button 4 direct links

Posted: Fri Feb 15, 2019 9:08 pm
by PuteR
Hello, I have a soft problem with 6 links. Uploaded on nodemcu v3, correctly connects to the network, but after pressing the button, the diode blinks twice and nothing happens.
In the configuration mode too, I can not enter holding the button on D1 gives nothing. What can it do?

Re: Supla Button 4 direct links

Posted: Fri Feb 15, 2019 9:58 pm
by elmaya
PuteR wrote:
Fri Feb 15, 2019 9:08 pm
Hello, I have a soft problem with 6 links. Uploaded on nodemcu v3, correctly connects to the network, but after pressing the button, the diode blinks twice and nothing happens.
In the configuration mode too, I can not enter holding the button on D1 gives nothing. What can it do?
normal or bistable?
have you tried Dio mode?
and most importantly, you have erased module?

Re: Supla Button 4 direct links

Posted: Fri Feb 15, 2019 10:52 pm
by PuteR
Normal monstable buttons, module cleaned each time with a blank file, possibly erase.

The server is on raspberry.

Re: Supla Button 4 direct links

Posted: Fri Feb 15, 2019 11:00 pm
by elmaya
PuteR wrote:
Fri Feb 15, 2019 10:52 pm
Normal monstable buttons, module cleaned each time with a blank file, possibly erase.

The server is on raspberry.
try this Bin that I made for the friend niko
D_Link_Config_5_s_x6_miko.ino.generic.rar
(411.43 KiB) Downloaded 23 times

Re: Supla Button 4 direct links

Posted: Fri Feb 15, 2019 11:27 pm
by PuteR
elmaya wrote:
Fri Feb 15, 2019 11:00 pm
PuteR wrote:
Fri Feb 15, 2019 10:52 pm
Normal monstable buttons, module cleaned each time with a blank file, possibly erase.

The server is on raspberry.
try this Bin that I made for the friend niko

D_Link_Config_5_s_x6_miko.ino.generic.rar
unfortunately, the same is still true, I assumed that the outputs are so D1 = Link1.

After connecting to the network, the first one you press the LED blinks several times, the next time it is only twice, but nothing happens.

Re: Supla Button 4 direct links

Posted: Sat Feb 16, 2019 8:33 am
by elmaya
What does it show on the serial monitor?

Re: Supla Button 4 direct links

Posted: Sat Feb 16, 2019 8:49 am
by PuteR
elmaya wrote:
Sat Feb 16, 2019 8:33 am
What does it show on the serial monitor?
It's about the putty program? If so, I will check it in the evening and write.

Re: Supla Button 4 direct links

Posted: Sat Feb 16, 2019 9:26 am
by PuteR
I do not know if I did a good job, but if I combine with putty, only some bushes pop up and after pressing d1 turn off the putty.

Re: Supla Button 4 direct links

Posted: Sat Feb 16, 2019 9:30 am
by elmaya
I suppose the links work for you from the browser?

Serial (115200)

httpsPort = 443; Or have you changed it on your local server?