ESP8266 i DS18B20

0xFF
Posty: 308
Rejestracja: sob lut 20, 2016 8:54 pm

wt mar 01, 2016 9:17 pm

U mnie wygląda ok, teraz pokazuje 20.5C.
Obok leży moduł BLE z DHT22 i pokazuje 20.2C, więc jest ok.
Awatar użytkownika
pzygmunt
Posty: 7740
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

śr mar 02, 2016 3:41 pm

Jak możesz to pobierz aktualną wersję pliku https://github.com/SUPLA/supla-core/blo ... _ds18b20.c
skompiluj i sprawdź czy działa z DS1820.

Dodałem automatyczne wykrywanie modelu czujnika tak więc teraz powinno być uniwersalnie.
0xFF
Posty: 308
Rejestracja: sob lut 20, 2016 8:54 pm

czw mar 03, 2016 7:46 pm

Potwierdzam, działa na DS1820.
askori
Posty: 23
Rejestracja: śr mar 30, 2016 9:36 pm

ndz kwie 03, 2016 5:21 pm

Witam,
mam taki problem ze DS po podłączeniu poprzez rezystor do GPI02 strasznie się grzeje,
nw jak to rozwiązac,
prosiłbym o jakąś rade
z góry dzięki
besix
Posty: 263
Rejestracja: ndz mar 20, 2016 9:51 pm

ndz kwie 03, 2016 7:56 pm

Podłączasz przez rezystor do GPIO2 czy rezystor równolegle między +V a GPIO ? Jaki rezystor ? Powinien być 4,7K podłączony równolegle
askori
Posty: 23
Rejestracja: śr mar 30, 2016 9:36 pm

pn kwie 04, 2016 1:12 pm

Podlaczam tak jak na tym schemacie:
Załączniki
image.png
image.png (10.86 KiB) Przejrzano 2895 razy
Awatar użytkownika
wojtas567
Posty: 1916
Rejestracja: ndz kwie 03, 2016 7:16 pm
Lokalizacja: Olsztyn

pn kwie 04, 2016 2:53 pm

Witam
Pomijając zwarcie na piach to pozostają dwie możliwości zamiana plusa z minusem i wtedy Ds będzie się grzał lub jest uszkodzony.
Pozdrawiam
Wojtas
Pozdrawiam
Wojtek
0xFF
Posty: 308
Rejestracja: sob lut 20, 2016 8:54 pm

pn kwie 04, 2016 6:06 pm

Schemat nie wyjaśnia czy jest to widok z góry, czy z dołu.
Zatem pomyłka jest możliwa.
Awatar użytkownika
slawek
Posty: 2221
Rejestracja: pn mar 14, 2016 11:48 pm
Lokalizacja: Biała Podlaska

pn kwie 04, 2016 10:06 pm

DS18B20-Wiring.jpg
DS18B20-Wiring.jpg (26.44 KiB) Przejrzano 2883 razy
To powinno rozwiać wątpliwości
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
0xFF
Posty: 308
Rejestracja: sob lut 20, 2016 8:54 pm

wt kwie 05, 2016 10:25 am

Schemat połączeń wygląda prawidłowo.
Jak masz możliwość sprawdź na innym egzemplarzu. Może ten jest uwalony.
ODPOWIEDZ