Firmware Multiboard

Niebanalny_J
Posty: 10
Rejestracja: śr maja 22, 2019 7:13 pm

ndz gru 15, 2019 7:18 pm

Włącznik zew bistabilny zachowuje się jak monostabilny i włącza konfiguracje.

Sonoff Basic, wgrany multiboard, na gpio14 (Key) walutowany zewnętrzny włącznik bistabilny, gpio14 podciągnięty rezystor 4,7k do vcc, w ustawieniach wybrany button bistabilny. Mimo to włącznik zachowuje się/ działa jak mono w dodatku sonoff przechodzi w tryb konfiguracji. po zmianie w ustawieniach na mono bez zmian, takie samo zachowanie. Co robię źle?? Pomocy bo już nie ogarniam.
mareks6
Posty: 133
Rejestracja: sob sty 13, 2018 4:39 pm
Lokalizacja: Opole

ndz gru 15, 2019 8:40 pm

Przekopałem cały ten wątek i nie znalazłem jednoznacznej odpowiedzi.

Czy po wgraniu multiboard do Sonoff 4ch Pro R2 (wersja druga) będę w stanie ustawić moduł na 2x socket (włączanie światła w pomieszczeniu) + 2x gate (sterowanie dwoma ryglami w drzwiach) + 2 jakiekolwiek czujniki temperatury?

Drugie pytanie, czy w tym module, a raczej firmware są poprawione błędy zgłaszane w głównym wątku dotyczącym Sonoff 4ch PRO, takie jakie chwilowe zwieranie przekaźników kanałów 1 i 2 przy przerwach w dostępie do serwera czy trzeba dolutowywać wspomniane tam kondensatory?
krawiol
Posty: 8
Rejestracja: śr paź 25, 2017 7:23 pm

czw gru 19, 2019 10:30 pm

Wgrałem do shelly 1 multiboard i chciałbym żeby zwalniał elektrozaczep w drzwiach ustawiłem bistabilny i w Cloud mam do wyboru tylko włącznik światła lub zasilania. Proszę o pomoc.
Patryk
Posty: 778
Rejestracja: pn sty 07, 2019 7:51 pm

czw gru 19, 2019 10:40 pm

krawiol pisze:
czw gru 19, 2019 10:30 pm
Wgrałem do shelly 1 multiboard i chciałbym żeby zwalniał elektrozaczep w drzwiach ustawiłem bistabilny i w Cloud mam do wyboru tylko włącznik światła lub zasilania. Proszę o pomoc.
Nie mam tego Shelly
Ale, może podczas pierwszej konfiguracji miałeś ustawiony "monostabilny". ( przy rejestracji do CLUD-a).
Jeżeli tak to usuń ten "moduł" z CLUD-a i ponownie go zarejestrować.
krawiol
Posty: 8
Rejestracja: śr paź 25, 2017 7:23 pm

czw gru 19, 2019 11:43 pm

Tak też robiłem.
Przemo_06_92
Posty: 41
Rejestracja: ndz lis 11, 2018 2:39 pm

ndz gru 29, 2019 2:40 pm

Witam!
Mam zrobiony układ: Wemos D1 mini do tego 4 przekaźniki i 4 zewnętrzne przyciski monostabilne i czy jest możliwość aby ten Firmware obsłużył ten układ ?
Mam wgrany Firmware z Github-a do obsługi takiego układu ale problem pojawia się przy braku połączenia z internetem otóż załącza mi co paredziesiąt sekund przekaźniki i od razu rozłącza albo jak są załączone to wyłącza i załącza a przy sonoff basic lub przy sonoff S26 (inteligentne gniazdko) tego efektu nie ma tylko mruga dioda o braku połączenia.
Ktoś mógłby pomóc albo podsunąć jakiś Firmware ? bo szukam na forach i nie mogę sobie poradzić :(
Czy w ustawieniach Multiboard można zaznaczyć Sonoff 4Ch i będzie działało to na Wemos D1 mini ?

Z Góry Dzięki ;-)
diehard
Posty: 8
Rejestracja: pn paź 14, 2019 6:01 am

pn gru 30, 2019 7:18 pm

Przepraszam, że nie odpowiem na powyższy temat, ale mam problem z przejściem w tryb konfiguracji sonoffa basic.
Pomimo klikania 10 razy na włącznik sonoff nie chce przejść do konfiguracji.
Proszę o pomoc

Mam wgranego najnowszego multiboard od espablo i ustawiłem łącznik jako monostabilny i tryb konfiguracji (x10)
Patryk
Posty: 778
Rejestracja: pn sty 07, 2019 7:51 pm

pn gru 30, 2019 7:31 pm

Spróbuj "przytrzymać" przycisk monostabilny przez ok 5 sekund.
diehard
Posty: 8
Rejestracja: pn paź 14, 2019 6:01 am

pn gru 30, 2019 8:01 pm

Dzięki za szybką odpowiedź, ale niestety to nie pomaga.
jpierscieniak
Posty: 3
Rejestracja: czw lut 22, 2018 8:02 pm

śr sty 01, 2020 9:13 pm

Cześć
Mam prośbę o podpowiedź co robię źle.
Podłączyłem Sonoff Basic w trybie programowania i wyczyściłem pamięć poleceniem:
esptool.py --port /dev/ttyUSB0 erase_flash
następnie pobrałem pliki z https://github.com/Espablo/SUPLA_Firmwa ... multiboard
i po następnym połączeniu w trybie programowania wgrywam poleceniem:
esptool.py --port /dev/ttyUSB0 write_flash -fs 1MB -fm dout 0x00000 multiboard_1024_dout_eagle.flash.bin 0x40000 multiboard_1024_dout_eagle.irom0text.bin

Wynik:
"esptool.py v2.8
Serial port /dev/ttyUSB0
Connecting....
Detecting chip type... ESP8266
Chip is ESP8266EX
Features: WiFi
Crystal is 26MHz
MAC: 5c:cf:7f:79:dd:4e
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Warning: Image file at 0x0 doesn't look like an image file, so not changing any flash settings.
Compressed 66540 bytes to 14225...
Wrote 66540 bytes (14225 compressed) at 0x00000000 in 1.3 seconds (effective 421.1 kbit/s)...
Hash of data verified.
Compressed 66744 bytes to 14253...
Wrote 66744 bytes (14253 compressed) at 0x00040000 in 1.3 seconds (effective 422.4 kbit/s)...
Hash of data verified.

Leaving...
Hard resetting via RTS pin..."

ale jak widać mam błąd z rozpoznaniem pliku "Image file at 0x0 doesn't look like an image file". Oczywiście sonoff nie reaguje po podłączeniu do zasilania.

Pliki pobierałem przez przeglądarkę internetową, więc raczej powinny być dobre. Może polecenie mam niekompletne?


Pozdrawiam
Jacek P
ODPOWIEDZ