Strona 38 z 129

Re: Firmware Multiboard

: pn lis 05, 2018 1:15 pm
autor: byniom
To nie jest chyba wina softu bo zaobserwowałem podobne zjawisko na innym sofcie tylko jak teraz to napisałeś dało mi do myślenia i coś sprawdziłem.
Mam w pokojach dwa czujniki DHT22 i jeden moduł działa prawidłowo a inny ma problemy jeżeli nastapi reset supli np. przy zapisywaniu ustawień przy konfiguracji jakiegos modułu. Myślałem że to wina modułu bo miałem w tym jendym czujniku wgrany program do esp12 ale potem ten sam program wgrałem do wemosa . Jakis czas działa a jeżeli nastąpi reset supli to już nie pokazuje wartości choć jest połaczony z siecią . Oba czujniki sa w tej samej lokalizacji . Wgrałem do tego ferelnego modułu oprogramowanie 9x relay ale włączony mam tylko czujnik DHT22 i nadal problem występuje . Wydaje mi się że to wina supli a nie modułów . Wymieniałem w nim nawet sam czujnik i tez nic nie dało . Dodałem rezystor na GPIO15 bo koledzy pisali że musi być i tez nic , po resecie pomiar ginie. Teraz mam suplę w cloudzie ale wczesniej miałem na raspberry i tez była taka sama sytuacja. Wcześniej nie zwróciłęm uwagi w jakim momencie następuje brak pomiarów ale teraz jak napisałeś że po resecie to specjalnie sprawdziłem zmieniając co kolwiek w supli tak żeby zrobić zapisanie ustawień , wtedy supla się resetuje i już nie mam pomiaru . Dziwne jest to że tylko na tym jednym czujniku. Kiedy odłącyzłem czujnik od ładowarki to po podłączeniu nadal nie wstawał a odłączony był około 1 min. Kiedy podłączyłem pod usb w kompie złapał pomiar i pokazuje . Po ponownym podłączeniu do ładowarki pokazuje normalnie.

Re: Firmware Multiboard

: pn lis 05, 2018 3:25 pm
autor: dawidd
wsadziłem teraz nówkę dht22, zrobiłem kilka zapisów w cloudzie i odczyt o dziwo powrócił. Potestuje i dam znać czy wymiana dht pomogła. Poprzedni dht tez pokazywał prawidłowo temp i wilgotność ale tylko do czasu utraty połączenia z serwerem

Re: Firmware Multiboard

: pn lis 05, 2018 6:24 pm
autor: QLQ
scoobi pisze:
ndz lis 04, 2018 1:40 pm
mam problem z muliboard:
poprzednio na płytce "witty" jakiś clon wemosa miałem wgrane soft incan i podłączony dht11 wszystko działało, teraz po wgraniu multiboard i ustawieniu incan wyświetla kosmiczne wyniki typu temperatura 450 stopni wilgotność 1500% - ( przy powrocie do incan wszystko działa) są jakieś różnice w sofcie ?

edit takie samo są objawy na sonoff basic z wgranym multiboard- elektrodaragon ( dht11 podłaczone pod pin 14 i tak tez ustawione w opcjach) tez pokazuje kosmiczne wartości
Miałem dokładnie to samo na sofcie @Espablo w wersji InCan easy na płytce projektu Supla inCan2.0. Pisałem wtedy do Espablo w tej sprawie . Zaraz odkopię wiadomości - podam kiedy dokładnie to było. Był wtedy soft InCan Easy i InCan. W jedym z nich właśnie w tym gdzie można było już ustawiać GPIOX działy się dokładnie te same rzeczy - czyli temperatura i wilgotność z kosmosu. Po odłączeniu czujnika i ponownym podłączeniu wracało do normy



Proszę treść wiadomości z początku 2018 roku do @Espablo. :
Historia wiadomości:
Re: Płytka do puszki Supla V2

Wysłano: czw sty 04, 2018 8:48 am
autor: Espablo

QLQ pisze:

Wysłano: wt sty 02, 2018 9:08 am
autor: QLQ


pt gru 08, 2017 9:30 pm
Witam serdecznie
MAM OD KOLEGI kupione 2 szt Supla V3 . I do jednego z nich wgrałem inCan Easy bo przy braku wifi po ok 4 min gasił światło samoczynnie . Flashowanie poszło ok. Tyle że nie działa wyświetlanie temp z dht11 . A dokładnie nawet jak czujnik odłączę pokazuje jakieś bzdury jak już pisałem. Np temp 487.7 st C i podobnie wilgotność. W konfigu esp na 192.168.4.1 zostawiam w inCan Easy tak jak jest. Zastanawia mnie to że na GPIO2 jest czujnik i dioda . Może to jest przyczyną?

Czy można prosić firmware z pamięcią stanów do wer 3 ?

Tak czy inaczej coś jest na rzeczy w sofcie .

Re: Firmware Multiboard

: pn lis 05, 2018 7:02 pm
autor: mihu
też odpiłem od sonoffa dht11 który działa na sofcie z daty początku października ,wgrałem do nowego sonofa z aklualnym softem i bzdury pokazuje.pozd

Re: Firmware Multiboard

: pn lis 05, 2018 8:22 pm
autor: QLQ
Soft od @Espablo oraz @Zybi gdzie nie ma możliwości zmian GPIO chodzi od września zeszłego roku bez zarzutu. Płytki z 2 przekaźnikami plus Dth11. Dokładnie 5 szt oraz 1 szt 4 przekaźniki plus ds18

Re: Firmware Multiboard

: wt lis 06, 2018 7:19 am
autor: dawidd
Po nocy działania płytki 9xprzekaznik niestety nie jest dobrze. Rano załączone sa 2 przekaźniki z lini tx i rx, a dht22 pokazuje przez moment dobre wartosci, po paru sekundach 00 i --- a później z znów ok, a do tego co jakiś czas kosmiczne odczyty wilgotności rzędu 1000000 procent

Re: Firmware Multiboard

: wt lis 06, 2018 8:24 am
autor: shimano73
A takie pytanie , jeśli podłączymy czujniki pod rx lub tx a później coś wyślemy coś na konsole ( Serial.print(„coś tam”) ) to jak to się zachowa ? Może tu jest prablem z zanikiem odczytów z czujnika

Re: Firmware Multiboard

: wt lis 06, 2018 8:30 am
autor: dogu18
A jest różnica czy ds podepne do RX czy tx? Czy jest jakaś kolejność że na tym ma być ds a na tym thd?

Re: Firmware Multiboard

: wt lis 06, 2018 11:36 am
autor: piotrh94
Jak tak czytam to widzę że również mam podobny problem. Po zasileniu sonoff Basic z DHT22 dokonuje pomiaru ale po czasie wysyła bzdury temp 0 wilg. 108..... Jeśli się to tak zostawi to zanika jakikolwiek odczyt z czujnika (tak jakby był nie podlaczony). Czytałem że powodem tego może być fakt że termometr jest w sofcie przypisany do gpio1, dlatego myślałem czy nie dało by rady wgrać soft na sonoff th (termometr na gpio14) Czy to możliwe, czy ktoś tak próbował?

Re: Firmware Multiboard

: wt lis 06, 2018 11:40 am
autor: byniom
Mam pod wemos i pod gpio2 i tak samo się robi