Arduino - sterowanie z przycisków przy braku połączenia z serwerem

Zybi
Posts: 1296
Joined: Sun Jun 26, 2016 4:24 pm

Sat Mar 09, 2019 8:41 pm

Od dzisiaj moje kompilacje na bazie środowiska Arduino SDK dostały nową funkcjonalność - jest już możliwość sterowania kanałami ON/OFF z przycisków nawet przy braku połączenia modułu ESP z serwerem.

Funkcjonalność ta dotyczy przycisków w trybie MONOSTABLE, BISTABLE i TIMER i działa zarówno przy sterowaniu przekaźnikiem stanem wysokim jak i niskim.

W ten sposób mamy całkowitą autonomiczność modułu.

Funkcja została dodana do softu ALL IN ONE (w różnych odmianach) :
viewtopic.php?f=11&t=4134

Z tego też względu wznawiam testy softu ALL IN ONE, jednak tylko dla aktywnych użytkowników społeczności SUPLI.
PuteR
Posts: 512
Joined: Wed Dec 06, 2017 10:07 am

Sat Mar 16, 2019 12:18 am

Zibi coś nie mogę odpalić DS na tym sofcie V5.1 podłączając czy to jeden czy więcej sonoff w ogóle się nie łączy z cloudem a sam DS zaczyna się grzać, po odłączeniu DS sonoff odrazu łączy się z cloudem, ale lampka zaczyna mrugać (to akurat chyba prawidłowy objaw) czy robię coś nie tak?? Aha przy podłączonym DHT22 wszystko jest OK.
Zybi
Posts: 1296
Joined: Sun Jun 26, 2016 4:24 pm

Sat Mar 16, 2019 6:43 am

Skoro DS Ci się grzeje, to albo źle go podłączasz, albo jest uszkodzony.

Jaką masz wersję softu i jaki model Sonoff-a, bo w wersji v5.1 zmieniona jest pinologia w stosunku do opisu w wątku na forum.
PuteR
Posts: 512
Joined: Wed Dec 06, 2017 10:07 am

Sat Mar 16, 2019 8:52 am

Sprawdzałem na 3 szt. więc albo wszystkie są walniete albo faktycznie źle je podłączam. Sonoff ta pierwsza wersja DS podłączalem pod GPIO1 więc chyba prawidłowo.

Podłączam to tak lewa nóżka GND, środkowa pin GPIO1, prawa nóżka VCC i wtedy DS się grzeje i sonoff się nie łączy. Jak go odwroce sonoff się łączy a DS już się nie grzeje ale też i nie działa.
Zybi
Posts: 1296
Joined: Sun Jun 26, 2016 4:24 pm

Sat Mar 16, 2019 9:03 am

Następna zasada jest taka, że DS musi być podłączony przed włączeniem zasilania modułu, a pomiary pokazują się dopiero po ok. 30 sekundach.
PuteR
Posts: 512
Joined: Wed Dec 06, 2017 10:07 am

Sat Mar 16, 2019 9:27 am

Tak właśnie robię, niestety przy podłączeniu z zasilania z podłączonym DS brak jakiekolwiek reakcji sonoff nie łączy się a dioda nie świeci w ogóle. Przy podłączeniu odwrotnym DS (raczej tym błędnym) sonoff się łączy dioda mruga i brak wskazań z DS. Może faktycznie trafiła się jakaś kiepska partia i wszystkie DS są uszkodzone.
User avatar
slawek
Posts: 2170
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Sat Mar 16, 2019 10:51 am

A może przypadkiem zapomniałeś o rezystorze?
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
Zybi
Posts: 1296
Joined: Sun Jun 26, 2016 4:24 pm

Sat Mar 16, 2019 12:40 pm

PuteR wrote:
Sat Mar 16, 2019 9:27 am
Tak właśnie robię, niestety przy podłączeniu z zasilania z podłączonym DS brak jakiekolwiek reakcji sonoff nie łączy się a dioda nie świeci w ogóle. Przy podłączeniu odwrotnym DS (raczej tym błędnym) sonoff się łączy dioda mruga i brak wskazań z DS. Może faktycznie trafiła się jakaś kiepska partia i wszystkie DS są uszkodzone.
A ile DS-ów masz zadeklarowanych w trybie konfiguracji modułu?
PuteR
Posts: 512
Joined: Wed Dec 06, 2017 10:07 am

Sat Mar 16, 2019 1:09 pm

Zachowanie jest zawsze takie same czy mam jeden, dwa czy trzy podłączone.
edm
Posts: 135
Joined: Mon Jan 15, 2018 6:18 pm

Sat Mar 16, 2019 1:33 pm

Kiedyś błędnie podłączyłem DS, czyli zamieniłem VCC z GND i efektem było mocne nagrzewanie DS. Lecz nie uszkodził się.
Post Reply