ESP8266 Primary GUI v2

Awatar użytkownika
pilcu
Posty: 169
Rejestracja: pt sty 11, 2019 9:49 am
Lokalizacja: Wrocław

śr mar 11, 2020 6:55 am

krycha88 pisze:
śr mar 11, 2020 6:43 am
pilcu pisze:
śr mar 11, 2020 6:13 am
Wgrywam to na Wemosa d1 mini a w Arduino IDE mam wybraną płytkę LOLIN(WEMOS) D1 R2 & mini.

1.png

EDIT:

Zauważyłem teraz, że moduł traci stan przekaźnika po ponownym zarejestrowaniu do routera.
W panelu konfiguracyjnym jest wybrane "pamiętaj stan".
a jaką masz zainstalowaną wersję płytek? aktualna to 2.6.3

uruchom sobie monitor portu szeregowego i zobacz co się dzieje po restarcie urządzenie.
Miałem wersję 2.5.1, po zainstalowaniu 2.6.3 moduł restartuje się po każdym "przejściu" przez wszystkie kanały. Ten sam problem, który opisywałem kilka postów wcześniej (z filmikiem).
2.png
2.png (84.82 KiB) Przejrzano 428 razy
krycha88
Posty: 714
Rejestracja: pt lis 16, 2018 7:25 am

śr mar 11, 2020 7:22 am

pilcu pisze:
śr mar 11, 2020 6:55 am
krycha88 pisze:
śr mar 11, 2020 6:43 am
pilcu pisze:
śr mar 11, 2020 6:13 am
Wgrywam to na Wemosa d1 mini a w Arduino IDE mam wybraną płytkę LOLIN(WEMOS) D1 R2 & mini.

1.png

EDIT:

Zauważyłem teraz, że moduł traci stan przekaźnika po ponownym zarejestrowaniu do routera.
W panelu konfiguracyjnym jest wybrane "pamiętaj stan".
a jaką masz zainstalowaną wersję płytek? aktualna to 2.6.3

uruchom sobie monitor portu szeregowego i zobacz co się dzieje po restarcie urządzenie.
Miałem wersję 2.5.1, po zainstalowaniu 2.6.3 moduł restartuje się po każdym "przejściu" przez wszystkie kanały. Ten sam problem, który opisywałem kilka postów wcześniej (z filmikiem).
2.png
czy na pewno masz źródła stąd:
https://github.com/krycha88/Primary_GUI/tree/custom

bo nie widzę wszystkich plików na twoich screenach.
Awatar użytkownika
pilcu
Posty: 169
Rejestracja: pt sty 11, 2019 9:49 am
Lokalizacja: Wrocław

śr mar 11, 2020 7:28 am

krycha88 pisze:
śr mar 11, 2020 7:22 am
pilcu pisze:
śr mar 11, 2020 6:55 am
krycha88 pisze:
śr mar 11, 2020 6:43 am


a jaką masz zainstalowaną wersję płytek? aktualna to 2.6.3

uruchom sobie monitor portu szeregowego i zobacz co się dzieje po restarcie urządzenie.
Miałem wersję 2.5.1, po zainstalowaniu 2.6.3 moduł restartuje się po każdym "przejściu" przez wszystkie kanały. Ten sam problem, który opisywałem kilka postów wcześniej (z filmikiem).
2.png
czy na pewno masz źródła stąd:
https://github.com/krycha88/Primary_GUI/tree/custom

bo nie widzę wszystkich plików na twoich screenach.
Zauważyłem, że nie mam pliku o nazwie hardware.h

Skompiluje soft jeszcze raz na nowo pobranej paczce plików, którą przed chwilą mi udostępniłeś i dam znać.
Zaktualizować płytki do 2.6.3? Bo wróciłem do wersji 2.5.1 na której soft mi działał.
krycha88
Posty: 714
Rejestracja: pt lis 16, 2018 7:25 am

śr mar 11, 2020 7:36 am

pilcu pisze:
śr mar 11, 2020 7:28 am
krycha88 pisze:
śr mar 11, 2020 7:22 am
pilcu pisze:
śr mar 11, 2020 6:55 am


Miałem wersję 2.5.1, po zainstalowaniu 2.6.3 moduł restartuje się po każdym "przejściu" przez wszystkie kanały. Ten sam problem, który opisywałem kilka postów wcześniej (z filmikiem).
2.png
czy na pewno masz źródła stąd:
https://github.com/krycha88/Primary_GUI/tree/custom

bo nie widzę wszystkich plików na twoich screenach.
Zauważyłem, że nie mam pliku o nazwie hardware.h

Skompiluje soft jeszcze raz na nowo pobranej paczce plików, którą przed chwilą mi udostępniłeś i dam znać.
Zaktualizować płytki do 2.6.3? Bo wróciłem do wersji 2.5.1 na której soft mi działał.
ja używam 2.6.3 i działa bardzo dobrze.

odkomentuj sobie chcianego define lub dodaj swojego
https://github.com/krycha88/Primary_GUI ... dware.h#L6
i wtedy sobie dodajesz metody:
https://github.com/krycha88/Primary_GUI ... gs.cpp#L52
Awatar użytkownika
pilcu
Posty: 169
Rejestracja: pt sty 11, 2019 9:49 am
Lokalizacja: Wrocław

śr mar 11, 2020 12:34 pm

krycha88 pisze:
śr mar 11, 2020 7:36 am
pilcu pisze:
śr mar 11, 2020 7:28 am
krycha88 pisze:
śr mar 11, 2020 7:22 am


czy na pewno masz źródła stąd:
https://github.com/krycha88/Primary_GUI/tree/custom

bo nie widzę wszystkich plików na twoich screenach.
Zauważyłem, że nie mam pliku o nazwie hardware.h

Skompiluje soft jeszcze raz na nowo pobranej paczce plików, którą przed chwilą mi udostępniłeś i dam znać.
Zaktualizować płytki do 2.6.3? Bo wróciłem do wersji 2.5.1 na której soft mi działał.
ja używam 2.6.3 i działa bardzo dobrze.

odkomentuj sobie chcianego define lub dodaj swojego
https://github.com/krycha88/Primary_GUI ... dware.h#L6
i wtedy sobie dodajesz metody:
https://github.com/krycha88/Primary_GUI ... gs.cpp#L52
Wgrałem soft, problem mam z dodaniem czujnika BME280.
Odkomentowuje go w zakładce supla_board_settings.ccp i wywala błąd przy kompilacji.
krycha88
Posty: 714
Rejestracja: pt lis 16, 2018 7:25 am

śr mar 11, 2020 1:08 pm

pilcu pisze:
śr mar 11, 2020 12:34 pm
krycha88 pisze:
śr mar 11, 2020 7:36 am
pilcu pisze:
śr mar 11, 2020 7:28 am


Zauważyłem, że nie mam pliku o nazwie hardware.h

Skompiluje soft jeszcze raz na nowo pobranej paczce plików, którą przed chwilą mi udostępniłeś i dam znać.
Zaktualizować płytki do 2.6.3? Bo wróciłem do wersji 2.5.1 na której soft mi działał.
ja używam 2.6.3 i działa bardzo dobrze.

odkomentuj sobie chcianego define lub dodaj swojego
https://github.com/krycha88/Primary_GUI ... dware.h#L6
i wtedy sobie dodajesz metody:
https://github.com/krycha88/Primary_GUI ... gs.cpp#L52
Wgrałem soft, problem mam z dodaniem czujnika BME280.
Odkomentowuje go w zakładce supla_board_settings.ccp i wywala błąd przy kompilacji.
daj szansę się wykazać i podeślij chociaż ten błąd kompilacji ;)
Awatar użytkownika
pilcu
Posty: 169
Rejestracja: pt sty 11, 2019 9:49 am
Lokalizacja: Wrocław

czw mar 12, 2020 5:11 am

Nie wiem czy powinienem odkomentowywać w tym miejscu...
blad.png
blad.png (105.23 KiB) Przejrzano 323 razy
krycha88
Posty: 714
Rejestracja: pt lis 16, 2018 7:25 am

czw mar 12, 2020 6:41 am

pilcu pisze:
czw mar 12, 2020 5:11 am
Nie wiem czy powinienem odkomentowywać w tym miejscu...

blad.png
to co odkomentowałeś to są tylko przykłady

zrób tak jak pisałem wyżej.
Awatar użytkownika
pilcu
Posty: 169
Rejestracja: pt sty 11, 2019 9:49 am
Lokalizacja: Wrocław

czw mar 12, 2020 7:26 am

krycha88 pisze:
czw mar 12, 2020 6:41 am
pilcu pisze:
czw mar 12, 2020 5:11 am
Nie wiem czy powinienem odkomentowywać w tym miejscu...

blad.png
to co odkomentowałeś to są tylko przykłady

zrób tak jak pisałem wyżej.
Mógłbyś pomóc prostszym językiem jak dodać te metody? Ja raczkuję w programowaniu...
Ogólnie chcę to ogarnąć na WeMos z Oledem i BME280.
Podpowiedz jak powinien wyglądać plik supla_board_settings.cpp
Co w nim zostawić, co zmienić, gdzie #if, #elif itp.
krycha88
Posty: 714
Rejestracja: pt lis 16, 2018 7:25 am

czw mar 12, 2020 7:33 am

pilcu pisze:
czw mar 12, 2020 7:26 am
krycha88 pisze:
czw mar 12, 2020 6:41 am
pilcu pisze:
czw mar 12, 2020 5:11 am
Nie wiem czy powinienem odkomentowywać w tym miejscu...

blad.png
to co odkomentowałeś to są tylko przykłady

zrób tak jak pisałem wyżej.
Mógłbyś pomóc prostszym językiem jak dodać te metody? Ja raczkuję w programowaniu...
Ogólnie chcę to ogarnąć na WeMos z Oledem i BME280.
Podpowiedz jak powinien wyglądać plik supla_board_settings.cpp
Co w nim zostawić, co zmienić, gdzie #if, #elif itp.
Pobierz sobie nowe pliki które wrzuciłem na githuba:
https://github.com/krycha88/Primary_GUI/tree/custom
I wszystkie metody dodajesz w tym miejsciu:
https://github.com/krycha88/Primary_GUI ... s.cpp#L134
ODPOWIEDZ