Zdarzenia / webhooki

rafalfarba
Posty: 11
Rejestracja: pn lis 25, 2019 11:48 am

czw paź 15, 2020 8:58 am

W historii kanałów podaje mi zły czas. Opóźnienie dokładnie o 2 godziny (zdarzenie z 8:00 w historii jest 6:00). Czas ustawiony w Claudzie i w Skryptach poprawny Europe/Warsaw (UTC + 2). Dziwne że logi w skryptach pokazuje poprawnie. Co może być powodem?
Awatar użytkownika
PuteR
Posty: 862
Rejestracja: śr gru 06, 2017 10:07 am

czw paź 15, 2020 9:08 am

U mnie tak samo jak u lukfud sceny się nie wykonują 😐 no chyba że przez naciśnięcie przycisku wykonaj scene.
wsosniak
Posty: 443
Rejestracja: sob cze 02, 2018 8:02 am

czw paź 15, 2020 9:26 am

@fracz - a ja ma taki dziwny przypadek : Stworzyłem scenę (na bazie czujnika temperatury) gdzie w obydwa pola "wyzwalanie " i "warunek wykonania sceny" mam :
{{ state(xxxxx).temperature > 35 }}
rezultat to powiadomienie pushover "ZA CIEPŁO !!!" i super to działa, scena wyzwalana i uruchamiana jest tylko wtedy kiedy ten warunek jest spełniony

ale zrobiłem identyczną scenę gdzie w obydwa te pola wpisałem :
{{ state(xxxxx).temperature <7 }}
i powiadomienie "ZA ZIMNO !!" .
i ku mojemu zdziwieniu , co 15 sekund zacząłem dostawać powiadomienia ze jest ZA ZIMNO !!! chociaż temperatura jest cały czas w okolicach 21 stopni na tym czujniku, wyzwalacz i warunek cały czas pokazują sie NA ZÓŁTO / POMARAŃCZOWO z komunikatem "Warunek nie jest aktualnie spełniony.". NIe rozumiem ......I musiałem ten warunek w obydwu polach zmienic na
{{ state(xxxxx).temperature <7 and state(xxxxx).temperature >0 }}

czemu ? co jest nie tak ?

a jak ustawie wyzwalacz na :
{{ state(20078).temperature < 7 }}

a warunek na :
{{ state(20078).temperature < 7 and state(20078).temperature > 0}}

to scena jest wyzwalana co 15 sekund ale juz nie dostaje powiadomienia .
I w sumie mógłbym tak zostawić ale nie chcę CI bruździć po serwerze taką sceną . NIe mówiąc juz o tym że takich czujników mam kilka gdzie musiałbym podobne sceny stworzyć :) patrz screen ponizej
Załączniki
1.png
1.png (118.28 KiB) Przejrzano 76 razy
Ostatnio zmieniony czw paź 15, 2020 9:42 am przez wsosniak, łącznie zmieniany 2 razy.
Awatar użytkownika
klew
Posty: 1272
Rejestracja: czw cze 27, 2019 12:16 pm

czw paź 15, 2020 9:35 am

rafalfarba pisze:
czw paź 15, 2020 8:58 am
W historii kanałów podaje mi zły czas. Opóźnienie dokładnie o 2 godziny (zdarzenie z 8:00 w historii jest 6:00). Czas ustawiony w Claudzie i w Skryptach poprawny Europe/Warsaw (UTC + 2). Dziwne że logi w skryptach pokazuje poprawnie. Co może być powodem?
To jest znany problem. Fracz ma to poprawić.
Awatar użytkownika
klew
Posty: 1272
Rejestracja: czw cze 27, 2019 12:16 pm

czw paź 15, 2020 9:36 am

PuteR pisze:
czw paź 15, 2020 9:08 am
U mnie tak samo jak u lukfud sceny się nie wykonują 😐 no chyba że przez naciśnięcie przycisku wykonaj scene.
Masz swój serwer, czy publiczny? Jaki rodzaj i funkcja kanału? Pokaż screen z edycji sceny, aby było widać ustawienia.
Awatar użytkownika
uchnast.michal
Posty: 371
Rejestracja: wt cze 04, 2019 11:37 am
Lokalizacja: Czeladź
Kontaktowanie:

czw paź 15, 2020 10:18 am

fracz pisze:
śr paź 14, 2020 11:40 am
Mamy nowe skrypty, a w nich wsparcie dla hooków dla następujących funkcji:
  • czujnik temperatury i wilgotności oraz samej wilgotności
  • czujniki otwarcia wszystkich bram i okien
  • czujnik poczty
Aby skrypty dostawały informacje o zmianie stanów, należy się wylogować ze skryptów i zalogować jeszcze raz.
Webhook na moje mailsansory w supla virtual device nie reaguje:(
W "Wyzwalanie w oparciu o stan kanałów" i "Warunek wykonania: mam:
W {{state(XXX).hi or state(YYY).hi or state(ZZZ).hi or state(QQQ).hi}}
Manualne wykonanie sceny działa, lecz po zmianie stanu automatycznie się nie wykonuje.
e-talking............
Awatar użytkownika
klew
Posty: 1272
Rejestracja: czw cze 27, 2019 12:16 pm

czw paź 15, 2020 10:36 am

uchnast.michal pisze:
czw paź 15, 2020 10:18 am
fracz pisze:
śr paź 14, 2020 11:40 am
Mamy nowe skrypty, a w nich wsparcie dla hooków dla następujących funkcji:
  • czujnik temperatury i wilgotności oraz samej wilgotności
  • czujniki otwarcia wszystkich bram i okien
  • czujnik poczty
Aby skrypty dostawały informacje o zmianie stanów, należy się wylogować ze skryptów i zalogować jeszcze raz.
Webhook na moje mailsansory w supla virtual device nie reaguje:(
W "Wyzwalanie w oparciu o stan kanałów" i "Warunek wykonania: mam:
W {{state(XXX).hi or state(YYY).hi or state(ZZZ).hi or state(QQQ).hi}}
Manualne wykonanie sceny działa, lecz po zmianie stanu automatycznie się nie wykonuje.
Wylogowałeś się ze skryptów i zalogowałeś od nowa?
lukfud
Posty: 543
Rejestracja: czw lis 23, 2017 11:33 pm
Lokalizacja: Warszawa

czw paź 15, 2020 10:46 am

klew pisze:
śr wrz 30, 2020 9:37 am
lukfud pisze:
śr wrz 30, 2020 9:07 am
U mnie niestety nie działa (docker). Wygenerowałem nawet nowy token.
Wyzwalanie:

Kod: Zaznacz cały

{{state(401).on or state(402).on}}
Warunek:

Kod: Zaznacz cały

{{(state(401).on or state(402).on) and (not state(353).on or not state(354).on)}}
Warunki są spełnione i nic się nie dzieje.
webhooki działają aktualnie tylko dla włączników, oświetlenia i termometrów. Upewnij się, że 401 i 402 są tego typu
Tu faktycznie popełniłem błąd, nie doczytałem ze zrozumieniem (tylko światło w funkcji kanału)
Od wczoraj, odkąd połączyłem skrypty z cloud przez oAuth testuję na włączniku światła (kanał wirtualny) i niestety nie działa.
Awatar użytkownika
klew
Posty: 1272
Rejestracja: czw cze 27, 2019 12:16 pm

czw paź 15, 2020 10:58 am

lukfud pisze:
czw paź 15, 2020 10:46 am
Tu faktycznie popełniłem błąd, nie doczytałem ze zrozumieniem (tylko światło w funkcji kanału)
Od wczoraj, odkąd połączyłem skrypty z cloud przez oAuth testuję na włączniku światła (kanał wirtualny) i niestety nie działa.
Już zakres działania webhooków jest poszerzony.
Awatar użytkownika
PuteR
Posty: 862
Rejestracja: śr gru 06, 2017 10:07 am

czw paź 15, 2020 11:19 am

klew pisze:
czw paź 15, 2020 9:36 am
PuteR pisze:
czw paź 15, 2020 9:08 am
U mnie tak samo jak u lukfud sceny się nie wykonują 😐 no chyba że przez naciśnięcie przycisku wykonaj scene.
Masz swój serwer, czy publiczny? Jaki rodzaj i funkcja kanału? Pokaż screen z edycji sceny, aby było widać ustawienia.
Serwer mam swój. To jest scena testowa na sprawdzenie. Ale mimo tego że warunki są spełnione to światło które miało się właczyc po ich spwlnenieniu nie reaguje.
Załączniki
Screenshot_20201015-131653_Opera.jpg
Screenshot_20201015-131653_Opera.jpg (445.09 KiB) Przejrzano 43 razy
ODPOWIEDZ

Wróć do „Nowości”