Brak odświeżania stanu urządzeń

Awatar użytkownika
Lucas
Posty: 577
Rejestracja: pn lip 31, 2017 7:11 am
Lokalizacja: Chrzanów

wt sty 21, 2020 6:06 pm

Zauważyłem dzisiaj, że kiedy na czas prac wyłączyłem prąd w mieszkaniu, to stan moich modułów nie zmienił się. I w cloudzie i w aplikacji moduły widniały jako połączone i ich stan (on/off) był taki jak sprzed odłączenia zasilania. Dopiero próba zmiany stanu danego urządzenia skutkowała czerwoną kropką na tym kanale. Całkowite zamykanie aplikacji też nie odświeżało stanu modułu.
Wydaje mi się, że kiedyś odświeżanie stanu było szybkie.
8x Sonoff Basic, 1x Sonoff Touch, 2x ROW-02, 1x SRW-03, 1x SLW-01, 1x LIW-01, 1x Shelly 1v3, 2x Yunshan, 1x MoesHouse, 1x BW-SHP6, 2x Smart DGM, kilka modułów na D1 mini... i notoryczny brak czasu na więcej
GH + Trådfri + RM mini 3
elmaya
Posty: 815
Rejestracja: śr cze 27, 2018 5:48 pm
Lokalizacja: Sevilla

wt sty 21, 2020 6:15 pm

masz rację, zajmuje to 120 sekund
Awatar użytkownika
pzygmunt
Posty: 8418
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

wt sty 21, 2020 9:07 pm

Ten czas różni się w zależności firmware-u. Urządzenie może zmienić czas po którym serwer uznaje je za urządzenie offline.
elmaya
Posty: 815
Rejestracja: śr cze 27, 2018 5:48 pm
Lokalizacja: Sevilla

wt sty 21, 2020 9:37 pm

Cóż, coś nie działa dobrze.
Arduino Devo - Mam to w terminalu, ale to za 120 sekund

Kod: Zaznacz cały

Establishing connection with: svrX.supla.org (port: 2015)
Connected
Device registered (activity timeout 120 s, server version: 11, server min version: 1)
Changing activity timeout to 30
Activity timeout set to 30 s
Awatar użytkownika
klew
Posty: 831
Rejestracja: czw cze 27, 2019 12:16 pm

wt sty 21, 2020 9:58 pm

U mnie kanały zmieniają się na czerwone po 110 sekundach.
Urządzenia otrzymują z serwera przy rejestracji wartość 120 s. Po czym zmieniają ten timeout na 30 s, otrzymują odpowiedź potwierdzającą z serwera, a w rzeczywistości timeout robi się po 110 s ;)
Awatar użytkownika
pzygmunt
Posty: 8418
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

wt sty 21, 2020 10:00 pm

Sprawdzę to. Pewnie błąd po stronie serwera.
ODPOWIEDZ

Wróć do „supla-server”