Build

Pandora
Posts: 1
Joined: Mon Mar 07, 2016 6:43 pm

Mon Mar 07, 2016 6:52 pm

Witam, z czysto praktycznych względów zmuszony zostałem do rekompilacji supla-server pod CentOS7, która przebiegła bez żadnych większych problemów. Daemon uruchamia się, widziany jest z poziomu klienta Android. Problem pojawia się z poprawnie skonfigurowanym RBPi, który jest widziany przez supla-cloud, ale nie odnajduje żadnych kanałów. Co robię nie tak ?
PS. Warto by dodać dump bazy, bo przyznam musiałem się posiłkować VM do tego celu.

Dopisek.
Ręczne ustawienie funkcji w tabeli supla_dev_channel pomogło. Teraz nowe pytanie, dlaczego sam tego nie robi. Nadal mam RBPi jako unknown, rejestracja jest OK - wykrywany jako RASBPBERRY PI B+ EXTENSION 01, nadany GUID również, a status jak powyżej.
Biedronek
Posts: 17
Joined: Wed Feb 24, 2016 1:19 pm

Tue Mar 08, 2016 1:46 am

Hej,
a masz moze jakies skrypty ze stawiania serwera? Ja posciagalem wszystkie paczki, poustawialem baze itp. ale musialem i tak uruchomic VM a nie chce przekopiowywac po koleu plikow i zgadywac co jest potrzebe, tylko wolalbym wszystko ze skryptu puscic.

Na razie ulepilem cos takiego ale zabraklo mi cierpliwosci... zwlaszcze ze przy RPi to wollabym na lighttpd/nginex to puscic.

#!/bin/sh

# Assume you are on debian based OS

# MySQL
sudo apt-get install -y mysql-server
sudo apt-get install libmysql++-dev
sudo apt-get install libssl-dev

# Apache
sudo apt-get install mysql-server libapache2-mod-auth-mysql php5-mysql

# PHP
sudo apt-get install php5 libapache2-mod-php5 php5-mcrypt

# Recommendation is to work securely
sudo mysql_secure_installation

# Obtain the setup script and use it
wget https://www.supla.org/download/supla_database.zip
unzip supla_database.zip
mysql -u root -e "CREATE DATABASE supla;" -p
mysql -u root -p < supla_database.sql


# Web part
cd /var/www/html
git clone https://github.com/SUPLA/supla-cloud.git cloud

# Server
cd /etc/suple-server
openssl req -x509 -newkey rsa:2048 -keyout private.key -out cert.crt -nodes -days 365
# cat > supla.cfg
User avatar
pzygmunt
Posts: 7080
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Tue Mar 08, 2016 1:59 pm

Pandora wrote: Dopisek.
Ręczne ustawienie funkcji w tabeli supla_dev_channel pomogło. Teraz nowe pytanie, dlaczego sam tego nie robi. Nadal mam RBPi jako unknown, rejestracja jest OK - wykrywany jako RASBPBERRY PI B+ EXTENSION 01, nadany GUID również, a status jak powyżej.
Domyślnie jak urządzenie się rejestruje to nie są ustawiane funkcje. Trzeba je wybrać przez www. Są jednak wyjątki i za nie odpowiada
procedura w mysql-u o nazwie supla_on_newdevice, która ustawia funkcje przy rejestracji.

Wrzuciłem na ftp-a aktualny dump struktury bazy.
https://www.supla.org/download/supla_database.zip

W przypadku problemów sugeruję uruchomić serwer z parametrem -D tak samo urządzenie.
bicker
Posts: 345
Joined: Tue Feb 02, 2016 8:18 am

Fri Apr 15, 2016 9:32 am

Witam,
podepnę się pod temat konfiguracji.
jeśli nie tutaj to proszę o przeniesienie

chcę postawić serwer na Raspberry pi i mam pytanie czy na wyjściu Raspberry pi adresacja IP modułów jest w tej samej sieci co wejście raspberry pi,
pytam, bo zależy mi na tym aby była inna, moja sięć
10.0.0.x

a chciałbym aby esp były na adresacji
192.168.1.x

(mam nadzieje, że zrozumiale napisałem :))
User avatar
pzygmunt
Posts: 7080
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Fri Apr 15, 2016 11:15 am

Nie do końca chyba to zrozumiałem, ale może inaczej... Jaki ma być cel takiego rozwiązania ?
bicker
Posts: 345
Joined: Tue Feb 02, 2016 8:18 am

Sun Apr 17, 2016 3:20 pm

chodzi mi o to, żeby sieć wi-Fi do której podpiętą będą ESP nie była tą samą siecią jaką mam w domu.
0xFF
Posts: 308
Joined: Sat Feb 20, 2016 8:54 pm

Sun Apr 17, 2016 4:03 pm

Co w jakiej sieci umieścisz nie ma znaczenia.
Zasada jest jedna - klient musi mieć dostęp do serwera.

Zatem jak postawisz serwer SUPLA w sieci domowej, a sieć gdzie są ESP będzie miała dostęp do niej - wszystko zadziała.
User avatar
pzygmunt
Posts: 7080
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Mon Apr 18, 2016 5:59 am

Wepnij sobie osobny interfejs WiFi do RB PI który będzie dostępny tylko dla urządzeń wykonawczych. Drugi interfejs wepnij w sieć domową.
michailw
Posts: 2
Joined: Fri Jul 21, 2017 10:24 pm

Fri Jul 21, 2017 10:32 pm

Cześć,
sory za odgrzebywanie tematu, ale mam problem z buildem na właśnie Centos 7 - czyms z czym autor sobie poradził.

W katalogu supla-server/Release robię:

Code: Select all

make clean
make
Linker nie jest w stanie znaleźć mysqlclient:

Code: Select all

Building target: supla-server
Invoking: Cross G++ Linker
g++ -L/usr/include/mysql -L/usr/src/openssl/lib -pthread -lrt -o "supla-server"  ./src/accept_loop.o ./src/cdcommon.o ./src/cfg.o ./src/client.o ./src/clientchannel.o ./src/clientlocation.o ./src/datalogger.o ./src/db.o ./src/dbatabase.o ./src/device.o ./src/devicechannel.o ./src/eh.o ./src/ini.o ./src/ipcctrl.o ./src/ipcsocket.o ./src/lck.o ./src/log.o ./src/proto.o ./src/safearray.o ./src/serverconnection.o ./src/srpc.o ./src/sthread.o ./src/supla-server.o ./src/supla-socket.o ./src/svrcfg.o ./src/tools.o ./src/user.o   -lssl -lcrypto -lmysqlclient
/bin/ld: cannot find -lmysqlclient
collect2: error: ld returned 1 exit status
make: *** [supla-server] Error 1
Dodam, że mam zainstalowane mysql-devel, mysql-libs. Co musze zrobić, żeby uruchomić kompilację na Centos 7?
User avatar
pzygmunt
Posts: 7080
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Sat Jul 22, 2017 4:05 pm

Sprawdź ścieżki.
Odpal ldconfig
wyloguj się i zaloguj ponownie przed kompilacją
Post Reply