Własny serwer 2.0.2

Zybi
Posts: 1378
Joined: Sun Jun 26, 2016 4:24 pm

Fri Jul 28, 2017 8:30 pm

Próbuję "postawić" własny server w wersji v.2.0.2.
Instalacja przeszła prawidłowo, ale po wpisaniu w przeglądarce adresu serwera dostaję jedynie:

Code: Select all

<?php

use Symfony\Component\HttpFoundation\Request;

/** @var \Composer\Autoload\ClassLoader $loader */
$loader = require __DIR__ . '/../app/autoload.php';

defined('APPLICATION_ENV') || define('APPLICATION_ENV', (getenv('APPLICATION_ENV') ?: 'prod'));
include_once __DIR__ . '/../var/bootstrap.php.cache';

$kernel = new AppKernel(APPLICATION_ENV, APPLICATION_ENV == 'dev');
if (APPLICATION_ENV == 'prod') {
    $kernel->loadClassCache();
} else {
    Symfony\Component\Debug\Debug::enable();
}

//$kernel = new AppCache($kernel);

// When using the HttpCache, you need to call the method in your front controller instead of relying on the configuration parameter
//Request::enableHttpMethodParameterOverride();
$request = Request::createFromGlobals();
$response = $kernel->handle($request);
$response->send();
$kernel->terminate($request, $response);
Prośba o pomoc w uruchomieniu.
User avatar
pzygmunt
Posts: 6871
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Sat Jul 29, 2017 11:00 am

Masz wyłączone php
Zybi
Posts: 1378
Joined: Sun Jun 26, 2016 4:24 pm

Sat Jul 29, 2017 3:52 pm

Cały czas stoję w miejscu, a tak ładnie to wygląda
Attachments
zonk1.jpg
zonk1.jpg (94.57 KiB) Viewed 8924 times
User avatar
pzygmunt
Posts: 6871
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Sat Jul 29, 2017 4:01 pm

apt-get update
apt-get install libapache2-mod-php php-mysql php-curl php-intl php-pear php-mbstring php7.0-zip
Zybi
Posts: 1378
Joined: Sun Jun 26, 2016 4:24 pm

Sat Jul 29, 2017 4:25 pm

Niestety nie pomogło.
User avatar
pzygmunt
Posts: 6871
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Sat Jul 29, 2017 5:13 pm

a2enmod
Zybi
Posts: 1378
Joined: Sun Jun 26, 2016 4:24 pm

Sat Jul 29, 2017 5:57 pm

"Module rewrite already enabled"
User avatar
pzygmunt
Posts: 6871
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Sat Jul 29, 2017 6:01 pm

A php* ?
Zybi
Posts: 1378
Joined: Sun Jun 26, 2016 4:24 pm

Sat Jul 29, 2017 6:02 pm

Musisz bardziej "łopatologicznie" podpowiedzieć
User avatar
fracz
Posts: 1585
Joined: Fri Oct 28, 2016 10:56 pm
Location: Rybna

Sat Jul 29, 2017 7:08 pm

Czy na tym samym serwerze działał cloud 2.0? Jeśli tak to nic w konfiguracji systemu nie powinno być zmieniane bo "poważnych" zmian nie wprowadziliśmy.

Po tych apt-getach które napisał pzygmunt musisz zrestartować apacha

Code: Select all

service restart apache2
Jaki jest wynik komendy php -v
Post Reply