[supla-cloud development] błąd wykonania skryptu

Awatar użytkownika
Goral64
Posty: 293
Rejestracja: pt gru 27, 2019 6:22 pm

pt sty 24, 2020 11:26 am

Podczas instalacji wersji deweloperskiej serwera na Win 10 Pro 64bit pojawia się błąd przy wykonaniu polecenia:

Kod: Zaznacz cały

composer run-script webpack
Wynika on z polecenia użytego w src/Frontend/package.json

Kod: Zaznacz cały

    "build": "rm -fr ../../web/assets/dist && cross-env NODE_ENV=production webpack --hide-modules",
bo winda nie kuma polecenia rm.
Proponuję dołączyć do node.js pakiet del-cli i zmienić to polecenie na

Kod: Zaznacz cały

    "build": "del-cli -f ../../web/assets/dist && cross-env NODE_ENV=production webpack --hide-modules",
wtedy każdy system powinien to wykonać.
RPi4: Supla Cloud + Supla Scripts + Proxy + Let's Encrypt
1x MEW-01, 1x LIW-01, 2x SBW-02, 2x PNW-01, 1x ROW-01, 1x ROW-02, 1x ROW-04m,
1x Sonoff BRIDGE RF 433 (FW by Duch__)
This is only the beggining...
Awatar użytkownika
fracz
Posty: 1832
Rejestracja: pt paź 28, 2016 10:56 pm
Lokalizacja: Rybna

pt sty 24, 2020 12:49 pm

Przy standardowej instalacji gita na Windowsie podstawowe narzędzia konsolowe też są dodawane, więc powinieneś je wtedy mieć.
Awatar użytkownika
Goral64
Posty: 293
Rejestracja: pt gru 27, 2019 6:22 pm

pt sty 24, 2020 1:38 pm

fracz pisze:
pt sty 24, 2020 12:49 pm
Przy standardowej instalacji gita na Windowsie podstawowe narzędzia konsolowe też są dodawane, więc powinieneś je wtedy mieć.
OK. Sprawdziłem. Git zainstalował dodatkowe komendy w usr/bin ale nie dodał do nich ścieżki, dał tylko do cmd.
RPi4: Supla Cloud + Supla Scripts + Proxy + Let's Encrypt
1x MEW-01, 1x LIW-01, 2x SBW-02, 2x PNW-01, 1x ROW-01, 1x ROW-02, 1x ROW-04m,
1x Sonoff BRIDGE RF 433 (FW by Duch__)
This is only the beggining...
Awatar użytkownika
fracz
Posty: 1832
Rejestracja: pt paź 28, 2016 10:56 pm
Lokalizacja: Rybna

pt sty 24, 2020 3:15 pm

To musiałeś zmienić przy instalacji domyślną opcję chyba :-)

A generalnie - możesz wprowadzić tę zmianę o której piszesz i przysłać PR
Awatar użytkownika
Goral64
Posty: 293
Rejestracja: pt gru 27, 2019 6:22 pm

pt sty 24, 2020 5:59 pm

fracz pisze:
pt sty 24, 2020 3:15 pm
To musiałeś zmienić przy instalacji domyślną opcję chyba :-)
Poszło bez wydziwiania ;)
fracz pisze:
pt sty 24, 2020 3:15 pm
A generalnie - możesz wprowadzić tę zmianę o której piszesz i przysłać PR
Poszło.
RPi4: Supla Cloud + Supla Scripts + Proxy + Let's Encrypt
1x MEW-01, 1x LIW-01, 2x SBW-02, 2x PNW-01, 1x ROW-01, 1x ROW-02, 1x ROW-04m,
1x Sonoff BRIDGE RF 433 (FW by Duch__)
This is only the beggining...
ODPOWIEDZ