FOTA

User avatar
lesny8
Posts: 668
Joined: Mon Dec 11, 2017 9:43 pm

Thu Sep 20, 2018 9:30 pm

Ja mam taką wersje, sprawdź czy masz. Jeśli nie masz, to tak jak @Espablo napisał, trzeba doinstalować

Code: Select all

apt list --installed | grep libhogweed4

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libhogweed4/xenial-updates,xenial-security,now 3.2-1ubuntu0.16.04.1 amd64 [zainstalowany]

A jaką masz dystrybucję linuxa?
User avatar
slawek
Posts: 2193
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Thu Sep 20, 2018 9:36 pm

Code: Select all

slawek Release # apt list --installed | grep libhogweed4
slawek Release # 
Mam Linuxmint 17.3
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
User avatar
slawek
Posts: 2193
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Thu Sep 20, 2018 9:40 pm

Dostaję coś takiego przy instalacji ręcznej
"Błąd: zależność nie może być spełniona:libgmp10(>=2.6.0.0.)"
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
User avatar
lesny8
Posts: 668
Joined: Mon Dec 11, 2017 9:43 pm

Thu Sep 20, 2018 9:49 pm

Zrobiłeś?
lesny8 wrote:
Fri Sep 07, 2018 10:18 pm

Code: Select all

sudo apt update
sudo apt upgrade
sudo apt install libgmp-dev 
jeśli tak to sprawdź czy masz

Code: Select all

sudo apt list --installed | grep libgmp10

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libgmp10/xenial,now 2:6.1.0+dfsg-2 amd64 [zainstalowany]
User avatar
slawek
Posts: 2193
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Thu Sep 20, 2018 9:57 pm

Code: Select all

slawek Release # sudo apt list --installed | grep libgmp10
slawek Release # 
Upgrade robiłem przed instalacją
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
User avatar
lesny8
Posts: 668
Joined: Mon Dec 11, 2017 9:43 pm

Thu Sep 20, 2018 10:14 pm

Taka jest zależność pakietów dla libhogweed4

Code: Select all

apt-rdepends libhogweed4

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libhogweed4
  Depends: libc6 (>= 2.14)
  Depends: libgmp10 (>= 2:6.0.0)
  Depends: libnettle6 (= 3.2-1)
libc6
  Depends: libgcc1
libgcc1
  Depends: gcc-6-base (= 6.0.1-0ubuntu1)
  Depends: libc6 (>= 2.14)
gcc-6-base
libgmp10
  Depends: libc6 (>= 2.14)
libnettle6
  Depends: libc6 (>= 2.14)
Swoją drogą ciekawi mnie dlaczego apt nie chce zainstalować wszystkiego co potrzebne :?

Code: Select all

sudo apt install libc6 libgmp10 libnettle6
sudo apt install libhogweed4
User avatar
slawek
Posts: 2193
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Thu Sep 20, 2018 10:18 pm

Code: Select all

slawek Release # sudo apt install libc6 libgmp10 libnettle6
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
E: Nie udało się odnaleźć pakietu libnettle6
Może akurat to repozytorium jest niedostępne?
A może czas na nowe distro :)
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
User avatar
slawek
Posts: 2193
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Thu Sep 20, 2018 10:22 pm

Code: Select all

slawek Release # sudo apt install libc6 libgmp10
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
libgmp10 jest już w najnowszej wersji.
libc6 jest już w najnowszej wersji.
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 4 nieaktualizowanych.
slawek Release #
To jakie distro polecacie - będę stawiał nowe
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
User avatar
lesny8
Posts: 668
Joined: Mon Dec 11, 2017 9:43 pm

Thu Sep 20, 2018 10:44 pm

slawek wrote:
Thu Sep 20, 2018 10:22 pm
To jakie distro polecacie - będę stawiał nowe
Ja mam akurat Ubuntu 16.04.3 LTS
Poczekaj chwile z tym stawianiem :) zapodaj co masz w pliku

Code: Select all

 
/etc/apt/sources.list
Brakuje repo, w którym jest ten pakiet libnettle6
User avatar
slawek
Posts: 2193
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Thu Sep 20, 2018 10:46 pm

Sprawdzę jutro, już "przelazłem" na windę, dzięki za pomoc - idę spać...
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
Post Reply