FOTA

User avatar
slawek
Posts: 2151
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Fri Sep 21, 2018 2:52 pm

lesny8 wrote:
Thu Sep 20, 2018 10:44 pm

Poczekaj chwile z tym stawianiem :) zapodaj co masz w pliku

Code: Select all

 
/etc/apt/sources.list
Brakuje repo, w którym jest ten pakiet libnettle6
Mam tak:

Code: Select all

#deb cdrom: [Linux Mint 17.3 _Rosa_ - Release amd64 20151128]/ trusty contrib main non-free
Po

Code: Select all

apt update
dostaję coś takiego

Code: Select all

.....................
Czytanie list pakietów... Gotowe
W: Nie udało się pobrać http://archive.getdeb.net/ubuntu/dists/trusty-getdeb/InRelease  

W: Nie udało się pobrać http://archive.getdeb.net/ubuntu/dists/trusty-getdeb/Release.gpg  Nie udało się przetłumaczyć nazwy "archive.getdeb.net"

W: Nie udało się pobrać niektórych plików indeksu, zostały one zignorowane lub użyto ich starszej wersji.
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
User avatar
Espablo
Posts: 1367
Joined: Wed Jun 29, 2016 5:04 pm
Location: Oświęcim
Contact:

Fri Sep 21, 2018 3:33 pm

Ja mam Minta 19

Code: Select all

sb_release -a

No LSB modules are available.
Distributor ID:	LinuxMint
Description:	Linux Mint 19 Tara
Release:	19
Codename:	tara

Code: Select all

sudo apt list --installed | grep libgmp10

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
libgmp10/bionic,now 2:6.1.2+dfsg-2 amd64 [zainstalowany]

Code: Select all

apt-rdepends libhogweed4

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libhogweed4
  Depends: libc6 (>= 2.14)
  Depends: libgmp10 (>= 2:6.0.0)
  Depends: libnettle6 (= 3.4-1)
libc6
  Depends: libgcc1
libgcc1
  Depends: gcc-8-base (= 8-20180414-1ubuntu2)
  Depends: libc6 (>= 2.14)
gcc-8-base
libgmp10
  Depends: libc6 (>= 2.14)
libnettle6
  Depends: libc6 (>= 2.14)
Może wystarczy zaktualizować minta do 19 https://404.g-net.pl/2018/07/linux-mint-19/
Każde urządzenie elektryczne działa o wiele lepiej jeśli podłączysz je do prądu. :? :roll:
https://github.com/Espablo
User avatar
slawek
Posts: 2151
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Fri Sep 21, 2018 3:37 pm

Miałem stawiać od nowa - ale w takim razie ruszam z aktualizacją...
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
User avatar
lesny8
Posts: 508
Joined: Mon Dec 11, 2017 9:43 pm

Fri Sep 21, 2018 3:50 pm

Sławku dodaj sobie takie repo

Code: Select all

sudo add-apt-repository 'deb http://packages.linuxmint.com rosa main' 
a potem

Code: Select all

sudo apt update
zobacz czy pobierze Ci listę pakietów
User avatar
slawek
Posts: 2151
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Fri Sep 21, 2018 3:54 pm

Code: Select all

Czytanie list pakietów... Gotowe                                               
W: Nie udało się pobrać http://archive.getdeb.net/ubuntu/dists/trusty-getdeb/InRelease  

W: Nie udało się pobrać http://archive.getdeb.net/ubuntu/dists/trusty-getdeb/Release.gpg  Nie udało się przetłumaczyć nazwy "archive.getdeb.net"

W: Nie udało się pobrać niektórych plików indeksu, zostały one zignorowane lub użyto ich starszej wersji.
W: Duplicate sources.list entry http://packages.linuxmint.com/ rosa/main amd64 Packages (/var/lib/apt/lists/packages.linuxmint.com_dists_rosa_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://packages.linuxmint.com/ rosa/main i386 Packages (/var/lib/apt/lists/packages.linuxmint.com_dists_rosa_main_binary-i386_Packages)
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
User avatar
slawek
Posts: 2151
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Fri Sep 21, 2018 3:56 pm

Espablo wrote:
Fri Sep 21, 2018 3:33 pm
Może wystarczy zaktualizować minta do 19 https://404.g-net.pl/2018/07/linux-mint-19/
Z 17.3 na 19 chyba się nie da... musi być min. 18.1

EDIT: Może się uda...
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
User avatar
lesny8
Posts: 508
Joined: Mon Dec 11, 2017 9:43 pm

Fri Sep 21, 2018 4:09 pm

A co masz tu?

Code: Select all

/etc/apt/sources.list.d/official-package-repositories.list
Gdzieś wyczytałem że to jest w Linux Mint standardowa lokalizacja repo
User avatar
slawek
Posts: 2151
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Fri Sep 21, 2018 4:13 pm

Na razie mam brak dostępu - aktualizuję... ;)
EDIT:Muszę "po drodze" przejść na wersję 18 więc trochę to potrwa - odezwę się - a na razie - wielkie dzięki ;)
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
User avatar
slawek
Posts: 2151
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Fri Sep 21, 2018 10:48 pm

Na razie zostałem przy wersji 18.3, bo 19-ka (update) wali błędy (chyba coś ze stroną kodową), ale FOTA poszło dalej i mam już klucze ;)
Rozumiem, że jeśli chcę mieć np. 2 płytki, to muszę mieć następną parę kluczy?
CDN... jutro ;)
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
User avatar
lesny8
Posts: 508
Joined: Mon Dec 11, 2017 9:43 pm

Sat Sep 22, 2018 8:00 am

slawek wrote:
Fri Sep 21, 2018 10:48 pm
Rozumiem, że jeśli chcę mieć np. 2 płytki, to muszę mieć następną parę kluczy?
Nie ma takiej potrzeby. Możesz mieć jedną paprę kluczy na wszystko co masz w domu. Ale jak chcesz mieć to nikt Ci nie zabroni ;)
Post Reply