[tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

procekms89
Posts: 66
Joined: Thu Jun 28, 2018 4:21 am

Wed Apr 24, 2019 11:30 am

Zrobiłem test polegający na wygenerowaniu Tokenu z mojego konta na serwerze svr14.supla.org i wpisałem token do mojej instancji skryptów. Test skończył się prawidłowo, mogłem utworzyć konto i wszystko działa prawidłowo. A z własnej instancji nie działało.

Postanowiłem wszystko zacząć od nowa. Odtworzyłem cały system z backupu maliny który miałem przed zabawą z proxy.
Uruchomiłem proxy i ustawienia w supla-cloud i suplascripts, dodałem plik docker-compose.local.yml i wszystko ruszyło bez problemu.

Nie wiem co było zrobione inaczej, ale nareszcie działa :D :D :D
cino111
Posts: 638
Joined: Mon May 07, 2018 8:00 pm

Wed Apr 24, 2019 4:30 pm

Pozwolę sobie napisać w tym temacie bo tyczy się instalacji, a nikt tak dobrze jak lesny8 nie tłumaczy :D
Lesny8 próbowałeś może Supla Events? viewtopic.php?f=24&t=3791&p=25635&hilit=Events#p25635
Chętnie bym posterowal przyciskiem z jednego urządzenia innym urządzeniem, ale nie ogarniam tej skromnej instrukcji.
User avatar
lesny8
Posts: 745
Joined: Mon Dec 11, 2017 9:43 pm

Wed Apr 24, 2019 6:02 pm

Dziękuję @cino111 za ciepłe słowo :)
Nie miałem takiej potrzeby póki co, ale szczerze Ci powiem, że muszę to u siebie wdrożyć. Instrukcja nie jest wcale tak skomplikowana jak Ci sie wydaje. Powinno pójść gładko ;)

@procekms89 fajnie że udało Ci się w końcu wszystko uruchomić :)
cino111
Posts: 638
Joined: Mon May 07, 2018 8:00 pm

Wed Apr 24, 2019 6:06 pm

lesny8 wrote:
Wed Apr 24, 2019 6:02 pm
Dziękuję @cino111 za ciepłe słowo :)
Nie miałem takiej potrzeby póki co, ale szczerze Ci powiem, że muszę to u siebie wdrożyć. Instrukcja nie jest wcale tak skomplikowana jak Ci sie wydaje. Powinno pójść gładko ;)

@procekms89 fajnie że udało Ci się w końcu wszystko uruchomić :)
Zrobię kopię zapasową i się pobawię, ale jak byś u sobie wdrażał to bardzo przydatne było by opisanie krok po kroku po Polsku ;)
alchemik86
Posts: 2
Joined: Fri Apr 26, 2019 8:16 pm

Fri Apr 26, 2019 8:17 pm

Witam wszystkich. Próbuję zainstalować Suplę na Pi 3B+ ale stanąłem na błędzie

pi@supla:~/supla-docker $ ./supla.sh start
Starting SUPLA containers
ERROR: Couldn't connect to Docker daemon at http+docker://localhost - is it running?

If it's at a non-standard location, specify the URL with the DOCKER_HOST environment variable.

Czy ktoś jest w stanie pomóc mi rozwiązać problem?
User avatar
lesny8
Posts: 745
Joined: Mon Dec 11, 2017 9:43 pm

Fri Apr 26, 2019 9:11 pm

Podaj wynik

Code: Select all

docker -v && docker-compose -v
Esteta
Posts: 15
Joined: Wed Oct 24, 2018 9:32 pm

Fri May 10, 2019 9:23 pm

Witam,

mam świeżo zainstalowanego clouda i skrypty na malinie. Obie strony działają z certyfikatem.
Po zalogowaniua na clouda , wygenerowałem token i wygląda na to, że jest poprawny.
Niestety przy próbie stworzenia konta, mam komunikat jak na załączonym screenshot'cie:

screenshot-home.scr.sea-bielsko.pl-2019.05.10-22-32-02.png
screenshot-home.scr.sea-bielsko.pl-2019.05.10-22-32-02.png (18.3 KiB) Viewed 451 times

Stworzyłem docker-compose.local.yml z odpowiednim wpisem i dodałem go do .env.
Nie wiem tylko czy wpis "mojadomena.pl" to ma być rekord wskazujący na clouda czy skrypty?
Efekt dalej taki sam. Nie wiem czy coś przeoczyłem w instalacji czy to jakiś problem z wersjami.

Pozdrawiam.
User avatar
lesny8
Posts: 745
Joined: Mon Dec 11, 2017 9:43 pm

Fri May 10, 2019 9:34 pm

Wpis mojadomena.pl dotyczy Cloud.
Po każdej zmianie w .env albo plikach .yml musisz zrobić restart skryptów.
Esteta
Posts: 15
Joined: Wed Oct 24, 2018 9:32 pm

Fri May 10, 2019 10:05 pm

Dla pewności zrobiłem jeszcze raz restart supli i skryptów, ale sytuacja bez zmian :(
User avatar
lesny8
Posts: 745
Joined: Mon Dec 11, 2017 9:43 pm

Sat May 11, 2019 8:08 pm

Sprawdź wszystko dwa razy. To musi działać.
Post Reply