Page 24 of 36

Re: [tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

Posted: Wed May 22, 2019 5:27 pm
by superprzemo
Faktycznie nie zmieniłem standalone na proxy, teraz mam takie coś:

Code: Select all

pi@raspberrypi:~ $ ./supla-docker/supla.sh start
Starting SUPLA containers
Starting supla-db ... done
Creating supla-cloud ... done
Creating supla-server ...

ERROR: for supla-server  UnixHTTPConnectionPool(host='localhost', port=None): Read timed out. (read timeout=60)

ERROR: for supla-server  UnixHTTPConnectionPool(host='localhost', port=None): Read timed out. (read timeout=60)
ERROR: An HTTP request took too long to complete. Retry with --verbose to obtain debug information.
If you encounter this issue regularly because of slow network conditions, consider setting COMPOSE_HTTP_TIMEOUT to a higher value (current value: 60).

Re: [tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

Posted: Wed May 22, 2019 10:15 pm
by lesny8
Nigdy nie widziałem takiego błędu. W sieci znalazłem takie rozwiązania, spróbuj

Code: Select all

sudo service docker restart
albo

Code: Select all

COMPOSE_HTTP_TIMEOUT=120 docker-compose up

Re: [tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

Posted: Thu May 23, 2019 6:42 pm
by superprzemo
Postanowiłem wgrać wszystko od nowa, ale znowu zaciąłem się na uruchamianiu kontenerów:

Code: Select all

pi@raspberrypi:~ $ ./supla-docker/supla.sh start
Starting SUPLA containers
Starting supla-db ... done
Starting supla-cloud ... done
Starting supla-server ... error

ERROR: for supla-server  Cannot start service supla-server: driver failed progra                                                                             mming external connectivity on endpoint supla-server (db682672f6089a001f694c937a                                                                             20e78884d8a3aaefa7882dec0c0ffc64d9c557): Bind for 0.0.0.0:2016 failed: port is a                                                                             lready allocated

ERROR: for supla-server  Cannot start service supla-server: driver failed progra                                                                             mming external connectivity on endpoint supla-server (db682672f6089a001f694c937a                                                                             20e78884d8a3aaefa7882dec0c0ffc64d9c557): Bind for 0.0.0.0:2016 failed: port is a                                                                             lready allocated
ERROR: Encountered errors while bringing up the project.

Próbowałem kilka razy wykonać to polecenie, ale zawsze kończyło się tak samo :(

Re: [tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

Posted: Thu May 23, 2019 7:26 pm
by lesny8
Dziwnie to wygląda.
Teraz masz problem podczas pobierania warstw obrazu. Albo masz problem z połączeniem internetowym, albo problem jest z kartą pamięci.

Re: [tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

Posted: Thu May 23, 2019 8:39 pm
by superprzemo
Za którymś razem poszło dalej (w ruterze zmieniłem DNS na ISP), po wpisaniu komend:

Code: Select all

export DOCKER_CLIENT_TIMEOUT=120
export COMPOSE_HTTP_TIMEOUT=120

teraz zwraca mi takie coś:

Code: Select all

pi@raspberrypi:~ $ ./supla-docker/supla.sh start
Starting SUPLA containers
Starting supla-db ... done
Starting supla-cloud ... done
Starting supla-server ... error

ERROR: for supla-server  Cannot start service supla-server: driver failed programming external connectivity on endpoint supla-server (db682672f6089a001f694c937a20e78884d8a3aaefa7882dec0c0ffc64d9c557): Bind for 0.0.0.0:2016 failed: port is already allocated

ERROR: for supla-server  Cannot start service supla-server: driver failed programming external connectivity on endpoint supla-server (db682672f6089a001f694c937a20e78884d8a3aaefa7882dec0c0ffc64d9c557): Bind for 0.0.0.0:2016 failed: port is already allocated
ERROR: Encountered errors while bringing up the project.
Zastanawiam się czy w ogóle RPi B jest zdolne pociągnąć serwer SUPLA.
Jakieś pomysły co mogę jeszcze zrobić żeby to zatrybiło?

Re: [tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

Posted: Thu May 23, 2019 8:58 pm
by lesny8
Teraz masz błąd, który mówi o tym, że port 2016 jest już zajęty.
Pokaż

Code: Select all

docker ps

Re: [tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

Posted: Fri May 24, 2019 4:31 pm
by superprzemo
To mam po docker ps:

Code: Select all

pi@raspberrypi:~ $ docker ps
CONTAINER ID        IMAGE                                                   COMMAND                  CREATED             STATUS              PORTS               NAMES
183efed3efc1        supla/supla-cloud:arm32v6                               "docker-php-entrypoi…"   25 hours ago        Up 30 seconds       80/tcp              supla-cloud
6d005fe52413        hypriot/rpi-mysql:5.5                                   "/entrypoint.sh mysq…"   25 hours ago        Up 34 minutes       3306/tcp            supla-db
056731cec1b5        wouterds/rpi-docker-gen                                 "/usr/local/bin/dock…"   27 hours ago        Up 27 minutes                           nginx-gen
fee1e7d46f34        wouterds/rpi-docker-letsencrypt-nginx-proxy-companion   "/bin/bash /app/entr…"   27 hours ago        Up 27 minutes                           nginx-letsencrypt

Wydaje mi się że RPi, które mam jest za słabe na serwer SUPLA, ma tylko 128 RAMu.
Próbowałem jeszcze raz od nowa wgrać na Serwer SUPLA, dopiasałem w pliku: docker-compose-multiple-networks.yml arm32v6/nginx:alpine i za którymś razem serwer SUPLA się wgrał (kilka razy wyskakiwały mi błędy, o których pisałem wcześniej), natomiast supla-scripts nie dało się wgrać (albo RPi się zawieszał, albo zgłaszało błędy). Mogłem uruchomić supla-scripts ale wówczas supla-serwer nie chciał się uruchomić.
Instalowanie SUPLA na tym sprzęcie odpuszczam i teraz pytanie, jaką wersję RPi polecacie pod serwer SUPLA?
Czy po udanej instalacji SUPLA po restarcie systemu wszystko powinno się samo uruchomić?

Re: [tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

Posted: Tue Jun 18, 2019 8:38 pm
by superprzemo
Witam,
Jestem po instalacji SUPLA oraz SUPLA-Scripts (tryb standalone) na RPI:

Code: Select all

pi@raspberrypi:~ $ docker ps
CONTAINER ID        IMAGE                        COMMAND                  CREATED             STATUS              PORTS                                      NAMES
79c9e727b905        supla/supla-server:arm32v7   "/usr/bin/server-ent…"   13 minutes ago      Up 13 minutes       0.0.0.0:2015-2016->2015-2016/tcp           supla-server
165fd6700293        supla/supla-cloud:arm32v7    "docker-php-entrypoi…"   13 minutes ago      Up 13 minutes       0.0.0.0:80->80/tcp, 0.0.0.0:443->443/tcp   supla-cloud
8ca856580092        hypriot/rpi-mysql:5.5        "/entrypoint.sh mysq…"   14 minutes ago      Up 13 minutes       3306/tcp                                   supla-db
25aba2b50449        suplascripts_suplascripts    "docker-php-entrypoi…"   6 days ago          Up 25 minutes       0.0.0.0:90->80/tcp, 0.0.0.0:453->443/tcp   suplascripts
b270a39b5c94        hypriot/rpi-mysql:5.5        "/entrypoint.sh mysq…"   6 days ago          Up 25 minutes       3306/tcp                                   suplascripts-db
RPI jest pod adresem lokalnym 192.168.1.45, SUPLA ma port HTTPS:80, natomiast SUPLA-Scripts ma HTTPS:90.
Mogę się zalogować do SUPLI, natomiast mam problemy z połączeniem SUPLA-Scripts za pomocą tokena (zrzuty z załączniku):

Poniżej logi:

Code: Select all

pi@raspberrypi:~ $ docker logs --tail=50 suplascripts

Refreshing tokens of users: 0

Refreshing tokens of users: 0

Refreshing tokens of users: 0

Refreshing tokens of users: 0


172.19.0.3:80 192.168.1.136 - - [18/Jun/2019:20:26:25 +0000] "GET /login?mode=token HTTP/1.1" 200 799 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.19.0.3:80 192.168.1.136 - - [18/Jun/2019:20:26:27 +0000] "GET /api/info HTTP/1.1" 200 413 "http://192.168.1.45:90/login?mode=token" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.19.0.3:80 192.168.1.136 - - [18/Jun/2019:20:26:28 +0000] "GET /favicon.ico HTTP/1.1" 200 1450 "http://192.168.1.45:90/login?mode=token" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.19.0.3:80 192.168.1.136 - - [18/Jun/2019:20:26:31 +0000] "PATCH /api/tokens/personal HTTP/1.1" 200 339 "http://192.168.1.45:90/login?mode=token" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.19.0.3:80 192.168.1.136 - - [18/Jun/2019:20:26:45 +0000] "POST /api/tokens/new HTTP/1.1" 503 281 "http://192.168.1.45:90/login?mode=token" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
pi@raspberrypi:~ $ docker logs --tail=50 suplascripts-db
190612  6:34:59 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
190612  6:34:59 [Note] mysqld (mysqld 5.5.60-0+deb7u1) starting as process 1 ...
190612  6:34:59 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
190612  6:34:59 [Note] Plugin 'FEDERATED' is disabled.
190612  6:34:59 InnoDB: The InnoDB memory heap is disabled
190612  6:34:59 InnoDB: Mutexes and rw_locks use GCC atomic builtins
190612  6:34:59 InnoDB: Compressed tables use zlib 1.2.7
190612  6:34:59 InnoDB: Using Linux native AIO
190612  6:34:59 InnoDB: Initializing buffer pool, size = 128.0M
190612  6:34:59 InnoDB: Completed initialization of buffer pool
190612  6:34:59 InnoDB: highest supported file format is Barracuda.
190612  6:35:00  InnoDB: Waiting for the background threads to start
190612  6:35:01 InnoDB: 5.5.60 started; log sequence number 2110916
190612  6:35:01 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
190612  6:35:01 [Note]   - '0.0.0.0' resolves to '0.0.0.0';
190612  6:35:01 [Note] Server socket created on IP: '0.0.0.0'.
190612  6:35:01 [Note] Event Scheduler: Loaded 0 events
190612  6:35:01 [Note] mysqld: ready for connections.
Version: '5.5.60-0+deb7u1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Debian)
190618  8:01:41 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
190618  8:01:41 [Note] mysqld (mysqld 5.5.60-0+deb7u1) starting as process 1 ...
190618  8:01:41 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
190618  8:01:41 [Note] Plugin 'FEDERATED' is disabled.
190618  8:01:41 InnoDB: The InnoDB memory heap is disabled
190618  8:01:41 InnoDB: Mutexes and rw_locks use GCC atomic builtins
190618  8:01:41 InnoDB: Compressed tables use zlib 1.2.7
190618  8:01:41 InnoDB: Using Linux native AIO
190618  8:01:41 InnoDB: Initializing buffer pool, size = 128.0M
190618  8:01:41 InnoDB: Completed initialization of buffer pool
190618  8:01:41 InnoDB: highest supported file format is Barracuda.
190618  8:01:43  InnoDB: Waiting for the background threads to start
190618  8:01:44 InnoDB: 5.5.60 started; log sequence number 2115300
190618  8:01:44 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
190618  8:01:44 [Note]   - '0.0.0.0' resolves to '0.0.0.0';
190618  8:01:44 [Note] Server socket created on IP: '0.0.0.0'.
190618  8:01:44 [Note] Event Scheduler: Loaded 0 events
190618  8:01:44 [Note] mysqld: ready for connections.
Version: '5.5.60-0+deb7u1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Debian)
pi@raspberrypi:~ $ docker logs --tail=50 supla-cloud
Client registration expiration date - cleared: 0
I/O Device registration expiration date - cleared: 0
supla:clean:disable-demo-client-apps: RUN:
Clients to disable: 0
supla:clean:passed-io-client-registration-dates: RUN:
Client registration expiration date - cleared: 0
I/O Device registration expiration date - cleared: 0
supla:clean:disable-demo-client-apps: RUN:
Clients to disable: 0
supla:clean:passed-io-client-registration-dates: RUN:
Client registration expiration date - cleared: 0
I/O Device registration expiration date - cleared: 0
supla:clean:disable-demo-client-apps: RUN:
Clients to disable: 0
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:25:55 +0000] "POST /api/webapp-auth HTTP/1.1" 200 2523 "https://192.168.1.45/login" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:25:57 +0000] "GET /api/users/current HTTP/1.1" 200 737 "https://192.168.1.45/login" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:25:57 +0000] "GET /api/locations?include=accessids,password HTTP/1.1" 200 581 "https://192.168.1.45/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:25:57 +0000] "GET /assets/img/icons/favicon.ico HTTP/1.1" 200 1479 "https://192.168.1.45/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:25:57 +0000] "GET /assets/img/step-1.svg HTTP/1.1" 200 3987 "https://192.168.1.45/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:25:57 +0000] "GET /assets/img/step-2.svg HTTP/1.1" 200 1979 "https://192.168.1.45/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:25:58 +0000] "GET /assets/img/icons/favicon.ico HTTP/1.1" 200 1479 "https://192.168.1.45/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:25:57 +0000] "GET /api/server-info HTTP/1.1" 200 710 "https://192.168.1.45/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:26:02 +0000] "GET /assets/img/icons/favicon.ico HTTP/1.1" 200 1479 "https://192.168.1.45/integrations/authorized" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:26:02 +0000] "GET /assets/img/icons/favicon.ico HTTP/1.1" 200 1479 "https://192.168.1.45/integrations/authorized" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:26:02 +0000] "GET /api/oauth-authorized-clients?include=client HTTP/1.1" 200 306 "https://192.168.1.45/integrations/authorized" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
supla:clean:passed-io-client-registration-dates: RUN:
Client registration expiration date - cleared: 0
I/O Device registration expiration date - cleared: 0
supla:clean:disable-demo-client-apps: RUN:
Clients to disable: 0
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:26:04 +0000] "GET /assets/img/icons/favicon.ico HTTP/1.1" 200 1479 "https://192.168.1.45/integrations/tokens" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:26:04 +0000] "GET /assets/img/icons/favicon.ico HTTP/1.1" 200 1479 "https://192.168.1.45/integrations/tokens" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:26:04 +0000] "GET /api/oauth-personal-tokens HTTP/1.1" 200 431 "https://192.168.1.45/integrations/tokens" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:26:06 +0000] "DELETE /api/oauth-personal-tokens/23 HTTP/1.1" 204 301 "https://192.168.1.45/integrations/tokens" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 192.168.1.136 - - [18/Jun/2019:20:26:17 +0000] "POST /api/oauth-personal-tokens HTTP/1.1" 201 713 "https://192.168.1.45/integrations/tokens" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36 Avast/74.0.1376.132"
172.18.0.3:443 172.18.0.1 - - [18/Jun/2019:20:26:31 +0000] "GET /api/token-info HTTP/1.1" 200 1837 "-" "-"
172.18.0.3:443 172.18.0.1 - - [18/Jun/2019:20:26:31 +0000] "GET /api/users/current HTTP/1.1" 200 2093 "-" "-"
172.18.0.3:443 172.18.0.1 - - [18/Jun/2019:20:26:45 +0000] "GET /api/token-info HTTP/1.1" 200 1837 "-" "-"
172.18.0.3:443 172.18.0.1 - - [18/Jun/2019:20:26:45 +0000] "GET /api/users/current HTTP/1.1" 200 2093 "-" "-"
172.18.0.3:443 172.18.0.1 - - [18/Jun/2019:20:26:46 +0000] "GET /api/v2.3.0/iodevices?include=channels,connected,state HTTP/1.1" 200 1686 "-" "-"
supla:clean:passed-io-client-registration-dates: RUN:
Client registration expiration date - cleared: 0
I/O Device registration expiration date - cleared: 0
supla:clean:disable-demo-client-apps: RUN:
Clients to disable: 0
supla:clean:passed-io-client-registration-dates: RUN:
Client registration expiration date - cleared: 0
I/O Device registration expiration date - cleared: 0
supla:clean:disable-demo-client-apps: RUN:
Clients to disable: 0
pi@raspberrypi:~ $ docker logs --tail=50 supla-server
2019-06-18 08:13:34,354 CRIT Supervisor running as root (no user in config file)
2019-06-18 08:13:34,361 INFO supervisord started with pid 1
2019-06-18 08:13:35,366 INFO spawned: 'supla-scheduler' with pid 11
2019-06-18 08:13:35,371 INFO spawned: 'supla-server' with pid 12
INFO[1560845615.406004] Scheduler version 2.3.3
INFO[1560845615.407499] Started at Tue Jun 18 08:13:35 2019
INFO[1560845615.411440] Server version 2.3.8 [Protocol v10]
INFO[1560845615.411643] Started at Tue Jun 18 08:13:35 2019
INFO[1560845615.440987] SSL version: OpenSSL 1.1.0j  20 Nov 2018
2019-06-18 08:13:36,443 INFO success: supla-scheduler entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2019-06-18 08:13:36,485 INFO success: supla-server entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
INFO[1560870177.837162] Connection accepted: 165.227.180.210:58998 ClientSD: 12 Secure: 1
INFO[1560880869.138938] Connection accepted: 192.168.1.205:41426 ClientSD: 15 Secure: 1
INFO[1560880869.245847] Cipher: ECDHE-RSA-AES256-GCM-SHA384, ClientSD: 15
INFO[1560880882.238955] Connection accepted: 192.168.1.205:41427 ClientSD: 14 Secure: 1
INFO[1560880882.329177] Cipher: ECDHE-RSA-AES256-GCM-SHA384, ClientSD: 14
INFO[1560880885.707375] Connection accepted: 192.168.1.205:41428 ClientSD: 15 Secure: 1
INFO[1560880885.783364] Cipher: ECDHE-RSA-AES256-GCM-SHA384, ClientSD: 15
INFO[1560880922.30538] Connection accepted: 192.168.1.205:41429 ClientSD: 14 Secure: 1
INFO[1560880922.89129] Cipher: ECDHE-RSA-AES256-GCM-SHA384, ClientSD: 14
INFO[1560881003.596320] Connection accepted: 192.168.1.205:41430 ClientSD: 13 Secure: 1
INFO[1560881003.671967] Cipher: ECDHE-RSA-AES256-GCM-SHA384, ClientSD: 13
INFO[1560881003.742786] Client registered. ClientSD: 13 Protocol Version: 10
Pytanie do znawców, czy postawienie SUPLA oraz SUPLA-Scripts na jednym RPI w sieci lokalnej jest możliwe, żeby można było podłączyć SUPLA-Scripts pod SUPLA za pomocą tokena?

Jeżeli tak, to co źle robię, czego nie mogę się połączyć za pomocą tokena?

Re: [tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

Posted: Tue Jun 18, 2019 9:27 pm
by lesny8
superprzemo wrote:
Tue Jun 18, 2019 8:38 pm
Witam,
Jestem po instalacji SUPLA oraz SUPLA-Scripts (tryb standalone) na RPI:
[...]
A dlaczego nie proxy? Problem portów zniknie.
superprzemo wrote:
Tue Jun 18, 2019 8:38 pm
[...]
Pytanie do znawców, czy postawienie SUPLA oraz SUPLA-Scripts na jednym RPI w sieci lokalnej jest możliwe, żeby można było podłączyć SUPLA-Scripts pod SUPLA za pomocą tokena?

Jeżeli tak, to co źle robię, czego nie mogę się połączyć za pomocą tokena?
Tak
Sprawdź to.
Tylko dodaj nr portu po dwukropku np.:192.168.0.2:453

Re: [tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

Posted: Wed Jun 19, 2019 6:54 am
by superprzemo
A dlaczego nie proxy? Problem portów zniknie.
Założenie jest takie żeby wszystko działało w sieci lokalnej bez względu na to czy jest sieć podpięta do WAN (zmniejszenie ryzyka awarii systemu z powodu braku internetu).
Tak
Sprawdź to.
Tylko dodaj nr portu po dwukropku np.:192.168.0.2:453
Nie mam takiego pliku w katalogu supla-docker. Mam go utworzyć i podać w nim adres maliny czyli 192.168.1.45, czy ten co podałeś 192.168.0.2?