SUPLA - Raspberry Pi - obsługa przekażników

Awatar użytkownika
pzygmunt
Posty: 7781
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

pn lip 08, 2019 7:36 pm

Nie mam teraz pod ręką kompa. Jeszcze odczyt musisz zmienić i ikony będą poprawne
vcompl
Posty: 156
Rejestracja: pn kwie 11, 2016 1:32 pm

wt lip 09, 2019 10:27 am

Zmieniam logikę w linii

*hi = value[0] == 1 ? 1 : 0;

z funkcji char channelio_get_hi_value(unsigned char number, char *hi)

i nie ma to żadnego wpływu na wyświetlanie się ikon włącznika w aplikacji Android.

później ta funkcja jest zastosowana w ipcctrl.cpp ale za mało wiem jak ta aplikacja działa aby to zdebugować skutecznie.

@pzygmunt - ponawiam jednak prośbę o dokładne wskazanie miejsc w kodzie gdzie zmiana wpłynie na zachowanie się ikon
Awatar użytkownika
pzygmunt
Posty: 7781
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

wt lip 09, 2019 10:34 am

https://github.com/SUPLA/supla-core/blo ... pio.c#L186

Kod: Zaznacz cały

*value = !(v[0] == 49 ? 1 : 0);
https://github.com/SUPLA/supla-core/blo ... pio.c#L174

Kod: Zaznacz cały

v[0] = !(value == 49 || value == 1) ? 49 : 48;
vcompl
Posty: 156
Rejestracja: pn kwie 11, 2016 1:32 pm

wt lip 09, 2019 11:57 am

Bardzo dziękuję :)

Uff, zadziałało.

A więc podsumowując:

odwróconą logikę dla supla-dev wersja dla raspberry pi wprowadzamy na samym poziomie sterowania gpio

https://github.com/SUPLA/supla-core/blo ... pio.c#L186
https://github.com/SUPLA/supla-core/blo ... pio.c#L174

a nie tu

"Musisz zmienić dla set i get.
https://github.com/SUPLA/supla-core/blo ... -io.c#L980
https://github.com/SUPLA/supla-core/blo ... io.c#L1097"
Awatar użytkownika
pzygmunt
Posty: 7781
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

wt lip 09, 2019 12:01 pm

Niekoniecznie. Rozwiązań jest kilka. Najprościej na poziomie gpio.
ODPOWIEDZ