Supla Cloud na Raspberry Pi 4

Polthom
Posty: 5
Rejestracja: ndz gru 22, 2019 5:51 pm

pn gru 30, 2019 1:41 pm

Oczywiście to ustawienie też testowałem. Niestety jak widać to jest znikoma ilość informacji. Na tych ustawieniach to nawet Malina się nie wzruszyła.
lukfud
Posty: 140
Rejestracja: czw lis 23, 2017 11:33 pm
Lokalizacja: Warszawa

pn gru 30, 2019 2:29 pm

Polthom pisze:
pn gru 30, 2019 1:41 pm
Oczywiście to ustawienie też testowałem. Niestety jak widać to jest znikoma ilość informacji. Na tych ustawieniach to nawet Malina się nie wzruszyła.
Zawartość mojego pliku wpa_supplicant.conf

Kod: Zaznacz cały

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=PL

network={
        ssid="xxx"
        psk="yyy"
}
Zauważyłem, że jak miałem na routerze ustawione "AC only" to malina nie chciała się połączyć, przestawiłem na "N/AC" i śmiga bez problemu.
.newbie
Polthom
Posty: 5
Rejestracja: ndz gru 22, 2019 5:51 pm

pn gru 30, 2019 7:59 pm

U mnie w routerze nawet nie ma takich ustawień. Ma już 10 lat. Ale dziwne, że działa na czystym raspbianie lite a na tym z serwerem supli od djack2017 nie działa. Trzeba będzie korzystać tylko na LAN. Szkoda, bo miałem plan, aby Malinę włożyć na szynę DIN do szafki a tak to lipa niestety.
Awatar użytkownika
Goral64
Posty: 129
Rejestracja: pt gru 27, 2019 6:22 pm

pn sty 06, 2020 11:39 am

Instalacja supli na RPi4B przeszła w miarę sprawnie. Teraz działa prawie wszystko.
Natomiast nie mogę zautoryzować tokena z supla-cloud w supla-scripts :(
Wyczytałem, że to zadziała tylko jeśli jest podpięte jakieś urządzenie. Dodałem urządzenie typu sensor, ale dalej token nie działa. Może wymagane jest urządzenie sterujące a nie odczytujące?
1x MEW-01, 1x PNW-01, 1x ROW-02
This is only the beggining...
michallus
Posty: 2
Rejestracja: wt sty 07, 2020 9:41 am

śr sty 08, 2020 3:31 pm

Połączenie CLOUD <->Scripts musi być po https.
9x SRW-01
3xSonoff Mini soft 2.8.3
1xSonoff Basic + DS18B20
Cloud na RPI 4b+
Awatar użytkownika
Goral64
Posty: 129
Rejestracja: pt gru 27, 2019 6:22 pm

śr sty 08, 2020 11:10 pm

michallus pisze:
śr sty 08, 2020 3:31 pm
Połączenie CLOUD <->Scripts musi być po https.
Z przeglądarki działa po https zarówno link do chmury jak i link do scripts. Instalacja jest w trybie proxy (wykonana krok po kroku wg instrukcji z tego forum). Wszystkie kontenery dockera działają. Niestety, nie można się zalogować tokenem. Może gdzieś znajdę logi, które mi pomogą namierzyć problem? Może jak w innym poście wyczytałem, trzeba ustawić proxy https dla scripts, tylko nie mam pojęcia gdzie?
1x MEW-01, 1x PNW-01, 1x ROW-02
This is only the beggining...
lukfud
Posty: 140
Rejestracja: czw lis 23, 2017 11:33 pm
Lokalizacja: Warszawa

czw sty 09, 2020 9:41 am

Powiedzcie proszę,

Czy jest możliwość wykorzystania maliny jako serwer i zarazem urządzenie wykonawcze?
Mam 9 kanałów na ESP-01, które wykorzystuję do skryptów. Chciałbym je przenieść na raspberry i zrezygnować z dodatkowego ESP.
.newbie
Awatar użytkownika
pzygmunt
Posty: 7690
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

czw sty 09, 2020 10:04 am

Jest taka możliwość. Musisz dodać supla_dev
lukfud
Posty: 140
Rejestracja: czw lis 23, 2017 11:33 pm
Lokalizacja: Warszawa

czw sty 09, 2020 10:45 am

pzygmunt pisze:
czw sty 09, 2020 10:04 am
Jest taka możliwość. Musisz dodać supla_dev
Dziękuję ;)

Co mogę z tym zrobić?

Kod: Zaznacz cały

ERR[1578566410.144833] Can't set GPIO port parameters. Port number 27
Udało się, po 3-4 uruchomieniu błąd się już nie pojawił. Rejestracja poprawna, kanał działa :)
.newbie
ODPOWIEDZ