Scena - wyjście z domu, wyłączanie telewizora, powrót, włączanie

dead_beat
Posty: 15
Rejestracja: ndz maja 19, 2019 10:30 pm

pt lut 21, 2020 1:45 am

Hejka dziś bawiąc się suplą stworzyłem coś takiego:
w routerze Mikrotik > System > Scheduler tworzymy klikamy plusik aby dodać nowy i uzupełniamy...
wylacz-tv.png
wylacz-tv.png (34.52 KiB) Przejrzano 250 razy

Kod: Zaznacz cały

{
  :local exists [/int wire reg find mac-address="00:00:00:00:00:00"];
  :local exists2 [/int wire reg find mac-address="11:11:11:11:11:11"];
  :local exists3 [/int wire reg find mac-address="22:22:22:22:22:22"];
  :local exists4 [/int wire reg find mac-address="33:33:33:33:33:33"];
  :if ($exists!="" or $exists2!="" or $exists3!="" or $exists4!="") do={
     /tool fetch url="https://svr21.supla.org/direct/XXXX/turn-on" keep-result=no
   }  else={
            /tool fetch url="https://svr21.supla.org/direct/XXXX/turn-off" keep-result=no
      }  
}
Jest to lepsze rozwiązanie niż korzystanie z samego netwach, ponieważ iPhone nie da się pingować i skrypty się nie wykonują.
Scheduler z małym opóźnieniem, ale po wykryciu adresu MAC w sieci / lub jego braku włączy lub wyłączy urządzenie.
Nie trzeba też korzystać z aplikacji, żeby włączyć lub wyłączyć dany przełącznik, zastosowałem to też przy drukarce.
ODPOWIEDZ