SUPLA Events - "zdarzenia"

Awatar użytkownika
michael
Posty: 1177
Rejestracja: śr lis 09, 2016 8:00 am
Lokalizacja: Wojkowice

śr gru 18, 2019 7:19 am

Może brak praw do uruchamiania

Kod: Zaznacz cały

chmod +x install.sh
./install.sh
Kabel ucięty na miarę zawsze jest za krótki...
Awatar użytkownika
PuteR
Posty: 913
Rejestracja: śr gru 06, 2017 10:07 am

śr gru 18, 2019 7:34 am

michael pisze:
śr gru 18, 2019 7:19 am
Może brak praw do uruchamiania

Kod: Zaznacz cały

chmod +x install.sh
./install.sh
nadanie uprawnień pomogło, ale niestety dalej coś nie tak

Kod: Zaznacz cały

pi@raspberrypi:~ $ chmod +x install.sh
pi@raspberrypi:~ $ ./install.sh
Instalacja skryptu zdarzeń dla Supla...

 // Warming up the cache for the prod environment with debug                    
 // false                                                                       

 [OK] Cache for the "prod" environment (debug=false) was successfully warmed.   

./install.sh: linia 17: /share/Container/container-station-data/application/supla]: Nie ma takiego pliku ani katalogu
Done.
Awatar użytkownika
michael
Posty: 1177
Rejestracja: śr lis 09, 2016 8:00 am
Lokalizacja: Wojkowice

śr gru 18, 2019 8:03 am

Fakt :?
Moje niedopatrzenie. Musisz ręcznie teraz zrestartować kontenery z Suplą.
Wejdź do katalogu z supla-docker i

Kod: Zaznacz cały

./supla.sh restart
Teoretycznie powinno Ci wszystko śmigać ;]
Kabel ucięty na miarę zawsze jest za krótki...
Awatar użytkownika
PuteR
Posty: 913
Rejestracja: śr gru 06, 2017 10:07 am

śr gru 18, 2019 8:48 am

No niestety dalej nie działa 😐 chyba "zdarzenia" nie dla mnie.
Maxio
Posty: 19
Rejestracja: sob mar 21, 2020 11:56 am

pt maja 01, 2020 3:16 pm

podepnę się pod temat, z góry dziękuję

jak postępować z instalacją w przypadku debian;a jak po poleceniu ./supla.sh start otrzymuje nie znaleziono polecenia ?
chmod +x jest, docker -v jest docker-compose -v :not found.
prosze o porade
piotr.bieda@post.pl
Posty: 22
Rejestracja: pt lis 15, 2019 7:07 pm

sob lis 21, 2020 9:50 am

Cześć,

Chciałem zaktualizować moją Suplę Scipts z wersji 3.2.0 do najnowszej.

Przy próbie upgrade-u pojawiają się następujące błędy, ktoś pomoże? :)

pi@raspberrypi:~/supla-scripts $ git pull
Updating 82494ae..cc03de2
error: Your local changes to the following files would be overwritten by merge:
backend/app/authorization/JwtAndBasicAuthorizationMiddleware.php
backend/app/commands/ClearDbLogsCommand.php
backend/app/commands/DispatchTimeScenesExecutionCommand.php
backend/app/commands/SendMetricsGaugesCommand.php
backend/app/commands/SuplaScriptsManager.php
backend/composer.json
backend/composer.lock
backend/controllers/ScenesController.php
backend/controllers/TokensController.php
backend/controllers/UsersController.php
backend/index.php
backend/models/User.php
backend/models/notification/Notification.php
backend/models/scene/FeedbackInterpolator.php
backend/models/scene/FeedbackTwigExtension.php
backend/models/scene/Scene.php
backend/models/scene/SceneExecutor.php
backend/models/supla/SuplaApiCached.php
backend/models/supla/SuplaApiClientWithOAuthSupport.php
backend/models/thermostat/ThermostatRoomConfig.php
classic/update.sh
docker/Dockerfile
docker/utils/crontab
docs/Installation-classic.md
frontend/app/common/navbar/navbar.html
frontend/app/logs/logs-table.coffee
frontend/app/notifications/form/notification-form.html
frontend/app/notifications/notifications-page.html
frontend/app/routes.coffee
frontend/app/scenes/details/scene-details-page.html
frontend/app/scenes/feedback/feedback-field.coffee
frontend/app/scenes/feedback/feedback-interpolation.coffee
frontend/app/scenes/feedback/feedback-interpolation.html
frontend/app/scenes/form/scene-form.html
frontend/app/scenes/scenes-page.html
frontend/app/user/account-page.html
frontend/app/user/details/account-details.html
frontend/app/user/login-form/login-view.scss
frontend/app/user/login-form/login-with-supla.html
frontend/package-lock.json
frontend/package.json
package-lock.json
package.json
Please commit your changes or stash them before you merge.
error: The following untracked working tree files would be overwritten by merge:
backend/app/commands/ExecuteIntervalScenesCommand.php
backend/app/commands/ExecuteSceneCommand.php
backend/controllers/StateLogsController.php
backend/controllers/StateWebhookController.php
backend/database/migrations/20200514210622_scene_trigger.php
backend/database/migrations/20200515215427_scene_crontab.php
backend/database/migrations/20200515222927_scene_pushover.php
backend/database/migrations/20200516004133_user_webhooks.php
backend/database/migrations/20200519224717_state_logs.php
backend/database/migrations/20200520170542_scene_limit.php
backend/database/migrations/20201031102553_state_logs_indexes.php
backend/models/log/StateLogEntry.php
backend/models/scene/NotificationSender.php
backend/models/supla/ChannelFunction.php
docker/docker-compose.expose.yml
frontend/app/scenes/notifications/scene-notification-form.coffee
frontend/app/scenes/notifications/scene-notification-form.html
frontend/app/scenes/notifications/scene-notifications-field.coffee
frontend/app/scenes/notifications/scene-notifications-field.html
frontend/app/state-logs/state-logs-view.coffee
frontend/app/state-logs/state-logs-view.html
frontend/app/state-logs/state-logs.coffee
frontend/app/state-logs/state-logs.scss
frontend/app/user/pushover-credentials/pushover-credentials.coffee
frontend/app/user/pushover-credentials/pushover-credentials.html
public/img/bg.svg
Please move or remove them before you merge.
Aborting
pi@raspberrypi:~/supla-scripts $
Awatar użytkownika
klew
Posty: 1554
Rejestracja: czw cze 27, 2019 12:16 pm

sob lis 21, 2020 9:59 am

Masz lokalne zmiany w swoim repozytorium, które są w konflikcie z merge'owanymi zmianami.
Muszisz:
1. usunąć swoje zmiany i wtedy merge'a zrobić
2. commitować swoje zmiany, potem zrobić merge (automatyczny może się nie udać, więc ręczne poprawki mogą być konieczne)
ODPOWIEDZ

Wróć do „Projekty użytkowników”