Automatyczna instalacja supla (server,cloud,dev)

michu9010
Posts: 8
Joined: Mon Nov 07, 2016 12:48 pm

Wed Dec 21, 2016 6:47 am

powiedz mi dane w moim pliku playbook.yml są dobrze przypisane?

ogonie mówiąc mam problem z podpięciem skrzynek mailowych system nie wysyła z żadnego serwera ma ktoś może przykładową konfiguracje?
alv
Posts: 74
Joined: Sat Jul 09, 2016 11:36 am

Wed Dec 21, 2016 5:23 pm

michu9010 wrote:powiedz mi dane w moim pliku playbook.yml są dobrze przypisane?

ogonie mówiąc mam problem z podpięciem skrzynek mailowych system nie wysyła z żadnego serwera ma ktoś może przykładową konfiguracje?
Jest błędnie skonfigurowane
https://symfony.com/doc/current/email.html

transport (smtp, mail, sendmail, or gmail)
username
password
host
port
encryption (tls, or ssl)

Jeśli masz swój serwer smtp, to wybierz smtp

Możesz również w prosty sposób użyć metody gmail:
transport: gmail
username: your_gmail_username
password: your_gmail_password
Zybi
Posts: 1368
Joined: Sun Jun 26, 2016 4:24 pm

Thu Jan 19, 2017 6:13 pm

@alv świetna robota.
Właśnie postawiłem własny serwer na Orange Pi Zero.
Wszystko ruszyło od pierwszego strzału.
Dzięki!
User avatar
slawek
Posts: 2209
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Thu Jan 19, 2017 7:51 pm

A jak z mailami i aktywacją?
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
Zybi
Posts: 1368
Joined: Sun Jun 26, 2016 4:24 pm

Thu Jan 19, 2017 8:09 pm

slawek wrote:A jak z mailami i aktywacją?
Maile i aktywacja bezproblemowa, ale niestety nie rejestrują się urządzenia oraz apka na smartfonie też nie chce połączyć się z serwerem.
Mój zachwyt był trochę przedwczesny.
User avatar
slawek
Posts: 2209
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Thu Jan 19, 2017 8:24 pm

W takim razie trzymam kciuki i czekam na sukces, bo też mam taki plan... czekam na dostawę. ;)
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
alv
Posts: 74
Joined: Sat Jul 09, 2016 11:36 am

Fri Jan 20, 2017 7:52 am

Podasz parametry jakich użyłeś? Sprawdzę czy coś mogło się nie powieść. System?
Zybi
Posts: 1368
Joined: Sun Jun 26, 2016 4:24 pm

Fri Jan 20, 2017 9:44 am

alv wrote:Podasz parametry jakich użyłeś? Sprawdzę czy coś mogło się nie powieść. System?
System ARMBIAN Debian Jessie.
Przy komendzie:

Code: Select all

sudo apt-get install python-pip python-dev libffi-dev libssl-dev libxml2-dev libxslt1-dev libjpeg8-dev zlib1g-dev -y
był komunikat, że paczka "libjpeg8-dev" już nie jest dostępna i proponowano paczkę "libjpeg62-turbo-dev"

Serwer ładnie startuje, maile i aktywacja ruszyła bez problemów, ale urządzenia wykonawcze nie rejestrują się i apka też nie może połączyć się z serwerem. Może jakieś uprawnienia, grupy należy zmodyfikować?

Na serwerze na RPB3 postawionego z obrazu miałem wszystko odwrotnie - maili nie było i aktywację konta musiałem dokonać bezpośrednio na bazie, ale potem już wszystko działało i działa bez problemów.
User avatar
pzygmunt
Posts: 6585
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Fri Jan 20, 2017 10:41 am

Musisz dodać dedykowany ssl z włączona obsługa SSLv2
Zybi
Posts: 1368
Joined: Sun Jun 26, 2016 4:24 pm

Fri Jan 20, 2017 11:07 am

pzygmunt wrote:Musisz dodać dedykowany ssl z włączona obsługa SSLv2
czyli tak?

Code: Select all

cd /usr/src
sudo mkdir openssl
sudo wget https://www.openssl.org/source/openssl-1.0.1t.tar.gz
sudo tar zxvf openssl-1.0.1t.tar.gz
cd openssl-1.0.1t
sudo ./config --prefix=/usr/src/openssl shared
*edit Makefile and remove no-ssl2 flags
sudo make depend
sudo make install
sudo cp /usr/src/openssl/lib/*.so /usr/lib/supla-server/
sudo rm -rf cp /usr/src/openssl
Post Reply