Sonoff Basic DS18B20 DHT22 multi switch

Awatar użytkownika
uchnast.michal
Posty: 353
Rejestracja: wt cze 04, 2019 11:37 am
Lokalizacja: Czeladź
Kontaktowanie:

pt sty 31, 2020 6:32 pm

Ciężko z czasem, przepraszam.
e-talking............
Awatar użytkownika
Gang
Posty: 125
Rejestracja: pt lis 09, 2018 12:44 pm

pt sty 31, 2020 7:23 pm

uchnast.michal pisze:
pt sty 31, 2020 6:32 pm
Ciężko z czasem, przepraszam.
Na luzie, to my korzystamy. :)

Znalazłem winowajce... jeden ds miał zamienione miejscami żółty z czerwonym.
Moduł wstał, ale nie może wykryć żadnego dsa, jakieś sugestie?

Rrzystor 4k7 jest jeden na rozgałezieniu dsów, jakiś metr przewodu od modułu, ds na metrowych przewodach.

Edit: działa! Przełożyłem rezystor na moduł.
krzysiek_bb
Posty: 30
Rejestracja: śr lut 05, 2020 1:17 pm

śr lut 05, 2020 6:45 pm

Witam jestem raczkujący jeśli chodzi o ESP
Przepraszam za głupie pytanie ale nie znalazłem w w/w temacie odpowiedzi....
Może ktoś miał podobny przypadek.
Mam problem z odczytem więcej niż jednej czujki DS18b20 ....
Podczas budowy domu nawet nie myślałem że powstanie coś takiego jak zdalny odczyt temperatur na bazie ESP.
W 2012r. zmontowałem układ rs232>usb oraz używałem programu maxitermo mierząc temp. z 4 DS18b20 jak to wtedy było montowane cały system chodził na 2 przewodach czyli pasożytniczo ...... nie mam możliwości dostępu do tych zamontowanych DS-ów wiec co za tym idzie nie ma możliwości przerobienia na linię 3 przewodową.

Wgrałem do sonoff SonoffBasic-DS-Multi ale problem w tym że wykrywa mi tylko 1 sztukę DS-a
Bez opornika 4,7kohm brak czujników (jakby nie widział lini)
z opornikiem 3,3 kohm jeden czujnik ale błąd temp 127*C
z opornikiem 2,1 kohm nadal 1 czujnik temp OK
z opornikiem 680 ohm bez zmian 1 czujnik temp OK ..... ale reszty brak
DS-y podpięte jak w opisie data do RX na płytce sonoff +3,3V na opornik i do data oraz GND
Prośba co mógłbym jeszcze "pokombinować" aby zaczytał podczas szukania resztę DS-ów.
Instalacja ma około 15m są to czujniki temperatury wyciąganej rekuperatora z pomieszczeń.

Sorry za chaotyczny opis. Jeśli można to proszę o jakąś poradę co jeszcze zmienić lub co wgrać aby ruszyło.
Pozdrawiam.
Załączniki
ds.jpg
ds.jpg (50.94 KiB) Przejrzano 905 razy
Maniek913
Posty: 260
Rejestracja: czw lut 22, 2018 9:46 pm

śr lut 05, 2020 9:59 pm

Byłem w identycznej sytuacji :D i też w 2012 roku ułożyłem sieć Ds-ów obsługiwane maxitermem. (co za zbieg okoliczności :?: )
tu o tym pisałem, możesz zerknąć.
viewtopic.php?f=24&t=4077&p=30320#p30320
viewtopic.php?f=11&t=5233&p=58276#p58276
viewtopic.php?f=24&t=5955&start=30
Mógłbym wiele mówić o moich "bojach" z przesiadką na suplę.
Tak na szybko to :
1.Najlepsza obsługa wielu czujników jest na sofcie primary V2 kol krycha88 , (po ostatnich modyfikacjach),a także rozwiązanie kol. klew ze swoją modyfikacją biblioteki supla device też działa wyśmienicie.
2. Układ pasożytniczy niestety ma mniejszy "zasięg" , ale nie wykluczam że u ciebie zadziała.
3.Sonoff basic ze względu na dość marny zasilacz nie specjalnie się do tego nadaje.
4. Wszelkie testy i próby detekcji czujników rób zasilając układ z zasilacza bateryjnego (to naprawdę pomaga)
U mnie sieć jest bardzo rozległa i niekorzystnie gwiaździsta, i dlatego musiałem przejść na trzy przewody ,ale teraz działa rewelacyjnie.
filmik z działania:
https://youtu.be/gv-KnXCA60o
krzysiek_bb
Posty: 30
Rejestracja: śr lut 05, 2020 1:17 pm

śr lut 05, 2020 11:15 pm

Dzięki za podpowiedź .... przetestuje softy oraz inne zasilanie.
Oglądnąłem filmik rewelka... a inspiracją u mnie na ówczesne czasy były tematy na forum muratora :) o ogrzewaniu elektrycznym.
Pięknie to u Ciebie ruszyło z baterii ..... biegnę testować tylko muszę poszukać baterii.
krzysiek_bb
Posty: 30
Rejestracja: śr lut 05, 2020 1:17 pm

czw lut 06, 2020 11:07 am

Niestety zmiana zasilacza jak i zasilanie bateryjne nie przyniosło pożądanego efektu w dalszym ciągu 1 czujnik brak reszty DS.
Co do firmware o którym piszesz to nie potrafię prawidłowo skompilować pliku *.bin w arduino jeden się zrobił i chyba nawet pociągnął prawidłowe biblioteki lecz po wgraniu sonoff nie reagował kompletnie wgrałem znów multi switch i działa jak przed.
Jeśli posiadasz jakieś gotowe pliki *.bin które mógłbym wgrać do SONOFF BASIC to poproszę o jakieś namiary lub jakiś opis / stronę jak prawidłowo skompilować, a następnie jak prawidłowo wgrać poprzez Arduino. Być może robie coś źle podczas wgrywania ale nie wiem co.

jestem w trakcie czytania może znajdę mój błąd w kompilowaniu ...
viewtopic.php?f=23&t=3559&hilit=zip

edit: sorry ale nie mam pojęcia gdzie popełniam błąd robię zgodnie z w/w opisem i mam taki efekt
Załączniki
błąd_kompilacji.jpg
błąd_kompilacji.jpg (82.89 KiB) Przejrzano 823 razy
Maniek913
Posty: 260
Rejestracja: czw lut 22, 2018 9:46 pm

czw lut 06, 2020 12:05 pm

Teraz nie mam możliwości , ale wieczorem spróbuję ci skompilowć soft dla sonofa basic - a jaki masz model -nowy (z grubymi przewodami do wyjścia)czy stary? Albo inaczej na jakim pinie chcesz mieć magistralę 1-Wire?
A co do błędu to zgłasza ci nieprawidłowy wybór typu płytki - masz wybrany nodemcu, możliwe że szkic nie pasuje do tej płytki, albo co bardziej prawdopodobne masz złą wersję biblioteki Supla device.
Awatar użytkownika
klew
Posty: 1137
Rejestracja: czw cze 27, 2019 12:16 pm

czw lut 06, 2020 12:11 pm

krzysiek_bb pisze:
czw lut 06, 2020 11:07 am

edit: sorry ale nie mam pojęcia gdzie popełniam błąd robię zgodnie z w/w opisem i mam taki efekt
Przewiń trochę to okno do góry i skopiuj cały tekst, które jest w tym pomarańczowym kolorze.
krzysiek_bb
Posty: 30
Rejestracja: śr lut 05, 2020 1:17 pm

czw lut 06, 2020 12:16 pm

OK serdeczne dzięki mam ten nowy Power R2, a pin może być RX GPIO3 chyba.....
Walcze dalej z błędem nawet gotowy przykład jak robie to zgłasza ten sam błąd :(


____________________________________________________
to cały text w pomarańczowym polu




C:\Users\XXXXXXXX\Documents\Arduino\libraries\Primary_GUI-OLED\supla_eeprom.cpp:10:31: fatal error: ESP8266TrueRandom.h: No such file or directory

Znaleziono wiele bibliotek w "SuplaDevice.h"
#include "ESP8266TrueRandom.h"

Wykorzystane: C:\Users\XXXXXXXX\Documents\Arduino\libraries\SuplaDevice
^

Niewykorzystane: C:\Users\XXXXXXXX\Documents\Arduino\libraries\SuplaDevice-master
compilation terminated.

Znaleziono wiele bibliotek w "Adafruit_Sensor.h"
Wykorzystane: C:\Users\XXXXXXXX\Documents\Arduino\libraries\Adafruit_Sensor-master
Niewykorzystane: C:\Users\XXXXXXXX\Documents\Arduino\libraries\Adafruit_Unified_Sensor
exit status 1
Błąd kompilacji dla płytki NodeMCU 1.0 (ESP-12E Module).
Maniek913
Posty: 260
Rejestracja: czw lut 22, 2018 9:46 pm

czw lut 06, 2020 12:19 pm

No to wszystko masz wypisane:
brakuje ci biblioteki ESP8266TrueRandom.h , masz kila wersji biblioteki SuplaDevice - zostaw tylko właściwą i doinstaluj brakujcą ESP8266TrueRandom.h
Np tu jest:
viewtopic.php?f=11&t=5233&hilit=primary+v2
ODPOWIEDZ

Wróć do „Projekty użytkowników”