BME280 + DS18B20 + LCD20x4

BlackAdder
Posty: 17
Rejestracja: czw lut 15, 2018 8:28 pm

wt cze 16, 2020 5:32 pm

Mam jedno pytanie do specjalistów, w/w projekcie mam zamontowany wyświetlacz LCD 20x4 (chodzi 24h/dobę). Czasami dzieje się tak, że wyświetlana temperatura blednie (traci kontrast) i trudno ją odczytać, czasami pomagało wyłączenie wyświetlacza na jakiś czas. Czy pojawia się u Was podobny problem?
piomar2
Posty: 368
Rejestracja: pt kwie 26, 2019 5:32 pm
Lokalizacja: Bukowice

wt cze 16, 2020 5:52 pm

Wszystko wskazuje na "kiepskie" połączenie konwertera z LCD lub wada (do wymiany) potencjometru do ustawiania kontrastu w konwerterze.
Mam kilka takich wyświetlaczy w ciągłym działaniu i zdarzały się takie problemy ale poprawienie lutowania pinów, wymiana wspomnianego potencjometru dawała pozytywne rezultaty.
BlackAdder
Posty: 17
Rejestracja: czw lut 15, 2018 8:28 pm

śr cze 17, 2020 1:38 pm

piomar2 pisze:
wt cze 16, 2020 5:52 pm
Wszystko wskazuje na "kiepskie" połączenie konwertera z LCD lub wada (do wymiany) potencjometru do ustawiania kontrastu w konwerterze.
Mam kilka takich wyświetlaczy w ciągłym działaniu i zdarzały się takie problemy ale poprawienie lutowania pinów, wymiana wspomnianego potencjometru dawała pozytywne rezultaty.
Bardzo dziękuje za podpowiedzi, udanego dnia :)
Jarson78
Posty: 72
Rejestracja: pn cze 11, 2018 10:54 am

czw cze 18, 2020 8:22 pm

U mnie po uruchomieniu na wemos d1 mini temperatura -147 a wilgotność 100%. Ciśnienie 1174hPa
Nie wiem o co chodzi
Awatar użytkownika
Goral64
Posty: 501
Rejestracja: pt gru 27, 2019 6:22 pm

pn cze 29, 2020 9:36 am

Pochodziło pięknie kilka dni, a dziś rano nagle BME280 zwariował. Temperatura -147°C, wilgotność 100% a ciśnienie 1235 hPa... Po restarcie Wemosa temperatura 0°C, wilgotność 0% i ciśnienie -1 hPa... Jakieś pomysły? BME280 zaliczył zgon? Zrobił sobie urlop? Inne opcje?
RPi4: Supla Cloud + Supla Scripts + Proxy + Let's Encrypt
1x MEW-01, 1x LIW-01, 2x SBW-02, 2x PNW-01, 1x ROW-01, 1x ROW-02, 1x ROW-04m,
2x Sonoff BRIDGE RF 433
This is only the beggining...
Awatar użytkownika
Goral64
Posty: 501
Rejestracja: pt gru 27, 2019 6:22 pm

pn cze 29, 2020 1:37 pm

Wymieniłem BME280 na inny i normalne wskazania się pojawiły. Kurcze, czy te sensory tak szybko padają, czy to ja miałem pecha?
RPi4: Supla Cloud + Supla Scripts + Proxy + Let's Encrypt
1x MEW-01, 1x LIW-01, 2x SBW-02, 2x PNW-01, 1x ROW-01, 1x ROW-02, 1x ROW-04m,
2x Sonoff BRIDGE RF 433
This is only the beggining...
Awatar użytkownika
klew
Posty: 987
Rejestracja: czw cze 27, 2019 12:16 pm

pn cze 29, 2020 1:40 pm

Goral64 pisze:
pn cze 29, 2020 1:37 pm
Wymieniłem BME280 na inny i normalne wskazania się pojawiły. Kurcze, czy te sensory tak szybko padają, czy to ja miałem pecha?
Mój BME280 działa już od kilku miesięcy bez żadnych problemów.
Awatar użytkownika
Goral64
Posty: 501
Rejestracja: pt gru 27, 2019 6:22 pm

pn cze 29, 2020 1:42 pm

klew pisze:
pn cze 29, 2020 1:40 pm
Mój BME280 działa już od kilku miesięcy bez żadnych problemów.
Daj tutka jak odpalić go na nowej SuplaDevice :) I jakby jeszcze z OLEDem śmigało to już w ogóle byłoby super :D
RPi4: Supla Cloud + Supla Scripts + Proxy + Let's Encrypt
1x MEW-01, 1x LIW-01, 2x SBW-02, 2x PNW-01, 1x ROW-01, 1x ROW-02, 1x ROW-04m,
2x Sonoff BRIDGE RF 433
This is only the beggining...
Awatar użytkownika
klew
Posty: 987
Rejestracja: czw cze 27, 2019 12:16 pm

pn cze 29, 2020 1:49 pm

Goral64 pisze:
pn cze 29, 2020 1:42 pm
klew pisze:
pn cze 29, 2020 1:40 pm
Mój BME280 działa już od kilku miesięcy bez żadnych problemów.
Daj tutka jak odpalić go na nowej SuplaDevice :) I jakby jeszcze z OLEDem śmigało to już w ogóle byłoby super :D
viewtopic.php?p=67913#p67913
Awatar użytkownika
shimano73
Posty: 1127
Rejestracja: ndz lut 28, 2016 12:27 pm
Lokalizacja: Orzesze

pn cze 29, 2020 3:18 pm

Mój BME działa już od co najmniej 1,5 roku i spisuje się dobrze ale jest zamknięty w obudowie tłumika pneumatycznego jak na zdjęciu
Załączniki
czujnik-bme280-temperatury-wilgotnosci-cisnienia-do-arduino.jpg
czujnik-bme280-temperatury-wilgotnosci-cisnienia-do-arduino.jpg (21.53 KiB) Przejrzano 217 razy
W elektronice jak nie wiadomo o co chodzi to zwykle chodzi o zasilanie
Jak się dziś oddycha https://schimano73.aqi.eco/
https://github.com/shimano73
ODPOWIEDZ

Wróć do „Projekty użytkowników”