SUPLA Filesensors - wyślij do SUPLI cokolwiek skądkolwiek

Beku
Posty: 331
Rejestracja: wt lis 06, 2018 1:49 pm

czw lut 20, 2020 1:25 pm

Generalnie one są połączone. Ten mój wchłonął funkcjonalność filesensors i z założenia ma być bogatszy w funkcjonalności. Jest mqtt chce dorobić inne protokoły. Napisany jest jednak w zasadzie od zera. Ja sobie przeniosłem mój filesensors na niego i od kilku dni używam tylko mojego z powodzeniem. Ale może być tak ze przekleisz config 1:1 (zmieniając type na odpowiednia Function) i coś nie zadziała. Wtedy bym prosił o feedback - poprawimy
Awatar użytkownika
fracz
Posty: 1812
Rejestracja: pt paź 28, 2016 10:56 pm
Lokalizacja: Rybna

czw lut 20, 2020 5:03 pm

Generalnie tak - ten projekt zawieszam bo to co Łukasz dostarczył przekracza możliwości tego co tu zrobiłem. Ogarnę to w dokumentacji w wolnej chwili, przekierowując do supla-virtual-device ;-)

A Łukasz nie chciał rozwijać tego tylko mieć swoje więc tak się porobiło
Awatar użytkownika
PuteR
Posty: 760
Rejestracja: śr gru 06, 2017 10:07 am

sob lut 22, 2020 12:55 pm

Po przejściu na supla-virtual-device nie ma potrzeby trzymania na malinie również supla-fileasensors czy wystarczy usunąć katalog czy powinno się to jakoś inaczej usuwać??
Beku
Posty: 331
Rejestracja: wt lis 06, 2018 1:49 pm

sob lut 22, 2020 2:47 pm

Wystarczy usunąć katalog
djack2017
Posty: 367
Rejestracja: pn lis 27, 2017 7:36 am

śr lut 26, 2020 7:50 am

lukfud pisze:
czw lut 06, 2020 12:25 am
Obrazek
Są może te ikony gdzieś do pobrania?
lukfud
Posty: 180
Rejestracja: czw lis 23, 2017 11:33 pm
Lokalizacja: Warszawa

śr lut 26, 2020 7:52 am

.newbie
Beku
Posty: 331
Rejestracja: wt lis 06, 2018 1:49 pm

śr lut 26, 2020 12:16 pm

Ile czujników macie podpiętych do jednego RPi zero ?
Awatar użytkownika
michael
Posty: 1090
Rejestracja: śr lis 09, 2016 8:00 am
Lokalizacja: Wojkowice

śr lut 26, 2020 12:45 pm

Co prawda nie do wersji zero, a do 3B mam obecnie podpięte 4 czujniki. Dzisiaj również zauważyłem, że od 6-tej rano miałem brak komunikacji. Restart maliny dopiero pomógł przywrócić komunikację bluetooth. Będę to obserwował, może to tylko incydent :lol:

EDIT:
mowa oczywiście o czujnikach temperatury Xiomi
Kabel ucięty na miarę zawsze jest za krótki...
Beku
Posty: 331
Rejestracja: wt lis 06, 2018 1:49 pm

śr lut 26, 2020 12:55 pm

michael pisze:
śr lut 26, 2020 12:45 pm
Co prawda nie do wersji zero, a do 3B mam obecnie podpięte 4 czujniki. Dzisiaj również zauważyłem, że od 6-tej rano miałem brak komunikacji. Restart maliny dopiero pomógł przywrócić komunikację bluetooth. Będę to obserwował, może to tylko incydent :lol:

EDIT:
mowa oczywiście o czujnikach temperatury Xiomi
no właśnie mi się to zdarzyło na 4 sztukach na rpizero. Musiałem zrestartować malinę bo z żadnym nie chciał się połączyć. Ciekawee...
Awatar użytkownika
Robert Błaszczak
Posty: 911
Rejestracja: sob gru 22, 2018 8:55 pm
Lokalizacja: Zielona Góra
Kontaktowanie:

śr lut 26, 2020 1:19 pm

Jaki był objaw? Do Supli był wysyłany cały czas ostatni zapisany w pliku pomiar? Jeśli tak, to czy nie wystarczyło zrestartować skryptu LYWSD03MMC.py?

Pytam czysto teoretycznie, bo czekam jeszcze na swoje LYWSD03MMC, ale na RPi Zero W mam wszystko skonfigurowane, a skrypt supla-virtual-device wysyła cały czas poprawnie wartości z plików tekstowych (od kilku dni). Oczywiście z racji braku czujników skrypt LYWSD03MMC.py nie jest uruchomiony.
Pozdrawiam
Robert Błaszczak

Strona prywatna: https://www.blaszczak.pl
Jakość powietrza: https://robert.aqi.eco
Zablokowany