Czujnik poczty z SBW-01

Awatar użytkownika
klew
Posty: 1756
Rejestracja: czw cze 27, 2019 12:16 pm

czw lis 19, 2020 12:21 pm

MadOnion78 pisze:
czw lis 19, 2020 12:08 pm
Wydaje mi się, że to kwestia zainstalowania mikro wyłączników.
Oba bym zamocował do bocznej ścianki, jeden na wysokości górnej a drugi na wys. dolnej klapki.
Działanie by było raczej takie samo jak przedstawił Klew w swoim rozwiązaniu.
Masz skrzynkę i pozostałe sprzęty to chyba warto spróbować jakaś taśma dwustronna i pacjenta na stół. :mrgreen:
Czujnik wg moje schematu działa podobnie do przerzutnika RS. Podanie impulsu od otwartej klapki ustawia stan "jest poczta", a otwarcie drzwiczek go resetuje na "nie ma poczty".
Tutaj otwarcie i zamknięcie drzwiczek wymaga podniesienia klapki. Więc mój pomysł tutaj nie zadziała, bo jak zamkniesz drzwiczki, to klapka jest nadal podniesiona i pojawi się sygnał "jest poczta".
Trzeba by zrobić coś, co by spowodowało, że po otwarciu drzwiczek, sygnał z klapki jest ignorowany aż do momentu, gdy drzwiczki zostaną zamknięte i klapka opuszczona.
ChrisSZ
Posty: 23
Rejestracja: śr lip 08, 2020 3:21 pm

czw lis 19, 2020 3:28 pm

Na dzień dzisiejszy jeśli nikt nie podrzuci jakiegoś innego rozwiązania jedynym rozwiązaniem na jakie wpadłem jest aby SW1 był wyprowadzony na zewnątrz i po wyjęciu poczty i ponownym włączeniu SW2 należałoby ręcznie wykonać reset przełącznikiem SW1. Przycisk od spodu niewidoczny płaski jeśli nawet osoba nieuprawniona miałaby do niego dostęp jedyną konsekwencją takiego działania byłby reset informacji o poczcie. Nie jest to zbyt dużym problemem gdyż ustawiłem powiadomienia o poczcie.
Awatar użytkownika
MadOnion78
Posty: 410
Rejestracja: ndz lis 24, 2019 3:53 pm
Lokalizacja: Głubczyce

pt lis 20, 2020 5:39 am

klew pisze:
czw lis 19, 2020 12:21 pm
Czujnik wg moje schematu działa podobnie do przerzutnika RS. Podanie impulsu od otwartej klapki ustawia stan "jest poczta", a otwarcie drzwiczek go resetuje na "nie ma poczty".
Tutaj otwarcie i zamknięcie drzwiczek wymaga podniesienia klapki. Więc mój pomysł tutaj nie zadziała, bo jak zamkniesz drzwiczki, to klapka jest nadal podniesiona i pojawi się sygnał "jest poczta". ...
No tak racja, czyli...
Przytrzymujesz górny mikro, zamykasz dolna klapkę następnie zamykasz górna tak żeby nie wywołać impulsu. :lol: :mrgreen:
Można przy okazji poćwiczyć sprawność. ;)
Ale dało by się tak zrobić kwestia zamontowania mikrowyłącznika z taką dłuższą blaszka w odpowiedniej odległości.
3x SRW-01, 3x ROW-02, 2x SBW-02, 2x LIW-01, 1x SLW-02, 1x MEW-01, RNW-01 ;)
ChrisSZ
Posty: 23
Rejestracja: śr lip 08, 2020 3:21 pm

pt lis 20, 2020 7:19 am

MadOnion78 pisze:
pt lis 20, 2020 5:39 am
No tak racja, czyli...
Przytrzymujesz górny mikro, zamykasz dolna klapkę następnie zamykasz górna tak żeby nie wywołać impulsu. :lol: :mrgreen:
Można przy okazji poćwiczyć sprawność. ;)
Ale dało by się tak zrobić kwestia zamontowania mikrowyłącznika z taką dłuższą blaszka w odpowiedniej odległości.
Musiałaby wystawać poza skrzynką ta blaszka od włącznika, na zdjęciu podałem przykładowe zdjęcie z netu a w moim przypadku jest gorzej bo górne drzwiczki mają jeszcze boki co pogarsza sprawę sprawnej ekwilibrystyki przy wyjmowaniu listu. O ile na taki eksperymenty z blaszkami i cyrkowym podejściem do wyjmowania listu może sobie pozwolić wykonawca skrzynki to już jego małżonka nie będzie zadowolona z konieczności pamiętani odpowiedniej sekwencji wyjęcia listu i procedury zamykania skrzynki. Trzeba to uprościć...
ChrisSZ
Posty: 23
Rejestracja: śr lip 08, 2020 3:21 pm

wt gru 08, 2020 10:46 am

klew pisze:
wt paź 27, 2020 10:25 am
Elementy zależą od tego jak chcesz to zrobić (mechanicznie na mikroprzełącznikach, czy na kontaktronach?). Dobór przekaźnika też jest uzależniony od napięcia jakie chcesz użyć.

Co potrzeba?
- SBW-01 (02 też może być)
Skrzynka zamontowana, ale nie mogę przeskoczyć jednego problemu. Przy próbach łączyłem wszystko na wolnym SBW-01 i działa bezbłędnie wszystko co trzeba z powiadamianiem włącznie. Mam także zamontowany do sterowania bramą i furtką SBW-02 (łącza out1 i out2). Jeden z czujników jest wykorzystany do bramy (bennica) jako czujnik otwarcia (in1) a drugi jest wolny (in2). Przełączyłem in2 w ustawieniach supli na czujnik poczty i nie informuje w aplikacji o poczcie, mimo iż napięcie sterujące jest podawane na złącze in2. Po przełączeniu do SBW-01 działa bezproblemowo powiadamianie o poczcie.

Czy ja coś z konfiguracją w supli źle zrobiłem?
Czy Uszkodzony jest moduł SBW-02 (złącze in2)?
Co i jak sprawdzić?
Awatar użytkownika
klew
Posty: 1756
Rejestracja: czw cze 27, 2019 12:16 pm

wt gru 08, 2020 11:20 am

ChrisSZ pisze:
wt gru 08, 2020 10:46 am
Skrzynka zamontowana, ale nie mogę przeskoczyć jednego problemu. Przy próbach łączyłem wszystko na wolnym SBW-01 i działa bezbłędnie wszystko co trzeba z powiadamianiem włącznie. Mam także zamontowany do sterowania bramą i furtką SBW-02 (łącza out1 i out2). Jeden z czujników jest wykorzystany do bramy (bennica) jako czujnik otwarcia (in1) a drugi jest wolny (in2). Przełączyłem in2 w ustawieniach supli na czujnik poczty i nie informuje w aplikacji o poczcie, mimo iż napięcie sterujące jest podawane na złącze in2. Po przełączeniu do SBW-01 działa bezproblemowo powiadamianie o poczcie.

Czy ja coś z konfiguracją w supli źle zrobiłem?
Czy Uszkodzony jest moduł SBW-02 (złącze in2)?
Co i jak sprawdzić?
Możesz spróbować dawać bezpośrednio napięcie zasilające SBW na IN2 i patrzeć w aplikacji, czy stan się zmienia. Możesz też testowo podłączyć pod IN1 i zobaczyć czy stan bramy się zmienia, gdy przychodzi poczta ;).
ChrisSZ
Posty: 23
Rejestracja: śr lip 08, 2020 3:21 pm

wt gru 08, 2020 7:09 pm

klew pisze:
wt gru 08, 2020 11:20 am
ChrisSZ pisze:
wt gru 08, 2020 10:46 am
Skrzynka zamontowana, ale nie mogę przeskoczyć jednego problemu. Przy próbach łączyłem wszystko na wolnym SBW-01 i działa bezbłędnie wszystko co trzeba z powiadamianiem włącznie. Mam także zamontowany do sterowania bramą i furtką SBW-02 (łącza out1 i out2). Jeden z czujników jest wykorzystany do bramy (bennica) jako czujnik otwarcia (in1) a drugi jest wolny (in2). Przełączyłem in2 w ustawieniach supli na czujnik poczty i nie informuje w aplikacji o poczcie, mimo iż napięcie sterujące jest podawane na złącze in2. Po przełączeniu do SBW-01 działa bezproblemowo powiadamianie o poczcie.

Czy ja coś z konfiguracją w supli źle zrobiłem?
Czy Uszkodzony jest moduł SBW-02 (złącze in2)?
Co i jak sprawdzić?
Możesz spróbować dawać bezpośrednio napięcie zasilające SBW na IN2 i patrzeć w aplikacji, czy stan się zmienia. Możesz też testowo podłączyć pod IN1 i zobaczyć czy stan bramy się zmienia, gdy przychodzi poczta ;).
Po pomiarach SBW-02 wygląda to tak:
  • napięcie zasilające bezpośrednio na IN2 = powiadomienie w aplikacji o poczcie działa (jest poczta)
  • miernikiem pomiędzy minus i przewód sterujący brak napięcia = teoretycznie brak poczty (ale aplikacja pokazuje cały czas że poczta jest
  • podnoszę klapkę i uaktywniam przełącznik SW2, uruchamia się przekaźnik = jest poczta i aplikacja pokazuje że jest poczta i faktycznie pojawia się napięcie na przewodzie sterującym podłączonym do IN2 (tyle że aplikacja pokazuje cały czas bez względu na to czy pojawia się napięcie pomiędzy minusem zasilania a przewodem sterującym)
i tu ważna obserwacja w stanie kiedy mierzę miernikiem pomiędzy minus i przewód sterujący i jest brak napięcia = aplikacja pokazuje że jest poczta i odłączenie przewodu sterującego powoduje zmianę stanu poczty w aplikacji na brak poczty. Coś się dzieje na przewodzie sterującym co powoduje że aplikacja nie reaguje na ten stan brakiem poczty. Co ciekawe na SBW-01 tego problemu nie ma. Przekładam napięcie i przewód sterujący i działa miodzio...
Awatar użytkownika
klew
Posty: 1756
Rejestracja: czw cze 27, 2019 12:16 pm

wt gru 08, 2020 11:11 pm

ChrisSZ pisze:
wt gru 08, 2020 7:09 pm
i tu ważna obserwacja w stanie kiedy mierzę miernikiem pomiędzy minus i przewód sterujący i jest brak napięcia = aplikacja pokazuje że jest poczta i odłączenie przewodu sterującego powoduje zmianę stanu poczty w aplikacji na brak poczty. Coś się dzieje na przewodzie sterującym co powoduje że aplikacja nie reaguje na ten stan brakiem poczty. Co ciekawe na SBW-01 tego problemu nie ma. Przekładam napięcie i przewód sterujący i działa miodzio...
Wydaje mi się, że przyczyną problemów jest to, że SBW-02 na wejściach IN potrafi wykrywać nie tylko sygnał w postaci napięcia, ale również zwarcie do GND. (SBW-01 wykrywa tylko napięcie i nie potrafi wykryć zwarcia do GND)
Mój układ do poczty ma wyjście wygnałowe podłączone na stałe do GND (przez cewkę) i pewnie to jest przyczyna problemów.

Na pewno można ten problem obejsć dokładając jeszcze jeden przekaźnik (cewkę podłączamy do GND oraz do aktualnego wyjścia sygnałowego, natomiast na COM dajemy + i z NO wyprowadzamy sygnał).

Może można to jeszcze jakoś inaczej obejść, ale elektryk ze mnie słaby ;)
ChrisSZ
Posty: 23
Rejestracja: śr lip 08, 2020 3:21 pm

śr gru 09, 2020 6:17 am

pzygmunt pisze:
czw paź 22, 2020 5:48 pm
Co skrzynki w sensie do czujnika poczty prowadzisz dwa przewody. Jeden od A2 drugi od IN1/2
Czy jest możliwe, że ten układ podany do wykorzystania w SBW-01 nie zadziała z SBW-02? U mnie działa bezbłędnie w SBW-01 a nie działa z SBW-02 i mam podejrzenie że jest to związane z tym, iż układ podaje "minus" na IN2 w stanie "brak poczty (IN2 u mnie wykorzystany na czujnik poczty w SBW-02) co u mnie sygnalizuje w aplikacji jako "jest poczta". A zmiana stanu na "plus" na IN2 czyli "jest poczta" powoduje wyświetlenie w aplikacji "jest poczta". Tylko odłączenie przewodu sygnałowego, czyli stan "brak minusa i plusa na złączu IN2) powoduje pokazanie w aplikacji stanu "brak poczty". Czy to bug softu SBW-02, czy tak ma działać? A jeśli SBW-02 działa inaczej niż SBW-01 z podanym tu schematem to jak w prosty sposób go zmodyfikować aby w stanie "Brak poczty - minus na sygnałowym" reagował w aplikacji informacją o braku poczty?
Awatar użytkownika
Robert Błaszczak
Posty: 1606
Rejestracja: sob gru 22, 2018 8:55 pm
Lokalizacja: Zielona Góra
Kontaktowanie:

śr gru 09, 2020 6:31 am

Post wyżej @klew odpowiedział Ci na to pytanie. SBW-02 ma wejścia IN1/IN2 wyzwalane stanem wysokim lub stanem niskim. SBW-01 tylko stanem wysokim.
Pozdrawiam
Robert Błaszczak

Strona prywatna: https://www.blaszczak.pl
Jakość powietrza: https://robert.aqi.eco
ODPOWIEDZ

Wróć do „Projekty użytkowników”