Smart DGM

djack2017
Posts: 285
Joined: Mon Nov 27, 2017 7:36 am

Mon Sep 09, 2019 11:12 am

Simono wrote:
Mon Sep 09, 2019 10:31 am
Takie coś znalazłem https://github.com/arendst/Sonoff-Tasmota/issues/4297
Z wgraną Tasmotą i wybranym modułem Gosund Sp nie działała mi jedynie dioda. Dioda działała jak wybrałem chyba Blitzwolf ale cała reszta wtedy nie działała.
Skonfigurowałem nr portów zgodnie z w/w tabelą. Wgram do pobrania dziś wieczorem (ok.20).
Simono
Posts: 301
Joined: Mon Sep 17, 2018 5:26 pm

Mon Sep 09, 2019 11:18 am

djack2017 wrote:
Mon Sep 09, 2019 11:12 am
Simono wrote:
Mon Sep 09, 2019 10:31 am
Takie coś znalazłem https://github.com/arendst/Sonoff-Tasmota/issues/4297
Z wgraną Tasmotą i wybranym modułem Gosund Sp nie działała mi jedynie dioda. Dioda działała jak wybrałem chyba Blitzwolf ale cała reszta wtedy nie działała.
Skonfigurowałem nr portów zgodnie z w/w tabelą. Wgram do pobrania dziś wieczorem (ok.20).
Super. Jak wrócę nie za późno to sprawdzę i dam znać jak działa.
Marco79
Posts: 24
Joined: Mon Sep 09, 2019 7:52 am

Mon Sep 09, 2019 11:40 am

djack2017 wrote:
Mon Sep 09, 2019 11:12 am
Simono wrote:
Mon Sep 09, 2019 10:31 am
Takie coś znalazłem https://github.com/arendst/Sonoff-Tasmota/issues/4297
Z wgraną Tasmotą i wybranym modułem Gosund Sp nie działała mi jedynie dioda. Dioda działała jak wybrałem chyba Blitzwolf ale cała reszta wtedy nie działała.
Skonfigurowałem nr portów zgodnie z w/w tabelą. Wgram do pobrania dziś wieczorem (ok.20).
Według forum użytkowników Tasmoty (która działa) konfiguracja GPIO jest następująca:
gpio3 - button
gpio13 - led
gpio14 - relay
gpio4 - bl0937 cf
gpio5 - hlwbl cf1
gpio12 - hlwbl seli

Image

Pozdrawiam i z niecierpliwością oczekuję na poprawiony firmware.
Simono
Posts: 301
Joined: Mon Sep 17, 2018 5:26 pm

Mon Sep 09, 2019 11:55 am

Marco79 wrote:
Mon Sep 09, 2019 11:40 am
djack2017 wrote:
Mon Sep 09, 2019 11:12 am
Simono wrote:
Mon Sep 09, 2019 10:31 am
Takie coś znalazłem https://github.com/arendst/Sonoff-Tasmota/issues/4297
Z wgraną Tasmotą i wybranym modułem Gosund Sp nie działała mi jedynie dioda. Dioda działała jak wybrałem chyba Blitzwolf ale cała reszta wtedy nie działała.
Skonfigurowałem nr portów zgodnie z w/w tabelą. Wgram do pobrania dziś wieczorem (ok.20).
Według forum użytkowników Tasmoty (która działa) konfiguracja GPIO jest następująca:
gpio3 - button
gpio13 - led
gpio14 - relay
gpio4 - bl0937 cf
gpio5 - hlwbl cf1
gpio12 - hlwbl seli

Image

Pozdrawiam i z niecierpliwością oczekuję na poprawiony firmware.
Podaj źródło, żeby być pewny i żeby djcak2017 nie kompilował softu kilka razy. Ja sprawdzałem na ustawieniach Gosund Sp i tu tylko dioda nie działała. Smart DGM nie widziałem w opcjach chyba, że pojawiła się nowa wersja.
Marco79
Posts: 24
Joined: Mon Sep 09, 2019 7:52 am

Mon Sep 09, 2019 12:05 pm

Simono wrote:
Mon Sep 09, 2019 11:55 am
Marco79 wrote:
Mon Sep 09, 2019 11:40 am
djack2017 wrote:
Mon Sep 09, 2019 11:12 am

Skonfigurowałem nr portów zgodnie z w/w tabelą. Wgram do pobrania dziś wieczorem (ok.20).
Według forum użytkowników Tasmoty (która działa) konfiguracja GPIO jest następująca:
gpio3 - button
gpio13 - led
gpio14 - relay
gpio4 - bl0937 cf
gpio5 - hlwbl cf1
gpio12 - hlwbl seli

Image

Pozdrawiam i z niecierpliwością oczekuję na poprawiony firmware.
Podaj źródło, żeby być pewny i żeby djcak2017 nie kompilował softu kilka razy. Ja sprawdzałem na ustawieniach Gosund Sp i tu tylko dioda nie działała. Smart DGM nie widziałem w opcjach chyba, że pojawiła się nowa wersja.
Na razie nie ma w opcjach SmartDGM, trzeba skonfigurować "Template -> Generic(18)" według wklejonego obrazka i wszystko działa.
Oto źródło:
https://www.pepper.pl/comments/permalink/2751721
User avatar
makrz
Posts: 234
Joined: Tue Nov 27, 2018 1:43 pm
Location: Opole

Mon Sep 09, 2019 2:32 pm

djack2017 wrote:
Mon Sep 09, 2019 10:08 am
makrz wrote:
Thu Sep 05, 2019 4:55 pm
// Buttons
#define BUTTON1_PIN 3
#define BUTTON1_RELAY 1
// Relays
#define RELAY1_PIN 14
// LEDs
#define LED1_PIN 1
Czy to są numery fizycznych pinów procesora czy numery GPIOxx ?
Numery gpio.
gpio3 - button
gpio13 - led
gpio14 - relay
gpio4 , 5 , 12 od licznika prądu.
User avatar
makrz
Posts: 234
Joined: Tue Nov 27, 2018 1:43 pm
Location: Opole

Mon Sep 09, 2019 4:31 pm

djack2017 wrote:
Mon Sep 09, 2019 11:12 am
Simono wrote:
Mon Sep 09, 2019 10:31 am
Takie coś znalazłem https://github.com/arendst/Sonoff-Tasmota/issues/4297
Z wgraną Tasmotą i wybranym modułem Gosund Sp nie działała mi jedynie dioda. Dioda działała jak wybrałem chyba Blitzwolf ale cała reszta wtedy nie działała.
Skonfigurowałem nr portów zgodnie z w/w tabelą. Wgram do pobrania dziś wieczorem (ok.20).
Z tą tabelą? https://github.com/arendst/Sonoff-Tasmo ... -436804860
djack2017
Posts: 285
Joined: Mon Nov 27, 2017 7:36 am

Mon Sep 09, 2019 4:51 pm

Iteracja druga. Firmware, pod podanym wcześniej linkiem, jest skompilowany zgodnie z tabelą:
DSG.png
DSG.png (159.53 KiB) Viewed 92 times
Simono
Posts: 301
Joined: Mon Sep 17, 2018 5:26 pm

Mon Sep 09, 2019 6:00 pm

djack2017 wrote:
Mon Sep 09, 2019 4:51 pm
Iteracja druga. Firmware, pod podanym wcześniej linkiem, jest skompilowany zgodnie z tabelą:
DSG.png
Kurcze u mnie niestety bez zmian. Fizyczny przycisk czy krótko czy długo nie działa, z aplikacji również nie da się załączyć :(
Czy to się różni od tego co ja dałem linka?
Marco79
Posts: 24
Joined: Mon Sep 09, 2019 7:52 am

Mon Sep 09, 2019 6:08 pm

Simono wrote:
Mon Sep 09, 2019 6:00 pm
djack2017 wrote:
Mon Sep 09, 2019 4:51 pm
Iteracja druga. Firmware, pod podanym wcześniej linkiem, jest skompilowany zgodnie z tabelą:
DSG.png
Kurcze u mnie niestety bez zmian. Fizyczny przycisk czy krótko czy długo nie działa, z aplikacji również nie da się załączyć :(
Czy to się różni od tego co ja dałem linka?
U mnie tak samo nic nie działa, ani przycisk ani z aplikacji więc nie można włączyć i sprawdzić czy działa licznik.
Post Reply