Page 1 of 3

ROW-1 zwłoka zał/wył

Posted: Sat Jun 08, 2019 5:40 am
by Patryk
Wiem, że ten temat już kiedyś był poruszany.
Chodzi mi o zwłokę przy wył/zał w szczególności wyłacznikiem monostabilnym.
Może jednak dało by się ją " trochę" zmniejszyć lub zastosować rozwiązanie z licznika impulsów, gdzie to użytkownik potrafi sam metodą " prób " dostosować ja do swoich potrzeb.

Re: ROW-1 zwłoka zał/wył

Posted: Sat Jun 08, 2019 9:45 am
by pzygmunt
Podaj maila to podepnę Cię do aktualizacji gdzie możesz przetestować nieoficjalną wersje. Można tam przestawić czułość ryzykując przypadkowe załączenia.

Re: ROW-1 zwłoka zał/wył

Posted: Wed Jun 12, 2019 2:16 pm
by Patryk
pzygmunt wrote:
Sat Jun 08, 2019 9:45 am
Podaj maila to podepnę Cię do aktualizacji gdzie możesz przetestować nieoficjalną wersje. Można tam przestawić czułość ryzykując przypadkowe załączenia.
Czy zostałem dodany ?
Gdyż próba aktualizacji nic nie zmienia.

Re: ROW-1 zwłoka zał/wył

Posted: Wed Jun 12, 2019 3:54 pm
by pzygmunt
Jeszcze nie. Jak wrócę z konferencji.

Re: ROW-1 zwłoka zał/wył

Posted: Thu Jun 13, 2019 12:50 pm
by woytas1
Jeśli można też bym poprosił, bo trochę długo trzeba gnieść przycisk.

Re: ROW-1 zwłoka zał/wył

Posted: Tue Jun 25, 2019 9:07 am
by pzygmunt
Gdyby ktoś chciał na wersji docker-owej uaktualnić ROW-01/ROW-02 do nieoficjalnej wersji zawierającą możliwość zmiany czasu reakcji przycisku, może to zrobić dodając odpowiednie wpisy do bazy danych.

Code: Select all

source supla-docker/.env
cat row01_279.sql | docker exec -i supla-db mysql -u root --password=$DB_PASSWORD supla
SQL w załączniku.

Re: ROW-1 zwłoka zał/wył

Posted: Sun Jun 30, 2019 6:13 pm
by 4estR
Na początku skrypt nie działał wcale, Dostawałem w odpowiedzi

Code: Select all

ERROR 1062 (23000) at line 2: Duplicate entry '0' for key 'PRIMARY'
root@raspberrypi:/home/pi# 
Po ręcznym wpisaniu do pliku row01_279.sql kolumny ID i rekordów kolejno 1 i 2, tabela ESP_Update prezentuje się następująco:

Code: Select all

+----+-----------+--------------+----------+-------------------------+---------+---------+-----------+-------------------+------+----------------------------------------------------------------------------+
| id | device_id | device_name  | platform | latest_software_version | fparam1 | fparam2 | protocols | host              | port | path                                                                       |
+----+-----------+--------------+----------+-------------------------+---------+---------+-----------+-------------------+------+----------------------------------------------------------------------------+
|  1 |         0 | ZAMEL ROW-01 |        1 | 2.7.9                   |       5 |       0 |         1 | www.acsoftware.pl |   80 | support/get_esp_firmware.php?file=zam_row_01_user2.2048_DIO.new.5.v279.bin |
|  2 |         0 | ZAMEL ROW-01 |        1 | 2.7.9                   |       5 |       1 |         1 | www.acsoftware.pl |   80 | support/get_esp_firmware.php?file=zam_row_01_user1.2048_DIO.new.5.v279.bin |
+----+-----------+--------------+----------+-------------------------+---------+---------+-----------+-------------------+------+----------------------------------------------------------------------------+
Wyszarpałem po jednym ROW01 i ROW02 z puszek. Na każdym po kolei wciskałem przycisk konfiguracji aż dioda zaczęła szybciej mrugać, po podłączeniu do sieci wifi zmieniłem pozycję firmware update na yes, zapisałem zmiany i wcisnąłem przycisk konfiguracji jeszcze raz i co ciekawe nic się nie wydarzyło.

O ile ogarniam w tabeli ESP_Update_LOG powinna być jakaś próba podłączenia albo coś a tu nic się nie pojawia. Tabela esp_update_log jest pusta.

Coś robię nie tak?

Re: ROW-1 zwłoka zał/wył

Posted: Sun Jun 30, 2019 8:42 pm
by pzygmunt
Uaktualnij clouda najpierw do najwyższej wersji. Może brakuje Ci procedur.

Re: ROW-1 zwłoka zał/wył

Posted: Mon Jul 01, 2019 7:59 am
by 4estR

Code: Select all

git pull
./supla.sh upgrade
Powyższy kod wykonywałem niedawno (max tydzień temu), czyli raczej powinno być wszystko aktualne, ale wykonam jeszcze raz i spróbuję podnieść ROW do nowszej wersji raz jeszcze. Zobaczymy czy coś to da.

Re: ROW-1 zwłoka zał/wył

Posted: Mon Jul 01, 2019 8:27 am
by pzygmunt
Upewnij się, że w SQL-u masz procedurę
supla_get_device_firmware_url