Tryb proxy (poprawne certyfiakty SSL, Let's Encrypt)

Moderator: fracz

radasx
Posty: 5
Rejestracja: sob gru 08, 2018 11:11 pm

pn mar 23, 2020 3:07 pm

pzygmunt pisze:
pn mar 23, 2020 8:26 am
Sprawdzałeś logi ?
BŁĄD
Wystąpił problem w trakcie komunikacji z serwerem. Spróbuj ponownie za chwilę.


INFORMACJA
Logowanie tymczasowo niedostępne. Spróbuj ponownie później.
Awatar użytkownika
pzygmunt
Posty: 7963
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

pn mar 23, 2020 4:04 pm

Chodziło mi logi z usług.
radasx
Posty: 5
Rejestracja: sob gru 08, 2018 11:11 pm

czw mar 26, 2020 10:10 pm

pzygmunt pisze:
pn mar 23, 2020 4:04 pm
Chodziło mi logi z usług.
Gdy wyłączę apache2 wszystko działa. Gdy włączę apache2 dostaje zwrotkę o zajętości portu 443.
Awatar użytkownika
pzygmunt
Posty: 7963
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

czw mar 26, 2020 10:12 pm

Zapewne więcej usług niż jedna chce używać 443 lub 80
radasx
Posty: 5
Rejestracja: sob gru 08, 2018 11:11 pm

czw mar 26, 2020 10:19 pm

pzygmunt pisze:
czw mar 26, 2020 10:12 pm
Zapewne więcej usług niż jedna chce używać 443 lub 80
To właśnie napisałem. Potrzebuje informacji w jaki sposób mogę ten port zmienić. Jeśli przestawię na proxy to działa. Pytanie tylko jak skierować proxy na nie.

@edit

Udało się postawić na innym porcie. Pytanie tylko w jaki sposób przekierować strone z ssl port :444 żeby nie wyrzucało błędu o certyfikatach?

@@edit2

Certyfikaty ogarnąłem. Nie wiem tylko w jaki sposób mogę dokonać wskazań domeny aby zamiast korzystać z https://domena.com:444 działała https://domena.com


"Bad Request
Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.""

@@edit3

SSLProxyEngine nie wpisałem ;)
ODPOWIEDZ