Supla ❤ Docker

Moderator: fracz

Simono
Posts: 142
Joined: Mon Sep 17, 2018 5:26 pm

Fri Sep 21, 2018 5:14 am

Koledzy wszystko się zainstalowało. Malina się grzeje bo jest dość obciążona jakimiś procesami, karta SD widać często pracuje. Strona https://192.168.1.201/ nie ładuje się.
Z błędów to mam jedynie tutaj:

Code: Select all

docker logs --since=5m supla-cloud
 [OK] Cache for the "prod" environment (debug=false) was successfully warmed.

User admin@supla.com already exists.
  File "/usr/lib/python2.7/encodings/__init__.py", line 1
SyntaxError: Non-ASCII character '\x80' in file /usr/lib/python2.7/encodings/__init__.py on line 1, but no encoding declared; see http://python.org/dev/peps/pep-0263/ for details
Database connection has been established.

                    Application Migrations


No migrations to execute.

 // Warming up the cache for the prod environment with debug
 // false

 [OK] Cache for the "prod" environment (debug=false) was successfully warmed.

User admin@supla.com already exists.
  File "/usr/lib/python2.7/encodings/__init__.py", line 1
SyntaxError: Non-ASCII character '\x80' in file /usr/lib/python2.7/encodings/__init__.py on line 1, but no encoding declared; see http://python.org/dev/peps/pep-0263/ for details
Database connection has been established.

                    Application Migrations


No migrations to execute.

 // Warming up the cache for the prod environment with debug
 // false

 [OK] Cache for the "prod" environment (debug=false) was successfully warmed.

User admin@supla.com already exists.
  File "/usr/lib/python2.7/encodings/__init__.py", line 1
SyntaxError: Non-ASCII character '\x80' in file /usr/lib/python2.7/encodings/__init__.py on line 1, but no encoding declared; see http://python.org/dev/peps/pep-0263/ for details
Database connection has been established.

                    Application Migrations


No migrations to execute.

 // Warming up the cache for the prod environment with debug
 // false

 [OK] Cache for the "prod" environment (debug=false) was successfully warmed.

User admin@supla.com already exists.
  File "/usr/lib/python2.7/encodings/__init__.py", line 1
SyntaxError: Non-ASCII character '\x80' in file /usr/lib/python2.7/encodings/__init__.py on line 1, but no encoding declared; see http://python.org/dev/peps/pep-0263/ for details
Database connection has been established.

                    Application Migrations


No migrations to execute.

 // Warming up the cache for the prod environment with debug
 // false

 [OK] Cache for the "prod" environment (debug=false) was successfully warmed.

User admin@supla.com already exists.
  File "/usr/lib/python2.7/encodings/__init__.py", line 1
SyntaxError: Non-ASCII character '\x80' in file /usr/lib/python2.7/encodings/__init__.py on line 1, but no encoding declared; see http://python.org/dev/peps/pep-0263/ for details
Database connection has been established.

                    Application Migrations


No migrations to execute.

 // Warming up the cache for the prod environment with debug
 // false

 [OK] Cache for the "prod" environment (debug=false) was successfully warmed.

User admin@supla.com already exists.
  File "/usr/lib/python2.7/encodings/__init__.py", line 1
SyntaxError: Non-ASCII character '\x80' in file /usr/lib/python2.7/encodings/__init__.py on line 1, but no encoding declared; see http://python.org/dev/peps/pep-0263/ for details
User avatar
fracz
Posts: 1454
Joined: Fri Oct 28, 2016 10:56 pm
Location: Rybna

Fri Sep 21, 2018 6:25 am

Pythony są dziwne. Nie miałem takich problemów ale wydaje mi się że powinien być python 3 a nie 2. Czy ktoś kto ma dockera na malinie mógłby zweryfikować jaką wersję pythona ma zainstalowana?
siba
Posts: 80
Joined: Mon Feb 06, 2017 4:01 pm
Location: Kraków

Fri Sep 21, 2018 8:13 am

u mnie jest Python 2.7.13
User avatar
lesny8
Posts: 574
Joined: Mon Dec 11, 2017 9:43 pm

Fri Sep 21, 2018 4:20 pm

U mnie jest 2.7 i 3.5

Code: Select all

pi@raspberrypi:~ $ sudo apt list --installed | grep python

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

dh-python/stable,now 2.20170125 all [installed,automatic]
libpython-all-dev/stable,now 2.7.13-2 armhf [installed,automatic]
libpython-dev/stable,now 2.7.13-2 armhf [installed,automatic]
libpython-stdlib/stable,now 2.7.13-2 armhf [installed,automatic]
libpython2.7/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
libpython2.7-dev/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
libpython2.7-minimal/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
libpython2.7-stdlib/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
libpython3-stdlib/stable,now 3.5.3-1 armhf [installed,automatic]
libpython3.5/stable,now 3.5.3-1 armhf [installed,automatic]
libpython3.5-minimal/stable,now 3.5.3-1 armhf [installed,automatic]
libpython3.5-stdlib/stable,now 3.5.3-1 armhf [installed,automatic]
python/stable,now 2.7.13-2 armhf [installed]
python-all/stable,now 2.7.13-2 armhf [installed,automatic]
python-all-dev/stable,now 2.7.13-2 armhf [installed,automatic]
python-apt-common/stable,now 1.1.0~beta5 all [installed,automatic]
python-cffi-backend/stable,now 1.9.1-2 armhf [installed,automatic]
python-crypto/stable,now 2.6.1-7 armhf [installed,automatic]
python-cryptography/stable,now 1.7.1-3+b2 armhf [installed,automatic]
python-dbus/stable,now 1.2.4-1 armhf [installed,automatic]
python-dev/stable,now 2.7.13-2 armhf [installed,automatic]
python-enum34/stable,now 1.1.6-1 all [installed,automatic]
python-gi/stable,now 3.22.0-2 armhf [installed,automatic]
python-idna/stable,now 2.2-1 all [installed,automatic]
python-ipaddress/stable,now 1.0.17-1 all [installed,automatic]
python-keyring/stable,now 10.1-1 all [installed,automatic]
python-keyrings.alt/stable,now 1.3-1 all [installed,automatic]
python-minimal/stable,now 2.7.13-2 armhf [installed,automatic]
python-pip/now 9.0.1-2+rpt1 all [installed,upgradable to: 9.0.1-2+rpt2]
python-pip-whl/now 9.0.1-2+rpt1 all [installed,upgradable to: 9.0.1-2+rpt2]
python-pkg-resources/stable,now 33.1.1-1 all [installed,automatic]
python-pyasn1/stable,now 0.1.9-2 all [installed,automatic]
python-rpi.gpio/stable,now 0.6.3~stretch-1 armhf [installed]
python-secretstorage/stable,now 2.3.1-2 all [installed,automatic]
python-setuptools/stable,now 33.1.1-1 all [installed,automatic]
python-six/stable,now 1.10.0-3 all [installed,automatic]
python-wheel/stable,now 0.29.0-2 all [installed,automatic]
python-xdg/stable,now 0.25-4 all [installed,automatic]
python2.7/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
python2.7-dev/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
python2.7-minimal/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
python3/stable,now 3.5.3-1 armhf [installed,automatic]
python3-apt/stable,now 1.1.0~beta5 armhf [installed,automatic]
python3-minimal/stable,now 3.5.3-1 armhf [installed,automatic]
python3.5/stable,now 3.5.3-1 armhf [installed,automatic]
python3.5-minimal/stable,now 3.5.3-1 armhf [installed,automatic]
Simono
Posts: 142
Joined: Mon Sep 17, 2018 5:26 pm

Fri Sep 21, 2018 5:10 pm

U mnie jest tak jakby ale u mnie wywala te błędy:

Code: Select all


pi@raspberrypi:~ $ sudo apt list --installed | grep python

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

dh-python/stable,now 2.20170125 all [installed,automatic]
libpython-all-dev/stable,now 2.7.13-2 armhf [installed,automatic]
libpython-dev/stable,now 2.7.13-2 armhf [installed,automatic]
libpython-stdlib/stable,now 2.7.13-2 armhf [installed,automatic]
libpython2.7/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
libpython2.7-dev/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
libpython2.7-minimal/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
libpython2.7-stdlib/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
libpython3-stdlib/stable,now 3.5.3-1 armhf [installed,automatic]
libpython3.5/stable,now 3.5.3-1 armhf [installed,automatic]
libpython3.5-minimal/stable,now 3.5.3-1 armhf [installed,automatic]
libpython3.5-stdlib/stable,now 3.5.3-1 armhf [installed,automatic]
python/stable,now 2.7.13-2 armhf [installed]
python-all/stable,now 2.7.13-2 armhf [installed,automatic]
python-all-dev/stable,now 2.7.13-2 armhf [installed,automatic]
python-apt-common/stable,now 1.1.0~beta5 all [installed,automatic]
python-cffi-backend/stable,now 1.9.1-2 armhf [installed,automatic]
python-crypto/stable,now 2.6.1-7 armhf [installed,automatic]
python-cryptography/stable,now 1.7.1-3+b2 armhf [installed,automatic]
python-dbus/stable,now 1.2.4-1 armhf [installed,automatic]
python-dev/stable,now 2.7.13-2 armhf [installed,automatic]
python-enum34/stable,now 1.1.6-1 all [installed,automatic]
python-gi/stable,now 3.22.0-2 armhf [installed,automatic]
python-idna/stable,now 2.2-1 all [installed,automatic]
python-ipaddress/stable,now 1.0.17-1 all [installed,automatic]
python-keyring/stable,now 10.1-1 all [installed,automatic]
python-keyrings.alt/stable,now 1.3-1 all [installed,automatic]
python-minimal/stable,now 2.7.13-2 armhf [installed,automatic]
python-pip/stable,now 9.0.1-2+rpt2 all [installed]
python-pip-whl/stable,now 9.0.1-2+rpt2 all [installed,automatic]
python-pkg-resources/stable,now 33.1.1-1 all [installed,automatic]
python-pyasn1/stable,now 0.1.9-2 all [installed,automatic]
python-rpi.gpio/stable,now 0.6.3~stretch-1 armhf [installed]
python-secretstorage/stable,now 2.3.1-2 all [installed,automatic]
python-setuptools/stable,now 33.1.1-1 all [installed,automatic]
python-six/stable,now 1.10.0-3 all [installed,automatic]
python-wheel/stable,now 0.29.0-2 all [installed,automatic]
python-xdg/stable,now 0.25-4 all [installed,automatic]
python2.7/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
python2.7-dev/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
python2.7-minimal/stable,now 2.7.13-2+deb9u2 armhf [installed,automatic]
python3/stable,now 3.5.3-1 armhf [installed,automatic]
python3-apt/stable,now 1.1.0~beta5 armhf [installed,automatic]
python3-minimal/stable,now 3.5.3-1 armhf [installed,automatic]
python3.5/stable,now 3.5.3-1 armhf [installed,automatic]
python3.5-minimal/stable,now 3.5.3-1 armhf [installed,automatic]
Wie ktoś co mam robić aby działało? Cały czas docker i php bin/console dość obciąża CPU maliny.
Simono
Posts: 142
Joined: Mon Sep 17, 2018 5:26 pm

Fri Sep 21, 2018 7:16 pm

Koledzy stawiam na innej maszynie z linuksem, mam na nim między innymi TVHeadend. Wywala mi:

Code: Select all

ERROR: for supla-cloud  Cannot start service supla-cloud: driver failed programming external connectivity on endpoint supla-cloud (ac4c6377aa1a014c7d3f54eba132c86f2c30116321ee38187d8d36c032fa00b3): Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use
Edit:
wywaliłem apache (został po czymś)
Simono
Posts: 142
Joined: Mon Sep 17, 2018 5:26 pm

Fri Sep 21, 2018 7:36 pm

Jeśli wywala mi

Code: Select all


In CreateConfirmedUserCommand.php line 69:

  Invalid e-mail address

co mam zrobić?

Edit:
Jakoś poradziłem sobie, ruszyła :) teraz spróbuje urządzenie dodać.
Nie idzie wpisuje do Sonoff hasło lokalizacji i wywala: Bad credentials :(
Simono
Posts: 142
Joined: Mon Sep 17, 2018 5:26 pm

Mon Sep 24, 2018 6:56 am

Koledzy, trzy razy od zera próbowałem instalować na raspberry według instrukcji z githuba i ciągle było coś nie tak. Wczoraj zainstalowałem zgodnie z poradnikiem kolegi lesny8 i instalacja przebiegła bez większych problemów, także wielkie dzięki dla niego za ten poradnik. Mam w tej chwili też zainstalowaną i użytkowaną na "dużym" linuksie. Wolę jednak przenieść się na malinę (wiem może paść karta SD, zrobię sobie kopie raz na miesiąc w locie na NAS i raz kiedyś obraz karty offline).
Reasumując wielkie dzięki za przygotowanie i oba poradniki, wszystko świetnie działa.
User avatar
michael
Posts: 851
Joined: Wed Nov 09, 2016 8:00 am
Location: Wojkowice

Mon Sep 24, 2018 7:08 am

Jakbyś potrzebował działający backup na malinę to już kiedyś opisywałem tutaj:

viewtopic.php?p=7638#p7638

ps. od tamtej pory działa u mnie po dziś dzień i nic mi się nigdy nie rozjechało
Kabel ucięty na miarę zawsze jest za krótki...
Simono
Posts: 142
Joined: Mon Sep 17, 2018 5:26 pm

Sun Sep 30, 2018 10:51 am

Używałem podobnego rozwiązania gdy malina miała inne zastosowanie. Backup obrazu trwał jakieś 20 minut chyba po LAN. Teraz niestety malina łączy się po WiFi tylko, karta WiFi w Raspberry Pi3 łączy się maks chyba na 54MB więc szału raczej nie będzie z czasem wykonywania kopii obrazu. Plan mam taki, że wszystko mam po konfigurowane, najważniejsze urządzenia dopięte. Dzisiaj robię kopię obrazu offline i dokładam raz na miesiąc na NAS kopię online.
Post Reply