Raspberry PI - Instalacja dockerowa

Moderator: fracz

dar3cz3k_
Posty: 38
Rejestracja: śr mar 07, 2018 10:20 pm
Lokalizacja: Brudzowice

ndz mar 11, 2018 7:25 am

ja też miałem ten problem i pomogło to co poradziła @fracz

viewtopic.php?p=19748#p19748


tylko przed wykonaniem:

Kod: Zaznacz cały

./supla.sh start
edytuj ponownie plik
.env
Ostatnio zmieniony ndz mar 11, 2018 7:36 am przez dar3cz3k_, łącznie zmieniany 1 raz.
dar3cz3k_
Posty: 38
Rejestracja: śr mar 07, 2018 10:20 pm
Lokalizacja: Brudzowice

ndz mar 11, 2018 7:34 am

Jak poprawnie uruchomić całość po "awari zasilania"

wykonując:

Kod: Zaznacz cały

pi@raspberrypi:~/supla-docker $ ./supla.sh start
ARM architecture detected. Adjusting configuration.
Starting SUPLA containers
Building supla-cloud

[..]

Step 9/9 : CMD ["/usr/bin/supervisord", "--nodaemon", "--configuration", "/etc/supervisor/conf.d/supervisord.conf"]
 ---> Using cache
 ---> 715b0950dab1
Successfully built 715b0950dab1
Successfully tagged supla_supla-server:latest
Starting supla-db ... error

ERROR: for supla-db  Cannot start service supla-db: container "afea472c107b70960b9732a867aab45ae8f3e5e3f4f4c83ad60aa2a8cc26e4d3": already exists

ERROR: for supla-db  Cannot start service supla-db: container "afea472c107b70960b9732a867aab45ae8f3e5e3f4f4c83ad60aa2a8cc26e4d3": already exists
ERROR: Encountered errors while bringing up the project.
Nie uruchamia się, problem jest chyba już działający container docker`a

Kod: Zaznacz cały

pi@raspberrypi:~/supla-docker $ docker ps -a
CONTAINER ID        IMAGE                   COMMAND                  CREATED             STATUS                           PORTS                                      NAMES
5caf1c682d71        supla_supla-server      "/usr/bin/server-ent…"   33 hours ago        Exited (255) About an hour ago   0.0.0.0:2015-2016->2015-2016/tcp           supla-server
bc1ce5bd5cdd        supla_supla-cloud       "docker-php-entrypoi…"   33 hours ago        Exited (255) About an hour ago   0.0.0.0:80->80/tcp, 0.0.0.0:443->443/tcp   supla-cloud
afea472c107b        hypriot/rpi-mysql:5.5   "/entrypoint.sh mysq…"   33 hours ago        Exited (255) About an hour ago   3306/tcp                                   supla-db
moim rozwiązaniem było reczne usunięcie tego container`a i ponowne uruchomienie

Kod: Zaznacz cały

pi@raspberrypi:~/supla-docker $ docker container rm afea472c107b
afea472c107b

pi@raspberrypi:~/supla-docker $ ./supla.sh start
ale, czy jest inne bardziej automatyczne rozwiązanie?
kris.sg
Posty: 154
Rejestracja: pn sie 07, 2017 8:08 pm
Lokalizacja: Przezchlebie

ndz mar 11, 2018 7:48 am

fracz pisze:
pn lut 12, 2018 4:36 pm
Lector pisze:
pn lut 12, 2018 7:39 am
Niestety CRON nie wypalił, przy wyłączonym zasilaniu czas stoi, więc rano jak włączą prąd to godzina jest ta która była przy wyłączeniu.
To zrób inaczej. Niech się już zamyka to tak chamsko, ale przy włączeniu rano trzeba posprzątać i odpalić na nowo.

Zrób sobie nowy skrypt w katalogu supla-docker, np. clean-boot.sh:

Kod: Zaznacz cały

#!/usr/bin/env bash

cd "$(dirname "$0")"

docker-compose rm -fs
./supla.sh start
Następnie w pliku supla-docker/docker-compose.yml usuń wszystkie linie (3x) konfigurujące automatyczny restart kontenerów, np: https://github.com/SUPLA/supla-docker/b ... ose.yml#L6

I na koniec skonfiguruj malinę tak by uruchamiała skrypt clean-boot.sh przy starcie systemu. Tu masz info jak: https://raspberrypi.stackexchange.com/a/8735
tu masz rozwiązanie
wystarczylo przejrzeć wątek
fast
Posty: 11
Rejestracja: pt mar 09, 2018 8:12 pm

ndz mar 11, 2018 6:06 pm

dar3cz3k_ pisze:
ndz mar 11, 2018 7:25 am
ja też miałem ten problem i pomogło to co poradziła @fracz

viewtopic.php?p=19748#p19748


tylko przed wykonaniem:

Kod: Zaznacz cały

./supla.sh start
edytuj ponownie plik
.env
Prawie tak jak mówisz, chociaż coś tam z wcześniejszych postów musiałem dodać i w końcu można było uruchomić
./supla.sh start
bez od razu wyskakującego błędu ale sobie nie skopiowałem go. Ale przy kolejnej instalacji naprawiłem swój błąd i skopiowałem komunikat:

Kod: Zaznacz cały

ERROR: .IOError: [Errno 2] No such file or directory: u'./docker-compose.arm32v7.yml'
ale teraz rzeczywiście dłuuuugo się instaluje i zatrzymuje się na czerwonych komunikatach:

Kod: Zaznacz cały

converted 'https://github.com/SUPLA/supla-cloud/releases/download/v2.1.6/supla-cloud  -v2.1.6.tar.gz' (ANSI_X3.4-1968) -> 'https://github.com/SUPLA/supla-cloud/releases/download/v2.1.6/supla-cloud-v2.1.6.tar.gz' (UTF-8)
--2018-03-11 16:25:34--  https://github.com/SUPLA/supla-cloud/releases/download/v2.1  .6/supla-cloud-v2.1.6.tar.gz
Resolving github.com (github.com)... 192.30.253.112, 192.30.253.113
Connecting to github.com (github.com)|192.30.253.112|:443... connected.
i niestety przez godzinę nie przechodzi dalej, ale trochę jeszcze poczekam

...po 2 godzinach zrezygnowałem :)
fast
Posty: 11
Rejestracja: pt mar 09, 2018 8:12 pm

śr mar 14, 2018 7:58 am

Lector pisze:
pt mar 09, 2018 8:46 pm
Dziś zamówiłem drugie Pi Zero W, jak dojdzie to będę na przykładzie pisał. Też miałem problemy i dokładnie już nie pamiętam w którym mocie coś zmieniałem.
Pierwsze jest u mnie w pracy i nie chciał bym rozłączać.
Czy doszła już do Ciebie nowa sztuka ? No i czy udało się ponownie postawić SUPLĘ ?
Mnie zatrzymuje się instalacja jak w poprzednim poście.
Awatar użytkownika
Lector
Posty: 575
Rejestracja: pt lis 17, 2017 2:26 pm
Lokalizacja: Poznań
Kontaktowanie:

śr mar 14, 2018 10:09 am

Idzie i już na PW komuś też pomogło.
Będę w domu to napiszę w FAQ.
Nie spełniony automatyk.
XiaomiFans.PL
Awatar użytkownika
Lector
Posty: 575
Rejestracja: pt lis 17, 2017 2:26 pm
Lokalizacja: Poznań
Kontaktowanie:

śr mar 14, 2018 2:38 pm

viewtopic.php?f=23&t=3218

Dziś postaram się jeszcze dopisać jak zrobić autostart.

Mam już kod, ale chcę go trochę uporządkować.
Nie spełniony automatyk.
XiaomiFans.PL
bialy
Posty: 5
Rejestracja: pn wrz 17, 2018 10:45 am

pn wrz 17, 2018 11:24 am

Postawiłem dockerową suplę na Raspbianie, wszystko działa. Przy rejestracji nowego usera wysyła się mail do aktywacji konta, wszystko gra. Ale jak chcę odzyskać hasło, generowany jest błąd i jest to niemożliwe. W .env mailer skonfigurowany prawidłowo, ponieważ wychodzą maile do rejestracji, ale odzysk hasła jest niemożliwy. Jakieś pomysły?
Awatar użytkownika
pzygmunt
Posty: 8867
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

pn wrz 17, 2018 11:27 am

Logi ?
bialy
Posty: 5
Rejestracja: pn wrz 17, 2018 10:45 am

pn wrz 17, 2018 12:27 pm

Nic ciekawego nie widać w logach, ale podłączę w wolnej chwili.
ODPOWIEDZ

Wróć do „supla-docker”