Raspberry PI - Instalacja dockerowa

Moderator: fracz

User avatar
lesny8
Posts: 689
Joined: Mon Dec 11, 2017 9:43 pm

Thu Apr 18, 2019 8:34 am

michu300
Posts: 3
Joined: Mon Apr 15, 2019 12:37 pm

Thu Apr 18, 2019 10:46 am

Dzięki, poszło!!!
alchemik86
Posts: 2
Joined: Fri Apr 26, 2019 8:16 pm

Fri Apr 26, 2019 8:29 pm

Witam wszystkich. Próbuję zainstalować Suplę na Pi 3B+ ale stanąłem na błędzie

pi@supla:~/supla-docker $ ./supla.sh start
Starting SUPLA containers
ERROR: Couldn't connect to Docker daemon at http+docker://localhost - is it running?

If it's at a non-standard location, specify the URL with the DOCKER_HOST environment variable.

Czy ktoś jest w stanie pomóc mi rozwiązać problem?
softone13
Posts: 2
Joined: Sat May 11, 2019 6:22 pm

Sat May 11, 2019 6:30 pm

Witam, obserwuję forum od jakiego czasu no i nadszedł moment, że chciałbym także mieć własną suplę na malince.
Niestety utknąłem na instalacji docker-compose. Zaznaczam tu, że nie jestem znawcą linuxa (mam z nim niewiele do czynienia i tylko czysto hobbistycznie). Prośba o pomoc.
Tu kawałek loga z instalacji docker-compose:

Using cached https://files.pythonhosted.org/packages ... 3.0.tar.gz
Complete output from command python setup.py egg_info:
Package libffi was not found in the pkg-config search path.
Perhaps you should add the directory containing `libffi.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libffi' found
Package libffi was not found in the pkg-config search path.
Perhaps you should add the directory containing `libffi.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libffi' found
Package libffi was not found in the pkg-config search path.
Perhaps you should add the directory containing `libffi.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libffi' found
Package libffi was not found in the pkg-config search path.
Perhaps you should add the directory containing `libffi.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libffi' found
Package libffi was not found in the pkg-config search path.
Perhaps you should add the directory containing `libffi.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libffi' found
c/_cffi_backend.c:15:17: fatal error: ffi.h: Nie ma takiego pliku ani katalogu
#include <ffi.h>

^
compilation terminated.
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/tmp/pip-build-6t38X9/pynacl/setup.py", line 255, in <module>
"Programming Language :: Python :: 3.7",
File "/usr/lib/python2.7/distutils/core.py", line 111, in setup
_setup_distribution = dist = klass(attrs)
File "/usr/lib/python2.7/dist-packages/setuptools/dist.py", line 317, in __init__
self.fetch_build_eggs(attrs['setup_requires'])
File "/usr/lib/python2.7/dist-packages/setuptools/dist.py", line 372, in fetch_build_eggs
replace_conflicting=True,
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 846, in resolve
dist = best[req.key] = env.best_match(req, ws, installer)
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 1118, in best_match
return self.obtain(req, installer)
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 1130, in obtain
return installer(requirement)
File "/usr/lib/python2.7/dist-packages/setuptools/dist.py", line 440, in fetch_build_egg
return cmd.easy_install(req)
File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 699, in easy_install
return self.install_item(spec, dist.location, tmpdir, deps)
File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 725, in install_item
dists = self.install_eggs(spec, download, tmpdir)
File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 906, in install_eggs
return self.build_and_install(setup_script, setup_base)
File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 1145, in build_and_install
self.run_setup(setup_script, setup_base, args)
File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 1133, in run_setup
raise DistutilsError("Setup script exited with %s" % (v.args[0],))
distutils.errors.DistutilsError: Setup script exited with error: command 'arm-linux-gnueabihf-gcc' failed with exit status 1

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-6t38X9/pynacl/
User avatar
lesny8
Posts: 689
Joined: Mon Dec 11, 2017 9:43 pm

Sat May 11, 2019 6:55 pm

Zerknij sobie i zainstaluj
softone13
Posts: 2
Joined: Sat May 11, 2019 6:22 pm

Sat May 11, 2019 8:30 pm

Dziękuję. Widziałem, że brakuje tego libffi tylko nie wiedziałem, że do instalacji jest libffi-dev :roll:
Dzięki jeszcze raz
User avatar
lesny8
Posts: 689
Joined: Mon Dec 11, 2017 9:43 pm

Sat May 11, 2019 9:29 pm

Nie ma za co ;) Przy okazji spytam, jaki model masz RPi?
kkarnas
Posts: 2
Joined: Sun Feb 17, 2019 5:20 pm

Sun Jul 28, 2019 11:43 am

Instalacja Supli na Docker jest ....
Walczę z nią od paru miesięcy ( z przerwami) i albo jedno nie działa albo coś innego. Próbowałem wg niniejszej instrukcji, wg tego https://github.com/SUPLA/supla-docker i wg tego viewtopic.php?f=23&t=4081 .
Napiszę tylko jedno.
Gratuluje tym , którym się udało i działa.

Po co udostępniać oprogramowanie "dla mas", skoro pewnie informatycy po studiach i z 10 letnią praktyką trybią czemu coś nie działa jak powinno działać.

Idę bawić się Domoticzem. Instaluje się od kopa bez żadnych kombinacji.
User avatar
lesny8
Posts: 689
Joined: Mon Dec 11, 2017 9:43 pm

Sun Jul 28, 2019 1:46 pm

Zamiast wylewać gorzkie żale, napisałbyś w którym miejscu stoisz z tą instalacją, na jakim sprzęcie i systemie. Wielu osobom się udało uruchomić, ale oni się nie chwalą tym faktem, a tym którzy mają problemy pomagamy na bieżąco.
User avatar
pzygmunt
Posts: 6449
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Sun Jul 28, 2019 8:28 pm

Docker nie działa „od kopa” na każdym Pi.
Post Reply