Page 1 of 15

Tryb proxy (poprawne certyfiakty SSL, Let's Encrypt)

Posted: Sat Jan 13, 2018 10:14 pm
by fracz

Re: Tryb proxy (poprawne certyfiakty SSL, Let's Encrypt)

Posted: Fri Jan 19, 2018 8:57 am
by dawkor
Jest jakiś prosty tutorial po polsku ?:D nie znam angielskiego i 2 dzień się już wykładam nad zrobieniem proxy :(

Re: Tryb proxy (poprawne certyfiakty SSL, Let's Encrypt)

Posted: Fri Jan 19, 2018 9:22 am
by fracz
Na czym się wykładasz?

BTW, czy ktoś testował w ogóle to proxy na malinach? Z tego co widzę, może mieć jakieś problemy: https://github.com/JrCs/docker-letsencr ... issues/316

Re: Tryb proxy (poprawne certyfiakty SSL, Let's Encrypt)

Posted: Fri Jan 19, 2018 9:53 am
by dawkor
jak będziesz chciał to mogę ci dać dostęp do maliny i spróbujesz czy da się zainstalować proxy :D Kopie karty mam zrobiona :D, zapomniałem już komunikat, ale wykładało się na wystartowaniu kontenera, będę później próbował ponownie to wkleję komunikat.

Re: Tryb proxy (poprawne certyfiakty SSL, Let's Encrypt)

Posted: Tue Jan 30, 2018 7:37 pm
by siba
fracz wrote:
Fri Jan 19, 2018 9:22 am
Na czym się wykładasz?

BTW, czy ktoś testował w ogóle to proxy na malinach? Z tego co widzę, może mieć jakieś problemy: https://github.com/JrCs/docker-letsencr ... issues/316
Ja spróbowałem trybu proxy na raspberry pi 3 i niby instalacja się powiodła, ale po uruchomieniu proxy dostaję taki komunikat w logach:

Code: Select all

standard_init_linux.go:195: exec user process caused "exec format error"
kontenery nginx-letsencrypt oraz nginx-gen w kółko się restartują

Re: Tryb proxy (poprawne certyfiakty SSL, Let's Encrypt)

Posted: Tue Jan 30, 2018 8:53 pm
by fracz
Więc wygląda na to, że na malinach trzeba próbować postawić proxy stąd: https://github.com/buchdag/multiarch-le ... ginx-proxy i ewentualnie zplusować to issue: https://github.com/JrCs/docker-letsencr ... issues/316

Re: Tryb proxy (poprawne certyfiakty SSL, Let's Encrypt)

Posted: Tue Jan 30, 2018 9:36 pm
by siba
fracz wrote:
Tue Jan 30, 2018 8:53 pm
Więc wygląda na to, że na malinach trzeba próbować postawić proxy stąd: https://github.com/buchdag/multiarch-le ... ginx-proxy i ewentualnie zplusować to issue: https://github.com/JrCs/docker-letsencr ... issues/316
Spróbowałem i niby wszystko ruszyło i kontenery nginx-proxy już działają i nie restartują się ale nadal nie mam dostępu przez przeglądarkę do clouda. Dostaję coś takiego w logu z nginx-proxy-le:

Code: Select all

2018-01-30 21:24:03,589:INFO:simp_le:1538: Retrieving Let's Encrypt latest Terms of Service.
2018-01-30 21:24:09,510:INFO:simp_le:1455: Generating new certificate private key
2018-01-30 21:24:44,211:ERROR:simp_le:1421: CA marked some of the authorizations as invalid, which likely means it could not access
 http://example.com/.well-known/acme-challenge/X. Did you set correct path in -d example.com:path or --default_root? Are all your 
 domains accessible from the internet? Please check your domains' DNS entries, your host's network/firewall setup and your webserver 
 config. If a domain's DNS entry has both A and AAAA fields set up, some CAs such as Let's Encrypt will perform the challenge validation 
 over IPv6. If you haven't setup correct CAA fields or if your DNS provider does not support CAA, validation attempts after september 8, 
 2017 will fail.  Failing authorizations: https://acme-v01.api.letsencrypt.org/acme/authz
 /rQ6U93eAaZuXLaMvh0JxKYQz9SRRWj52poYHDqSmPgw
 
Challenge validation has failed, see error log.

Debugging tips: -v improves output verbosity. Help is available under --help.
/app
Sleep for 3600s


nginx-proxy:

Code: Select all

localhost 185.222.210.29 - - [30/Jan/2018:21:24:39 +0000] "PROPFIND / HTTP/1.1" 503 213 "-" "-"
2018/01/30 21:51:25 [emerg] 1#1: no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
nginx: [emerg] no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
2018/01/30 21:51:29 [emerg] 1#1: no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
nginx: [emerg] no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
2018/01/30 21:51:32 [emerg] 1#1: no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
nginx: [emerg] no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
2018/01/30 21:51:34 [emerg] 1#1: no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
nginx: [emerg] no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
2018/01/30 21:51:36 [emerg] 1#1: no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
nginx: [emerg] no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
2018/01/30 21:51:39 [emerg] 1#1: no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
nginx: [emerg] no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
2018/01/30 21:52:06 [emerg] 1#1: no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
nginx: [emerg] no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
2018/01/30 21:52:14 [emerg] 1#1: no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
nginx: [emerg] no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
2018/01/30 21:52:28 [emerg] 1#1: no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
nginx: [emerg] no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
2018/01/30 21:52:55 [emerg] 1#1: no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
nginx: [emerg] no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
2018/01/30 21:53:47 [emerg] 1#1: no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
nginx: [emerg] no servers are inside upstream in /etc/nginx/conf.d/default.conf:53
jakieś rady?

Re: Tryb proxy (poprawne certyfiakty SSL, Let's Encrypt)

Posted: Wed Jan 31, 2018 7:35 am
by siba
Poprawka, jednak kontener 'nginx' z multiarch-letsencrypt-nginx-proxy nadal się restartuje co kilkanaście sekund. Na początku jak były zatrzymane kontenery z suplą to działał stabilnie ale po ich uruchomieniu zaczął kuleć i logi jak powyżej.

Re: Tryb proxy (poprawne certyfiakty SSL, Let's Encrypt)

Posted: Wed Jan 31, 2018 7:44 am
by fracz
Z logów wynika że skonfigurowana w pliku .env domena nie prowadzi do Twojej maliny

Re: Tryb proxy (poprawne certyfiakty SSL, Let's Encrypt)

Posted: Wed Jan 31, 2018 9:34 am
by siba
Zdecydowałem że zmodyfikuję mój ostatni post bo nic nie wnosił nowego.