Dziwna sytuacja z ponownym połączeniem

Awatar użytkownika
Goral64
Posty: 2007
Rejestracja: pt gru 27, 2019 6:22 pm

Dzisiaj naszła mnie tak dziwna sytuacja z mewką, która pojawiła się podczas wprowadzania kilkudziesięciu zmian w urządzeniach wprowodzanych w cloudzie, co jak wiadomo za każdym zapisem restartuje połączenia urządzeń z serwerem. Po kilkunastu takich zerwaniach połączenia mewka (v2.8.24) nie potrafiła się już połączyć z powrotem z serwerem Supli. Sprawdziłem na kontrolerze Unifi i wyglądało na problem z uzyskaniem adresu DHCP przez mewkę, bo była na liście urządzeń, ale bez adresu IP. Wymuszenie ponownego połączenia z kontrolera Unifi nie przyniosło skutku. Dopiero wprowadzenie urządzenia w tryb CONFIG i wyjście z tego trybu (czyli de facto restart urządzenia) naprawiło sytuację i mewka prawie natychmiast (niczym minirowek) połączyła się z serwerem.
Nie wiem czym jest podyktowane wymuszanie rozłączenia połączenia z wszystkimi urządzeniami podłączonymi do serwera zamiast tylko z tym, w którym zapisano zmiany ale jak widać poza uciążliwością przy dużej liczbie zmian, to jeszcze nieraz powoduje problemy w niektórych urządzeniach.
RPi4: Supla Cloud + Supla Scripts + Proxy + Let's Encrypt + MQTT
SUPLA: 1x MEW-01, 3x LIW-01, 3x SBW-02, 5x PNW-01, 3x ROW-01, 2x ROW-02, 2x ROW-04m, 2x ROW-07, 1x DIW-01, 1x mROW-02, 1x mSRW-01, 2x SRW-01
2x Sonoff BRIDGE RF 433, 10x Gosund SP111
Awatar użytkownika
klimasstudio
Posty: 145
Rejestracja: śr sie 28, 2019 9:35 pm
Lokalizacja: localhost
Kontakt:

Zobacz czy nie skończyła Ci się pula DHCP w ustawieniach. Ja tak też już miałem że UniFi widział sterownik supli a IP mu nie dawał. Wystarczyło na routerze w sekcji DHCP zwiększyć pule DHCP.
SONOFF: 5xBASIC+DHT22/2xBRIDGE RF433+4xDW2/3xMINI/3xTOUCH/1xTOUCH DUAL
ZAMEL: 1xPNW-01/1xSLW-01
SUPLA: 1xBME280/5xDHT11/1xDS18B20/1xSBW
V-TAC: 10xGU10 RGB+WW+CW/1xE27 RGB+WW+CW/1xSMART ROBOT
GOSUND: 9xSP111
GOOGLE: 2xHOME MINI
ODPOWIEDZ

Wróć do „ZAMEL MEW-01”