Sonoff + czujka PIR

Post Reply
PuteR
Posts: 172
Joined: Wed Dec 06, 2017 10:07 am

Wed May 16, 2018 7:14 am

Witam, jakie czujki PIR podłączacie pod sonoffy?? Które dobrze i bezproblemowo współgrają??
User avatar
Lucas
Posts: 243
Joined: Mon Jul 31, 2017 7:11 am
Location: Chrzanów

Wed May 16, 2018 7:20 am

PuteR wrote:
Wed May 16, 2018 7:14 am
Witam, jakie czujki PIR podłączacie pod sonoffy?? Które dobrze i bezproblemowo współgrają??
@Zybi pisał, że poleca takie http://propix.com.pl/pl/p/PIR-czujnik-p ... botDyn/886
I że działają stabilnie, w odróżnieniu do HC-SR501.
PuteR
Posts: 172
Joined: Wed Dec 06, 2017 10:07 am

Wed May 16, 2018 7:30 am

Dzięki za szybką odpowiedź, wypróbuje te. A macie jakiś sprytny sposób na ukrywanie ich przy lampach czy w innych miejscach?? :]
PuteR
Posts: 172
Joined: Wed Dec 06, 2017 10:07 am

Tue May 22, 2018 8:31 pm

ok, przyszła do mnie czujka PIR, ale chyba nie wiem jak tego używać albo robię coś nie tak. Do sonoffa wgrałem soft zibiego (https://github.com/zchmielak/ESP8266/bl ... p5_inv.rar) podłączyłem czujkę poprzez pul-up. I niby ok ale czujką cały czas włącza przełącznik po 3 min się wyłączy i znowu włącza dlaczego tak się dzieje?? I do czego służy ten drugi przełącznik w aplikacji??
Zybi
Posts: 1043
Joined: Sun Jun 26, 2016 4:24 pm
Contact:

Tue May 22, 2018 9:05 pm

PuteR wrote:
Tue May 22, 2018 8:31 pm
ok, przyszła do mnie czujka PIR, ale chyba nie wiem jak tego używać albo robię coś nie tak. Do sonoffa wgrałem soft zibiego (https://github.com/zchmielak/ESP8266/bl ... p5_inv.rar) podłączyłem czujkę poprzez pul-up. I niby ok ale czujką cały czas włącza przełącznik po 3 min się wyłączy i znowu włącza dlaczego tak się dzieje?? I do czego służy ten drugi przełącznik w aplikacji??
A ten wątek czytałeś?

viewtopic.php?f=11&t=2082
Szukasz alternatywnego firmware do Supli - zapraszam tu: https://github.com/zchmielak/ESP8266/tree/master/Zybi
PuteR
Posts: 172
Joined: Wed Dec 06, 2017 10:07 am

Wed May 23, 2018 6:44 am

Przyznaje się bez bicia, że nie zauważyłem tego tematu. Wiec żeby to działało jak należy trzeba by podłączyć czujnik według schematu który znajduję się pod końcem tematu :( Te schematy to dla mnie czarna magia prawdę mówiąc, więc albo se to odpuszczę albo znajdę kogoś kto to ogarnie.
Sibikk
Posts: 200
Joined: Mon Nov 07, 2016 12:42 pm
Location: Katowice

Wed May 23, 2018 7:26 am

Ale da się uruchomić bez tego układu wyłączającego, z pozycji cloud wyłączasz ten przełącznik do wyłączania czujki i powinno działać. Mi się udało uruchomić, z tym że trzeba było użyć tranzystora bo przełączenie jest wyzwalane zwarciem do gnd a pir wystawia 3,3v jak jest aktwne.
PuteR
Posts: 172
Joined: Wed Dec 06, 2017 10:07 am

Wed May 23, 2018 7:40 am

Sibikk wrote:
Wed May 23, 2018 7:26 am
Ale da się uruchomić bez tego układu wyłączającego, z pozycji cloud wyłączasz ten przełącznik do wyłączania czujki i powinno działać. Mi się udało uruchomić, z tym że trzeba było użyć tranzystora bo przełączenie jest wyzwalane zwarciem do gnd a pir wystawia 3,3v jak jest aktwne.
Jaki i gdzie ma być wlutowany ten tranzystor??
Sibikk
Posts: 200
Joined: Mon Nov 07, 2016 12:42 pm
Location: Katowice

Wed May 23, 2018 8:51 am

Powiem Ci kolego że nie pamiętam już jaki, może ktoś inny poradzi. Bazę łączysz z Out czujki A Kolektor z Pinem a emiter do GND. Oczywiście musisz zastosowac odpowiednie rezystory. Ja wiedze czerpię z forbot.pl Tobie tez polecam się podszkolić ;-)
Post Reply