Supla + ESP8266 + Adapter Gniazdka Radiowego

piomar2
Posts: 81
Joined: Fri Apr 26, 2019 5:32 pm
Location: Bukowice

Fri Aug 23, 2019 9:17 am

I sprawdź w menadżer płytek którą masz ver esp8266 by ESP8266 Community. Ja mam 2.4.2. Tu też może być problem.
Attachments
Zrzut ekranu 2019-08-23 11.12.55.png
Zrzut ekranu 2019-08-23 11.12.55.png (101.07 KiB) Viewed 210 times
piomar2
marsoonn
Posts: 11
Joined: Mon Aug 19, 2019 11:21 am

Fri Aug 23, 2019 9:32 am

Wersja 1.8.9 więc nie powinno być raczej problemów, masz może schemat/zdjęcie z dokładnego podłączenia układu? Nie wiem gdzie może być problem
marsoonn
Posts: 11
Joined: Mon Aug 19, 2019 11:21 am

Fri Aug 23, 2019 9:38 am

ESP8266 miałem 2.5.2 robię już 2.4.2
marsoonn
Posts: 11
Joined: Mon Aug 19, 2019 11:21 am

Fri Aug 23, 2019 9:48 am

Image
Attachments
narzedzia.png
narzedzia.png (85.03 KiB) Viewed 200 times
piomar2
Posts: 81
Joined: Fri Apr 26, 2019 5:32 pm
Location: Bukowice

Fri Aug 23, 2019 10:01 am

Jeżeli masz połączone jak narysowałeś to jest ok. a błąd jest gdzie indziej (może biblioteki?).
Ja używam innego układu do nagrywania.
Jak pomoże to prosze:
Attachments
IMG_20190823_115455.jpg
IMG_20190823_115455.jpg (314.48 KiB) Viewed 197 times
IMG_20190823_115449.jpg
IMG_20190823_115449.jpg (372.83 KiB) Viewed 197 times
piomar2
piomar2
Posts: 81
Joined: Fri Apr 26, 2019 5:32 pm
Location: Bukowice

Fri Aug 23, 2019 10:04 am

KOLEGO! w aduino 1.8.9 u mnie też się nie kompiluje !!!
piomar2
piomar2
Posts: 81
Joined: Fri Apr 26, 2019 5:32 pm
Location: Bukowice

Fri Aug 23, 2019 10:12 am

Sprawdziłem, że to nie jest wina biblioteki SuplaDevice a wina wersji arduino.
W 1.8.3 kompiluje się bez problemu a w 1.8.9 NIE.
Już wcześniej miałem problemy z 1.8.9 dlatego dalej używam 1.8.3 (chyba najbardziej stabilna).
piomar2
piomar2
Posts: 81
Joined: Fri Apr 26, 2019 5:32 pm
Location: Bukowice

Fri Aug 23, 2019 10:16 am

W wersji 1.8.4 też się NIE kompiluje...
Także trzeba użyć ver 1.8.3 !!!
piomar2
gigilio
Posts: 10
Joined: Sun Mar 10, 2019 7:48 pm

Sun Aug 25, 2019 5:47 pm

U mnie kompiluje pomimo błedu ...

Code: Select all

UWAGA: biblioteka SuplaDevice działa na architekturze(/architekturach) (avr) i może nie być kompatybilna z obecną płytką która działa na architekturze(/architekturach) (esp8266).
Szkic używa 360276 bajtów (34%) pamięci programu. Maksimum to 1044464 bajtów.
Zmienne globalne używają 36352 bajtów (44%) pamięci dynamicznej, pozostawiając 45568 bajtów dla zmiennych lokalnych. Maksimum to 81920 bajtów.
esptool.py v2.6
2.6
esptool.py v2.6
Serial port COM7
Connecting....
Chip is ESP8266EX
Features: WiFi
MAC: 84:0d:8e:b0:79:d3
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Auto-detected Flash size: 4MB
Compressed 364432 bytes to 258397...

Writing at 0x00000000... (6 %)
Writing at 0x00004000... (12 %)
Writing at 0x00008000... (18 %)
Writing at 0x0000c000... (25 %)
Writing at 0x00010000... (31 %)
Writing at 0x00014000... (37 %)
Writing at 0x00018000... (43 %)
Writing at 0x0001c000... (50 %)
Writing at 0x00020000... (56 %)
Writing at 0x00024000... (62 %)
Writing at 0x00028000... (68 %)
Writing at 0x0002c000... (75 %)
Writing at 0x00030000... (81 %)
Prawdopodobienstwo jest zerowe że wygrasz miliona jak nie wyślesz kuponu totolotka...
marsoonn
Posts: 11
Joined: Mon Aug 19, 2019 11:21 am

Wed Aug 28, 2019 1:13 pm

Okazało się że moduł wifi esp8266 nano jest popsuty dlatego chciałbym
zrealizować to zadania na dużym ESP8266 Nodemcu v3

Niestety wyskakują błędy nawet podczas kompilacji programu,
Posiadam wersje 1.8.3 Arduino
Attachments
69352115_2436959383245792_8056906919815675904_n.jpg
69352115_2436959383245792_8056906919815675904_n.jpg (48.23 KiB) Viewed 93 times
69329433_510865572788912_4420469577578708992_n.jpg
69329433_510865572788912_4420469577578708992_n.jpg (37.11 KiB) Viewed 93 times
69092470_503585170408942_7147187835265613824_n.jpg
69092470_503585170408942_7147187835265613824_n.jpg (37.65 KiB) Viewed 93 times
Post Reply