Dziwna awaria  ( zawieszenie ) routera  ( AP )

Awatar użytkownika
pzygmunt
Posty: 7711
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

śr lis 27, 2019 6:52 pm

Generalnie stare IP jeszcze trochę zostaną. Będziemy informować wszystkich użytkowników, którzy używają zamiast domen adresów IP aby w ciągu kilku miesięcy zmienili konfigurację. Zmieniamy IP-ki na takie, które mogą być migrowane na inne maszyny. Obecne są na sztywno przypisane do VPS-ów. W przypadku awarii podmiana maszyny będzie problematyczna z uwagi na to, że mały procent userów używa adresów zamiast domen. Ta migracja rozwiąże ten problem.

Co do incydentu.
W tym przypadku problem widzę wyłącznie w DDOS-ie jaki powstał przy globalnym restarcie.
Muszę temu zaradzić na przyszłość.
Patryk
Posty: 700
Rejestracja: pn sty 07, 2019 7:51 pm

śr lis 27, 2019 7:00 pm

@pzygmunt dobrze, że napisałeś o zmianie ip.
Ja osobiście w wszystkich modułach, zamiast nazwy serwera stosuje ip.
Czyli mógłbym mieć za jakiś czas problem, gdyż by mi przestały działać wszystkie moduły i nie miał bym pojęcia czemu.
dydyrydy
Posty: 82
Rejestracja: pt mar 01, 2019 7:35 pm

śr lis 27, 2019 7:16 pm

Mi póki co nadal nie działa a objawy w dniu dzisiejszym identyczne jak u poprzedników. :?
Moja Supla: ;)
2 x Yunshan (brama garażowa i furtka)
1 x Sonoff SV (brama wjazdowa)
2 x Sonoff Basic (oświetlenie)
Awatar użytkownika
pzygmunt
Posty: 7711
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

śr lis 27, 2019 7:28 pm

Wyślij na priv-a adres email na którym masz konto
dydyrydy
Posty: 82
Rejestracja: pt mar 01, 2019 7:35 pm

śr lis 27, 2019 7:39 pm

Poszło
Moja Supla: ;)
2 x Yunshan (brama garażowa i furtka)
1 x Sonoff SV (brama wjazdowa)
2 x Sonoff Basic (oświetlenie)
Awatar użytkownika
pzygmunt
Posty: 7711
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

śr lis 27, 2019 7:43 pm

Gdzie poszło ?
dydyrydy
Posty: 82
Rejestracja: pt mar 01, 2019 7:35 pm

śr lis 27, 2019 7:51 pm

Wiadomość prywatna. Sorki, wcześniej nie wpisałem tematu i nawet nie zobaczylem, że nie wyslałem.
Moja Supla: ;)
2 x Yunshan (brama garażowa i furtka)
1 x Sonoff SV (brama wjazdowa)
2 x Sonoff Basic (oświetlenie)
Awatar użytkownika
pzygmunt
Posty: 7711
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

śr lis 27, 2019 8:06 pm

3 urządzenia są online. Zmień tak jak @Patryk coś w ustawieniach na cloud.supla.org to wymusisz ich restart
dydyrydy
Posty: 82
Rejestracja: pt mar 01, 2019 7:35 pm

śr lis 27, 2019 8:52 pm

Ok. Wyłączyłem i włączyłem jedno urządzenie w cloudzie i już śmiga. Dzięki
Moja Supla: ;)
2 x Yunshan (brama garażowa i furtka)
1 x Sonoff SV (brama wjazdowa)
2 x Sonoff Basic (oświetlenie)
Awatar użytkownika
pzygmunt
Posty: 7711
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

czw lis 28, 2019 4:40 pm

Problem polegał głównie na ilości jednoczesnych połączeń do mysql-a przy restarcie serwera. Efekt był taki, że nie wszystkie dane kanałów się ładowały z uwagi na to, że mysql odmawiał zwrócenia danych z uwagi na limity. Problem rozwiązany. Aktualizacja dzisiaj leci na produkcję.

[EDIT]
łatka wrzucona na produkcję. Zbiegło się to ze zmianą IP ale nie miało z tym związku. W "dobrym" momencie się to stało co pozwoliło szybciej ustalić w czym problem. Gdyby incydent zdarzył się np gdy OVH zmieniałoby ustawienia firewalla resetując połączenia to moglibyśmy nie wpaść na to w czym problem. Problem dotyczył około 1% losowych użytkowników.
ODPOWIEDZ