Supla<->MQTT - Instalacja

Beku
Posty: 409
Rejestracja: wt lis 06, 2018 1:49 pm

ndz cze 14, 2020 7:32 am

Niestety nie posiadam liw-01 żeby to sprawdzić. Powinien działać jak impulsecounter, a te widzę ze powinny publikować wartości.... jak znajdę czas to spróbuje to jakoś zasymulować.
Awatar użytkownika
Goral64
Posty: 611
Rejestracja: pt gru 27, 2019 6:22 pm

ndz cze 14, 2020 8:23 am

Mój LIW podpięty jest pod impulsator wodomierza, więc to channel_type: 330 (WATERMETER), który ma zdefiniowany payload_template. Jednak na MQTT Explorer nie pokazuje odczytu dla tego kanału.
RPi4: Supla Cloud + Supla Scripts + Proxy + Let's Encrypt
1x MEW-01, 1x LIW-01, 2x SBW-02, 2x PNW-01, 1x ROW-01, 1x ROW-02, 2x ROW-04m, 1x ROW-07,
2x Sonoff BRIDGE RF 433
This is only the beggining...
Beku
Posty: 409
Rejestracja: wt lis 06, 2018 1:49 pm

ndz cze 14, 2020 1:55 pm

Goral64 pisze:
ndz cze 14, 2020 8:23 am
Mój LIW podpięty jest pod impulsator wodomierza, więc to channel_type: 330 (WATERMETER), który ma zdefiniowany payload_template. Jednak na MQTT Explorer nie pokazuje odczytu dla tego kanału.
Zobacz plik state.yaml w katalogu config. Nie wiem czy jest tam wpisany channel_type 330. Jeśli nie to możesz spróbować zmienić ten 320.
Awatar użytkownika
Goral64
Posty: 611
Rejestracja: pt gru 27, 2019 6:22 pm

ndz cze 14, 2020 2:28 pm

@Beku, jest wpisany jako:

Kod: Zaznacz cały

  - channel_type: 330 
    payload_template: '{"totalCost":$totalCost$, "pricePerUnit":$pricePerUnit$, "impulsesPerUnit":$impulsesPerUnit$, "counter":$counter$, "calculatedValue":$calculatedValue$, "currency":"$currency$", "unit":"$unit$"}'
RPi4: Supla Cloud + Supla Scripts + Proxy + Let's Encrypt
1x MEW-01, 1x LIW-01, 2x SBW-02, 2x PNW-01, 1x ROW-01, 1x ROW-02, 2x ROW-04m, 1x ROW-07,
2x Sonoff BRIDGE RF 433
This is only the beggining...
Sxorpio
Posty: 11
Rejestracja: pn maja 25, 2020 8:32 am
Lokalizacja: Bełchatów

wt lip 07, 2020 11:16 am

Witam wszystkich.
Nie wiem co robię źle. Na ubuntu 20.04 Supla MQTT client zainstalowałem bez większych problemów.
Zakupiłem RPI 4B i schody. Po entej kompilacji cały czas przy uruchomieniu wyskakuje błąd.

pi@raspberrypi:~/supla-core/supla-mqtt-client/Release $ ./supla-mqtt-client -config /home/pi/supla-core/supla-mqtt-client/config_template.yaml
INFO[1594120265.733940] initializing main loop
INFO[1594120265.737170] Client GUID: AE146529B73CC0A40AC4BEB742C4FF13
configuration file missing [parameter -config]

Bardzo proszę o pomoc.
Awatar użytkownika
Goral64
Posty: 611
Rejestracja: pt gru 27, 2019 6:22 pm

wt lip 07, 2020 12:16 pm

W ścieżce do konfigu brakuje Ci jeszcze katalogu /config
Polecenie powinno być

Kod: Zaznacz cały

./supla-mqtt-client -config /home/pi/supla-core/supla-mqtt-client/config/config_template.yaml
RPi4: Supla Cloud + Supla Scripts + Proxy + Let's Encrypt
1x MEW-01, 1x LIW-01, 2x SBW-02, 2x PNW-01, 1x ROW-01, 1x ROW-02, 2x ROW-04m, 1x ROW-07,
2x Sonoff BRIDGE RF 433
This is only the beggining...
Sxorpio
Posty: 11
Rejestracja: pn maja 25, 2020 8:32 am
Lokalizacja: Bełchatów

wt lip 07, 2020 8:04 pm

Dziękuję za pomoc. Aż wstyd że ślepota mnie ogarnęła :)

Teraz następny problem.

Loguję się do mqtt przez MQTT explorer bez problemu. Gdy uruchamiam supla mqtt cloud pojawia się błąd:

w mqtt log:

New client connected from 172.30.32.1 as homeassistant (p2, c0, k400, u'darek').
1594151706: Socket error on client homeassistant, disconnecting.

w bash:

INFO[1594151678.796499] initializing main loop
INFO[1594151678.797572] Client GUID: 5F3227B3ECBC6E0010EED56685D3A673
INFO[1594151678.800745] SSL version: OpenSSL 1.1.1d 10 Sep 2019
INFO[1594151678.806871] Connecting...
NOTICE[1594151681.10058] Access Identifier not assigned!


Dodam że w config_template.yaml podaję ten sam login i hasło co w mqtt explorer.
wyczerpałem już wszystkie znane mi możliwości.

Pomóżcie :)
Awatar użytkownika
pzygmunt
Posty: 9401
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

wt lip 07, 2020 8:05 pm

Wejdź na cloud.supla.org. Smartfony -> Klient MQTT -> Przypisz Access ID.
Sxorpio
Posty: 11
Rejestracja: pn maja 25, 2020 8:32 am
Lokalizacja: Bełchatów

wt lip 07, 2020 8:11 pm

Aż mi głupio. Dzisiaj dzień mojej ciemnoty :lol: :lol: :lol:

Dziękuję za pomoc.
Awatar użytkownika
pzygmunt
Posty: 9401
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

wt lip 07, 2020 9:08 pm

Spokojnie. Ten komunikat nie jest zbyt jasny.
ODPOWIEDZ

Wróć do „MQTT”