Supla<->MQTT - Instalacja

tomautohome
Posty: 3
Rejestracja: pn wrz 28, 2020 7:48 pm

śr wrz 30, 2020 6:52 am

w ramach samopomocy
tomautohome pisze:
pn wrz 28, 2020 9:12 pm

Kod: Zaznacz cały

#template for gate, garage door
#payload: {"idx": 3, "hi": 1}
 - topic: 'supla/channels/command/brama'
   id: '/idx'
   shut: '/hi'
Incorrect offset: line xxxx
Ten błąd był wynikiem pozostawienia zbędnej spacji przed -topic:
sprawa błaha, MQTT Explorer widzi urządzenia supli

Teraz nauka sterowania....
Awatar użytkownika
uchnast.michal
Posty: 371
Rejestracja: wt cze 04, 2019 11:37 am
Lokalizacja: Czeladź
Kontaktowanie:

śr wrz 30, 2020 7:02 pm

Nie mogę ogarnąć pobrania stanu POWERSWITCH po restarcie supla_virtual_device, zawsze mam OFF :( Po przełączeniu z poziomu mqtt lub Supli stan się zgadza. Ktoś podpowie co robię źle?

json wygląda tak:

Kod: Zaznacz cały

{"Time":"2020-09-30T20:00:52","Uptime":"0T00:00:12","UptimeSec":12,"Heap":31,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":1,"POWER":"ON","Wifi":{"AP":1,"Channel":3,"RSSI":42,"Signal":-79,"LinkCount":1,"Downtime":"0T00:00:06"}}

Kod: Zaznacz cały

[CHANNEL_6]
function=POWERSWITCH
state_topic=tele/Zawor_1/STATE
payload_value=/POWER
command_topic=cmnd/Zawor_1/POWER
available_topic=tele/Zawor_1/LWT
state_on=ON
state_off=OFF
command_template=$value$
payload_on=ON
payload_off=OFF
payload_available=Online
payload_not_available=Offline
#retain=true
e-talking............
mariusz2200#
Posty: 5
Rejestracja: pt paź 02, 2020 6:16 am

pt paź 02, 2020 8:53 am

Dzień dobry!
Z wielkimi problemami, ale udało mi się zainstalować supla-mqtt-client.
Po uruchomieniu nie sypie już błędami, jest status "Connecting..."
Mam dodane urządzenie na serwerze supla.org, jednak w MQTT explorer nie pojawiają się żadne informacje.
MEW-01 jest jedynym urządzeniem podłączonym do Supli.
Jak mogę podejrzeć gdzie jest błąd?
Sibikk
Posty: 312
Rejestracja: pn lis 07, 2016 12:42 pm
Lokalizacja: Katowice

pt paź 02, 2020 11:34 am

mariusz2200# pisze:
pt paź 02, 2020 8:53 am
Dzień dobry!
Z wielkimi problemami, ale udało mi się zainstalować supla-mqtt-client.
Po uruchomieniu nie sypie już błędami, jest status "Connecting..."
Mam dodane urządzenie na serwerze supla.org, jednak w MQTT explorer nie pojawiają się żadne informacje.
MEW-01 jest jedynym urządzeniem podłączonym do Supli.
Jak mogę podejrzeć gdzie jest błąd?
viewtopic.php?f=46&t=5026&p=64936...
mariusz2200#
Posty: 5
Rejestracja: pt paź 02, 2020 6:16 am

pt paź 02, 2020 12:23 pm

Chodzi o to, że dostaję odpowiedź: "on_remote_call_received: 50"
Nie wysyła jednak do MQTT...


Obrazek
Załączniki
mqtt.png
mqtt.png (74.35 KiB) Przejrzano 160 razy
mariusz2200#
Posty: 5
Rejestracja: pt paź 02, 2020 6:16 am

pn paź 05, 2020 3:24 pm

Ok. Sam odpowiem. Chodzi o to, że w supla cloud nie przypisałem lokalizacji.
Po przypisaniu licznika i "SUPLA MQTT Proxy" do tej samej lokalizacji, zaczęło działać!
Pozdrawiam.
Awatar użytkownika
nowy1
Posty: 325
Rejestracja: pt lip 01, 2016 11:51 am
Lokalizacja: Warszawa

śr paź 14, 2020 4:08 pm

Ktoś próbował instalować na Synology ? może docker
ODPOWIEDZ

Wróć do „MQTT”