Supla<->MQTT - Instalacja

Beku
Posty: 348
Rejestracja: wt lis 06, 2018 1:49 pm

wt lut 04, 2020 10:39 am

Rawq pisze:
wt lut 04, 2020 10:27 am
Sukces! Dziękuje :)
Jest połączenie, rozumiem, że za każdym razem muszę ręcznie startować z tego polecenia aby uruchomić proxy ?
Możesz uruchomić usługę

Po przetestowaniu działania (pamiętamy, aby na supla-cloud włączyć rejestrację smartfonów!!!), możemy pokusić się o "autostart".
Aby uruchamiać wszystko jako usługę, która sama wstanie po crashu wykonaj poniższe kroki:

sudo nano supla_mqtt.service

wklej do niego i odpowiednio dostosuj poniższy kod:

[Unit]
Description=SUPLA MQTT Broker
After=network.target

[Service]
ExecStart=/home/pi/supla-core/supla-mqtt-client/Release/supla-mqtt-client -config /home/pi/config_template.yaml
WorkingDirectory=/home/pi/supla-core/supla-mqtt-client/Release
StandardOutput=inherit
StandardError=inherit
Restart=always
User=pi

[Install]
WantedBy=multi-user.target

następnie skopiuj ten plik w następujący sposób:


sudo cp supla_mqtt.service /etc/systemd/system

następnie sprawdź czy usługa się uruchamia poleceniem:


sudo systemctl start supla_mqtt.service

aby sprawdzić czy działa klient możesz użyć polecenia

sudo journalctl -f -u supla_mqtt

wynik komendy powinien być podobny do tego, który już znasz

jeśli jest uruchomiony wykonaj

sudo systemctl stop supla_mqtt.service

sprawdź czy się zatrzymał:


sudo journalctl -f -u supla_mqtt

jeśli jest ok czyli usługa startuje i zatrzymuje się, pozostaje ją tylko zainstalować aby się uruchamiała przy starcie maliny


sudo systemctl enable supla_mqtt.service


usługa powinna sama się restartować w przypadku crash'u.
możesz sprawdzić czy się uruchomiła, jesli nie, to ją uruchom (nie pamiętam czy trzeba)
Rawq
Posty: 21
Rejestracja: ndz lut 02, 2020 11:06 am

wt lut 04, 2020 1:01 pm

Działa dziękuje
Rawq pisze:
wt lut 04, 2020 10:27 am
usługa powinna sama się restartować w przypadku crash'u.
możesz sprawdzić czy się uruchomiła, jesli nie, to ją uruchom (nie pamiętam czy trzeba)
nie podnosi się sama przy starcie systemu, przy crash'u pewnie wstanie

EDIT
Żeby się podnosiła przy starcie trzeba dać wpis
sudo systemctl enable supla_mqtt.service
Beku
Posty: 348
Rejestracja: wt lis 06, 2018 1:49 pm

wt lut 04, 2020 3:44 pm

Rawq pisze:
wt lut 04, 2020 1:01 pm
Działa dziękuje
Rawq pisze:
wt lut 04, 2020 10:27 am
usługa powinna sama się restartować w przypadku crash'u.
możesz sprawdzić czy się uruchomiła, jesli nie, to ją uruchom (nie pamiętam czy trzeba)
nie podnosi się sama przy starcie systemu, przy crash'u pewnie wstanie

EDIT
Żeby się podnosiła przy starcie trzeba dać wpis
sudo systemctl enable supla_mqtt.service
no tak własnie napisałem
Rawq
Posty: 21
Rejestracja: ndz lut 02, 2020 11:06 am

wt lut 04, 2020 7:09 pm

Tak, coś się zakręciłem i nie zauważyłem ;)
Rawq
Posty: 21
Rejestracja: ndz lut 02, 2020 11:06 am

śr lut 05, 2020 10:28 am

Konfiguracja w Home Assistant
Mam problem Mosquito Broker w HA nie pokazuje, żadnych integracji a na pozór wszystko jest ok:
1. HA łączy się do brokera
2. supla_client łączy się do brokera
3. MQTT Explerer pokazuje stan włącznika światła z Supla Cloud

configuration.yaml

Kod: Zaznacz cały

mqtt:
  broker: 127.0.0.1
  port: 1883
  client_id: homeassistant
  keepalive: 60
  username: !secret mqtt_user
  password: !secret mqtt_pass
  protocol: 3.1

switch: !include switch.yaml
light: !include light.yaml
light.yaml

Kod: Zaznacz cały

- platform: mqtt
  schema: template  
  name: "Lampka sypialnia"
  state_topic: "supla/channels/status/relay/4917"  
  command_topic: "supla/channels/command/4917"
  command_on_template: '{ "idx": 4917, "on": 1 }'
  command_off_template: '{ "idx": 4917, "on": 0 }'
  state_template: '{{ "on" if value_json.on else "off" }}'
Ten włącznik nie jest aktualnie podłączony do zasilania czy to może być przyczyna?
Beku
Posty: 348
Rejestracja: wt lis 06, 2018 1:49 pm

śr lut 05, 2020 8:01 pm

@mariusz_70 robił integracje przez MQTT do HA, odezwij się do niego to Ci pewnie pomoże 🙂
mariusz_70
Posty: 69
Rejestracja: czw lis 10, 2016 5:51 pm

czw lut 06, 2020 12:40 pm

Kod: Zaznacz cały

  command_on_template: '{ "idx": 4917, "on": true }'
  command_off_template: '{ "idx": 4917, "on": false }'
Rawq
Posty: 21
Rejestracja: ndz lut 02, 2020 11:06 am

pn lut 10, 2020 5:54 pm

mariusz_70 pisze:
czw lut 06, 2020 12:40 pm

Kod: Zaznacz cały

  command_on_template: '{ "idx": 4917, "on": true }'
  command_off_template: '{ "idx": 4917, "on": false }'
Dziękuje działa
tomekk87
Posty: 75
Rejestracja: pt sie 02, 2019 12:19 pm

śr lut 12, 2020 12:03 pm

Cześć

Kolega @fracz napisał fajne narzędzie SUPLA Filesensors, dzięki któremu wysyłam za pomocą wirtualnego czujnika PRESSURESENSOR do supli odczyt ciśnieni atmosferycznego. Proszę o info i pomoc jak zamieścić ten odczyt w Dashboard Supla MQTT Client. Wykorzystanie kanału temperatury nie sprawdza się bo nie wyświetla wartości powyżej 1000.
Jak zaimplementować odczyt z wirtualnego czujnika PRESSURESENSOR do Supla MQTT Client?

Pozdrawiam
Tomekk
Beku
Posty: 348
Rejestracja: wt lis 06, 2018 1:49 pm

śr lut 12, 2020 3:53 pm

tomekk87 pisze:
śr lut 12, 2020 12:03 pm
Cześć

Kolega @fracz napisał fajne narzędzie SUPLA Filesensors, dzięki któremu wysyłam za pomocą wirtualnego czujnika PRESSURESENSOR do supli odczyt ciśnieni atmosferycznego. Proszę o info i pomoc jak zamieścić ten odczyt w Dashboard Supla MQTT Client. Wykorzystanie kanału temperatury nie sprawdza się bo nie wyświetla wartości powyżej 1000.
Jak zaimplementować odczyt z wirtualnego czujnika PRESSURESENSOR do Supla MQTT Client?

Pozdrawiam
Tomekk

Aby odczyty tego kanału były wysyłane do MQTT musisz edytować plik state.yaml i dopisać tam:

Kod: Zaznacz cały


  - channel_type: 260 #PRESSURESENSOR
    payload_template: '{"id": $id$, "pressure": $value$, "online": $online$}'

Następnie restart klienta.
ODPOWIEDZ