Supla<->MQTT - Instalacja

Rawq
Posty: 21
Rejestracja: ndz lut 02, 2020 11:06 am

pn mar 02, 2020 2:39 pm

Dzięki :)
A sensory otwarcia zamknięcia da radę ogarnąć?
Beku
Posty: 357
Rejestracja: wt lis 06, 2018 1:49 pm

pn mar 02, 2020 3:30 pm

Rawq pisze:
pn mar 02, 2020 2:39 pm
Dzięki :)
A sensory otwarcia zamknięcia da radę ogarnąć?
A te sensory masz w supli podpięte pod bramę ?
Rawq
Posty: 21
Rejestracja: ndz lut 02, 2020 11:06 am

pn mar 02, 2020 3:47 pm

Tak :)
Beku
Posty: 357
Rejestracja: wt lis 06, 2018 1:49 pm

pn mar 02, 2020 3:51 pm

Rawq pisze:
pn mar 02, 2020 3:47 pm
Tak :)
No to ich wartości są w MQTT w tym miejscu gdzie jest informacja o bramie. Wartości sensorów widać w sensor_1 i sensor_2
Rawq
Posty: 21
Rejestracja: ndz lut 02, 2020 11:06 am

pn mar 02, 2020 5:31 pm

Beku pisze:
pn mar 02, 2020 3:51 pm
Rawq pisze:
pn mar 02, 2020 3:47 pm
Tak :)
No to ich wartości są w MQTT w tym miejscu gdzie jest informacja o bramie. Wartości sensorów widać w sensor_1 i sensor_2
Słusznie, dziękuję
Awatar użytkownika
PuteR
Posty: 805
Rejestracja: śr gru 06, 2017 10:07 am

ndz mar 08, 2020 10:30 pm

Mam coś takiego

Kod: Zaznacz cały

pi@raspberrypi:~ $ git clone https://github.com/SUPLA/supla-core.git
fatal: destination path 'supla-core' already exists and is not an empty directory.
Można jakoś zmienić katalog?? Co zrobić by ruszyć dalej??
Beku
Posty: 357
Rejestracja: wt lis 06, 2018 1:49 pm

ndz mar 08, 2020 10:41 pm

PuteR pisze:
ndz mar 08, 2020 10:30 pm
Mam coś takiego

Kod: Zaznacz cały

pi@raspberrypi:~ $ git clone https://github.com/SUPLA/supla-core.git
fatal: destination path 'supla-core' already exists and is not an empty directory.
Można jakoś zmienić katalog?? Co zrobić by ruszyć dalej??
Próbujesz pobrać repozytorium do już istniejącego katalogu . Pytanie co chcesz zrobić?

Już wcześniej pobierałeś źródła supli skoro masz katalog supla-core.

Najlepiej załóż jakiś inny katalog np. Supla-mqtt wejdź do niego i w nim zrób git-clone.
Awatar użytkownika
PuteR
Posty: 805
Rejestracja: śr gru 06, 2017 10:07 am

ndz mar 08, 2020 11:06 pm

Wcześniej instalowałem supła-dev dlatego mam już supła-core

W każdym razie zrobiłem jak mówiłeś - utworzyłem nowy katalog i zrobiłem git clone, ale po skopiowaniu jak chce wejść do katalogu

Kod: Zaznacz cały

cd supla-core/supla-mqtt-client/Release
Wywala że

Kod: Zaznacz cały

pi@raspberrypi:~/Supla-mqtt $ cd supla-core/supla-mqtt-client/Release
-bash: cd: supla-core/supla-mqtt-client/Release: Nie ma takiego pliku ani katalogu
Beku
Posty: 357
Rejestracja: wt lis 06, 2018 1:49 pm

pn mar 09, 2020 5:40 am

PuteR pisze:
ndz mar 08, 2020 11:06 pm
Wcześniej instalowałem supła-dev dlatego mam już supła-core

W każdym razie zrobiłem jak mówiłeś - utworzyłem nowy katalog i zrobiłem git clone, ale po skopiowaniu jak chce wejść do katalogu

Kod: Zaznacz cały

cd supla-core/supla-mqtt-client/Release
Wywala że

Kod: Zaznacz cały

pi@raspberrypi:~/Supla-mqtt $ cd supla-core/supla-mqtt-client/Release
-bash: cd: supla-core/supla-mqtt-client/Release: Nie ma takiego pliku ani katalogu
Musisz wejść do katalogu supla-core i wpisać:

Kod: Zaznacz cały

git checkout supla-mqtt-client

To wszystko jest w opisie instalacji.
opok_junior
Posty: 5
Rejestracja: ndz lis 03, 2019 11:34 pm

pn mar 16, 2020 9:09 am

Witam,
Mam problem z instalacją, a tak właściwie z wystartowaniem.
Pacjent: RPi4 4gb = Raspbian + HA na dockerze + Mosquitto na HA

config_template.yaml

Kod: Zaznacz cały

mqtt
  host: '192.168.1.160'  
  port: 1883
  commands_file_path: '/home/pi/supla-core/supla-mqtt-client/config/command.yaml'
  states_file_path: '/home/pi/supla-core/supla-mqtt-client/config/state.yaml'
  client_name: 'supla_mqtt_client'
  username: 'xxxx'
  password: 'xxxx'
  protocol_version: 3
  publish_supla_events: true
supla:
  port: 2016
  host: 'svrXX.supla.org'
  protocol_version: 10
  email: 'XXX@gmail.com'
Odpowiedź konsoli:

Kod: Zaznacz cały

INFO[1584348945.203124] initializing main loop
INFO[1584348945.203981] Client GUID: 9E8E3E4F7057705C70F7051F44DACE6C
Invalid quote. Line 1: mqtt
INFO[1584348945.204841] SSL version: OpenSSL 1.1.1d  10 Sep 2019
INFO[1584348945.209059] Connecting...
mqtt client error MQTT_ERROR_CONNACK_FORBIDDEN_CODE
mqtt client error MQTT_ERROR_CONNACK_FORBIDDEN_CODE
mqtt client error MQTT_ERROR_CONNACK_FORBIDDEN_CODE
mqtt client error MQTT_ERROR_CONNACK_FORBIDDEN_CODE
mqtt client error MQTT_ERROR_CONNACK_FORBIDDEN_CODE
mqtt client error MQTT_ERROR_CONNACK_FORBIDDEN_CODE
mqtt client error MQTT_ERROR_CONNACK_FORBIDDEN_CODE
mqtt client error MQTT_ERROR_CONNACK_FORBIDDEN_CODE
mqtt client error MQTT_ERROR_CONNACK_FORBIDDEN_CODE
mqtt client error MQTT_ERROR_CONNACK_FORBIDDEN_CODE
ERR[1584348947.232739] Bad credentials!
Próbowałem zmieniać config_template.yaml na różne sposoby, spędziłem nad tym trochę czasu i skończyły mi się pomysły.
Proszę o pomoc, bo znając życie, problem jest błachy :D
ODPOWIEDZ

Wróć do „MQTT”