Natywne wsparcie dla MQTT

hoauser
Posty: 9
Rejestracja: wt gru 15, 2020 7:23 pm

śr sty 13, 2021 3:25 pm

yamaha0014 pisze:
śr sty 06, 2021 2:14 pm
Czy login na becie jest inny? Trzeba konto nowe tworzyć?
istniejący login do cloud.supla.org nie działa
trzeba tworzyć nowego użytkownika dla https://beta-cloud.supla.org
hipek189
Posty: 4
Rejestracja: śr sty 13, 2021 4:22 pm

śr sty 13, 2021 4:25 pm

wkradła sie błąd w instrukcji powinno być
remote_username
remote_password

Pozdrawiam
zalus
Posty: 44
Rejestracja: czw sty 04, 2018 12:29 pm

śr sty 13, 2021 4:41 pm

witam
ktoś wie co jest nie ok.
w brokerze mam takie logi:
1610555982: Socket error on client local.core-mosquitto.bridge-01, disconnecting.
1610555988: Connecting bridge bridge-01 (beta-mqtt.supla.org:8883)
1610555990: Socket error on client local.core-mosquitto.bridge-01, disconnecting.
1610555996: Connecting bridge bridge-01 (beta-mqtt.supla.org:8883)
1610555999: Socket error on client local.core-mosquitto.bridge-01, disconnecting.
urządzenie z supli jest widoczne w HA ale reaguje na zmianę stanu za którymś naciśnięciem
Awatar użytkownika
pzygmunt
Posty: 10047
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

śr sty 13, 2021 6:34 pm

Spróbuj bezpośrednio podłączyć się pod mqtt broker Supli i sprawdź czy wtedy ha będzie tak samo się zachowywać.

Ewentualnie spróbuj zmienić po out w configu dodać 2 czyli

out 2

Co znaczy qos 2
hipek189
Posty: 4
Rejestracja: śr sty 13, 2021 4:22 pm

śr sty 13, 2021 7:36 pm

Witam nie mogę uruchomić MQTT bridge mam takie ustawienia
logins:
- username: admin
password: admin
anonymous: false
customize:
active: true
folder: mosquitto
certfile: fullchain.pem
keyfile: privkey.pem
require_certificate: false
brige.conf :

connection bridge-01
address beta-mqtt.supla.org:8883
topic supla/# in
topic homeassistant/# in
topic supla/+/devices/+/channels/+/execute_action out
topic supla/+/devices/+/channels/+/set/+ out
remote_username xxxxxxx@gmail.com
remote_password xxxxxxxxxxxxxxxxxx
bridge_capath /etc/ssl/certs

logg:

[20:33:49] INFO: Setup mosquitto configuration
[20:33:49] WARNING: SSL not enabled - No valid certs found!
[20:33:49] INFO: Found local users inside config
[20:33:50] INFO: Initialize Hass.io Add-on services
[20:33:50] INFO: Initialize Home Assistant discovery
[20:33:50] INFO: Start Mosquitto daemon
1610566430: Loading config file /share/mosquitto/bridge.conf
1610566430: mosquitto version 1.6.3 starting
1610566430: Config loaded from /etc/mosquitto.conf.
1610566430: Loading plugin: /usr/share/mosquitto/auth-plug.so
1610566430: |-- *** auth-plug: startup
1610566430: ├── Username/password checking enabled.
1610566430: ├── TLS-PSK checking enabled.
1610566430: └── Extended authentication not enabled.
1610566430: Opening ipv4 listen socket on port 1883.
1610566430: Opening ipv6 listen socket on port 1883.
1610566430: Opening websockets listen socket on port 1884.
1610566430: Warning: Mosquitto should not be run as root/administrator.
1610566430: Connecting bridge bridge-01 (beta-mqtt.supla.org:8883)
1610566430: New connection from 192.168.1.38 on port 1883.
[INFO] found admin on local database
1610566431: New client connected from 192.168.1.38 as mosqsub|225-DAFANG (p1, c1, k60, u'admin').
1610566432: New connection from 192.168.1.60 on port 1883.
1610566432: New client connected from 192.168.1.60 as 11M3lvrZNA1ftgte7EmfQr (p2, c1, k60, u'admin').
1610566434: Socket error on client local.core-mosquitto.bridge-01, disconnecting.

przez node-red łaczy sie z brokerem

prosze o pomoc
Pozdrawiam
Ostatnio zmieniony śr sty 13, 2021 7:47 pm przez hipek189, łącznie zmieniany 1 raz.
Awatar użytkownika
pzygmunt
Posty: 10047
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

śr sty 13, 2021 7:45 pm

Sprawdź czy możesz się telnetnąć na beta-mqtt.supla.org:8883

Może firewall trzyma
hipek189
Posty: 4
Rejestracja: śr sty 13, 2021 4:22 pm

śr sty 13, 2021 7:54 pm

przez node-red(hassio) działa z zaznaczonym
Enable secure (SSL/TLS) connection
inaczej nie działa
Awatar użytkownika
pzygmunt
Posty: 10047
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

śr sty 13, 2021 8:02 pm

OK, już wiem w czym problem. Nie należy podawać takiej samej nazwy połączenia jak inni użytkownicy.
czyli zamiast bridge-01 wstawiamy np. bridge-Mc93nmflsnf czyli jakiś random. Inaczej połączenia o tej samej nazwie wzajemnie się wyrzucają.
Awatar użytkownika
pzygmunt
Posty: 10047
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

śr sty 13, 2021 8:09 pm

zalus pisze:
śr sty 13, 2021 4:41 pm
witam
ktoś wie co jest nie ok.
w brokerze mam takie logi:
1610555982: Socket error on client local.core-mosquitto.bridge-01, disconnecting.
1610555988: Connecting bridge bridge-01 (beta-mqtt.supla.org:8883)
1610555990: Socket error on client local.core-mosquitto.bridge-01, disconnecting.
1610555996: Connecting bridge bridge-01 (beta-mqtt.supla.org:8883)
1610555999: Socket error on client local.core-mosquitto.bridge-01, disconnecting.
urządzenie z supli jest widoczne w HA ale reaguje na zmianę stanu za którymś naciśnięciem
Tu będzie też problem z nazwą połączenia. Zmień bridge-01 na bridge-RANDOM

(w random wstaw przypadkowy ciąg znaków)
hipek189
Posty: 4
Rejestracja: śr sty 13, 2021 4:22 pm

śr sty 13, 2021 8:26 pm

Dzięki działa :lol:
ODPOWIEDZ

Wróć do „MQTT”