Raspberry PI Extenstion 01 – SD Card Image -> don't boot

Post Reply
Atzek
Posts: 11
Joined: Fri Jul 12, 2019 5:44 am

Fri Jul 12, 2019 7:09 am

Hi everyone,

I have a RASPBERRY PI 3 B +
- I downloaded the software https://www.supla.org/download/rbpiext01.zip
- I transferred the .img file to SD with "balenaEtcher" (os Debian stretch)
- I insert the SD in the RB, but nothing happens. (the green LED does not flash)

Where am I wrong?

PS: Sorry for the English (I'm using google traslator)

Thanks in advance.

Armando
Atzek
Posts: 11
Joined: Fri Jul 12, 2019 5:44 am

Sat Jul 13, 2019 8:02 pm

Thanks for the reply.

I followed step by step "Device start-up on a Windows based computer" , but RB don't boot...

Does the image work on pi 3?
User avatar
pzygmunt
Posts: 6649
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Sun Jul 14, 2019 9:49 am

B+
Atzek
Posts: 11
Joined: Fri Jul 12, 2019 5:44 am

Tue Jul 23, 2019 9:30 pm

Hi,
I did some tests and these are the results:

1. Raspberry PI Extenstion 01 - SD Card Image -> don't boot

2. SD card image for Raspberry PI 2/3 including software SUPLA-CLOUD -> don't boot

( incompatibility with RPI PI 3 B +??)


3. Cloning from github "SUPLA / supla-core" -> the rpi connects with the server.

output OK

However, I have a problem reading the temperature. I tried with DHT22 and DS18B20, but with both I have the error:
"Error .....: Can't read 1-wire device …"
any advice?

tnx
Atzek
Posts: 11
Joined: Fri Jul 12, 2019 5:44 am

Fri Jul 26, 2019 11:12 am

Config.txt is ok:
#OneWire
dtoverlay=w1-gpio
I can read the sensor:
pi@raspberrypi:/sys/bus/w1/devices/28-0320977994ef $ cat w1_slave
b8 01 55 05 7f a5 a5 66 36 : crc=36 YES
b8 01 55 05 7f a5 a5 66 36 t=27500
but, when I start supla:
pi@raspberrypi:~/supla-core/supla-dev/Release $ ./supla-dev -c ./supla.cfg
ERR[1564138391.78455] Can't read 1-wire device 04
INFO[1564138391.79728] SSL version: OpenSSL 1.1.1c 28 May 2019

This my supla.cfg DS18B20 detail
# Available types: SENSORNO,RELAYHFD4,RELAYG5LA1A,2XRELAYG5LA1A,THERMOMETERDS18B2$
# Help: https://forum.supla.org

[CHANNEL_0]
type=THERMOMETERDS18B20
w1=04

[CHANNEL_1]
type=RELAYG5LA1A
gpio1=17
PS:I I have tried other values for w1, but I always have the same result

TNX



PS2: I followed these instructions:
SUPLA-DEV

Make a SUPLA-managed device from your RaspberryPI (or any other linux).

Installation
sudo apt-get install libssl-dev
git clone https://github.com/SUPLA/supla-core
cd supla-core/supla-dev/Release
make all
cp supla.cfg.sample supla.cfg


Edit supla.cfg to match your needs.

Run
cd supla-core/supla-dev/Release
./supla-dev -c ./supla.cfg


Configure autostart

TODO

Upgrade

Stop supla-dev if running and
cd supla-core
git pull
cd supla-dev/Release
make all
User avatar
pzygmunt
Posts: 6649
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków
Contact:

Fri Jul 26, 2019 11:30 am

supla.cfg

Code: Select all

[CHANNEL_0]
type=THERMOMETERDS18B20
w1=28-0320977994ef
Atzek
Posts: 11
Joined: Fri Jul 12, 2019 5:44 am

Fri Jul 26, 2019 4:47 pm

it works.
Super!!!

Tnx
Post Reply