ESP 01 i konfiguracja

besix
Posty: 263
Rejestracja: ndz mar 20, 2016 9:51 pm

pn maja 16, 2016 8:09 pm

besix
Posty: 263
Rejestracja: ndz mar 20, 2016 9:51 pm

pn maja 16, 2016 8:11 pm

Ty kolego zwierasz GPIO 2 przy starcie czy już po starcie ? Trzeba podać zasilanie i dopiero zwierać
pawel
Posty: 30
Rejestracja: pn maja 09, 2016 9:34 am

pn maja 16, 2016 8:20 pm

Wiem o tym.
Nie jestem nowicjuszem w cyfrówce.
Oczywiście firmware z termometrem nie uaktywnia sieci Supla.
Myślę, że problem jest po stronie mojego Windowsa.
Jutro spróbuję na drugim kompie, którego używam tylko do pisania programów i kompilacji.
Jak coś się zmieni, albo odkryję coś nowego, to się podzielę.
besix
Posty: 263
Rejestracja: ndz mar 20, 2016 9:51 pm

pn maja 16, 2016 8:23 pm

Ok życzę powodzenia
fork
Posty: 21
Rejestracja: pt maja 13, 2016 9:39 am

pn maja 16, 2016 8:45 pm

pawel pisze:daj link do tego firmware
https://github.com/SUPLA/ESP8266/tree/m ... ware/esp01
fork
Posty: 21
Rejestracja: pt maja 13, 2016 9:39 am

pn maja 16, 2016 8:49 pm

pawel pisze:Wiem o tym.
Nie jestem nowicjuszem w cyfrówce.
Oczywiście firmware z termometrem nie uaktywnia sieci Supla.
Myślę, że problem jest po stronie mojego Windowsa.
Jutro spróbuję na drugim kompie, którego używam tylko do pisania programów i kompilacji.
Jak coś się zmieni, albo odkryję coś nowego, to się podzielę.
Widows 10 , jakiego USB->serial uzywasz ?
pawel
Posty: 30
Rejestracja: pn maja 09, 2016 9:34 am

wt maja 17, 2016 7:56 am

Używam Win 7 Prof z przejściówką USB UART PL 2303 HX.
Na niej wszystko się ładnie programuje.
Myślisz, że w niej jest problem z Suplą firmware?
fork
Posty: 21
Rejestracja: pt maja 13, 2016 9:39 am

wt maja 17, 2016 9:47 am

pawel pisze:Używam Win 7 Prof z przejściówką USB UART PL 2303 HX.
Na niej wszystko się ładnie programuje.
Myślisz, że w niej jest problem z Suplą firmware?
Po tym jak dziś wgrałem do "niebieskiego" (esp8266-01 512KB flash) https://s3.amazonaws.com/adafruit-downl ... 2_2015.zip i spokojnie działał, wiem że to TYLKO i wyłącznie problem z obrazami SUPLA; Panowie może czegoś nie wiecie o tych czipach ? Może nie warto budować 2 plików, tylko jeden wgrywany od 0x00000 i zachować odpowiednią "integralność" pamięci ?
Jest wiele osób które posiada wcześniej zakupione esp, jak pisałem wcześniej mam ich 7szt, mam je teraz wyrzucić bo nie działają ?
vcompl
Posty: 156
Rejestracja: pn kwie 11, 2016 1:32 pm

wt maja 17, 2016 11:13 am

Za fork - podobnie jak on z sukcesem do ESP-01 "niebieskiego" wgrywałem rożne firmware i wszystkie działały. Prośba, tak jak inni aby ludzie z SUPLA odnieśli sie do naszych ustaleń. Tak jak fork mam kilka tych ESP-01
fork
Posty: 21
Rejestracja: pt maja 13, 2016 9:39 am

czw maja 19, 2016 3:55 pm

MicroPython v1.8 on 2016-05-19; ESP module with ESP8266
Type "help()" for more information.
>>> esp.freemem()
23896
>>> esp.info
<function>
>>> esp.info()
_text_start=40100000
_text_end=401077ee
_irom0_text_start=40209000
_irom0_text_end=40275e68
_data_start=3ffe8000
_data_end=3ffe8410
_rodata_start=3ffe8410
_rodata_end=3ffe9038
_bss_start=3ffe9038
_bss_end=3fff5bd0
_heap_start=3fff5bd0
_heap_end=3fffc000
qstr:
n_pool=1
n_qstr=20
n_str_data_bytes=206
n_total_bytes=302
GC:
24128 total
3776 : 20352
1=88 2=21 m=16
Jakoś na niebieskim działa a SUPLA nie potrafi przełączyć 2 gpio
ODPOWIEDZ