Strona 1 z 9

Sonoff - po wgraniu firmware przestały działać

: sob lip 29, 2017 8:42 pm
autor: jigsaw87
Witam. Na 1 sonoffie zrobiłem bez problemu aktualizacje firmware. Dokupiłem 3 kolejne sztuki. Dwie po wgraniu firmware już nie działają. Próbowałem kasować pamięć metodą z tej strony http://www.pratikpanda.com/completely-f ... sh-memory/ . Wgrywając pusty plik. Nie mam już pomysłu co jeszcze mogę zrobić. Pomocy. Pozdrawiam Marcin

Re: Sonoff - po wgraniu firmware przestały działać

: sob lip 29, 2017 9:00 pm
autor: slawek
1.Jakim programem flaszujesz?
2.Jakie pliki wgrywasz?
3 Jakie masz ustawienia flaszowania?

Re: Sonoff - po wgraniu firmware przestały działać

: sob lip 29, 2017 9:10 pm
autor: jigsaw87
slawek pisze:
sob lip 29, 2017 9:00 pm
1.Jakim programem flaszujesz?
NodeMCU Flasher
slawek pisze:
sob lip 29, 2017 9:00 pm

2.Jakie pliki wgrywasz?
sonoff_gate_ds18b20_noFOTA_1M_eagle.flash.bin ------------->0x00000
sonoff_gate_ds18b20_noFOTA_1M_eagle.irom0text.bin ------->0x40000

W zasadzie to już różne wersje wgrywałem.
Czy można zapchać całą pamięć ?
Może, źle kasowałem ?
kasowałem tym plikiem http://www.pratikpanda.com/wp-content/u ... nk_1MB.zip
slawek pisze:
sob lip 29, 2017 9:00 pm

3 Jakie masz ustawienia flaszowania?
Baudrate 115200
flassize 1MB
flash speed 40 mhz
spi QIO




Flasher USB UART PL2303 - może w nim leży problem? Chociaż z pierwszym razem, też nim flashowałem. Różnica jest jeszcze taka względem pierwszego działającego SONOFFA, że mam na nowa pstawionego WiN 10.

Re: Sonoff - po wgraniu firmware przestały działać

: sob lip 29, 2017 9:17 pm
autor: slawek
Nie używaj NodeMCU!!!
Dodaj plik: esp_init_data_default.bin pod adres 0xFC000
Flaszuj tym programem: http://bbs.espressif.com/download/file.php?id=385
Wyczyść wcześniej pamięć (może być plikiem blank)

Re: Sonoff - po wgraniu firmware przestały działać

: ndz lip 30, 2017 3:12 am
autor: jigsaw87
slawek pisze:
sob lip 29, 2017 9:17 pm
Nie używaj NodeMCU!!!
Dodaj plik: esp_init_data_default.bin pod adres 0xFC000
Flaszuj tym programem: http://bbs.espressif.com/download/file.php?id=385
Wyczyść wcześniej pamięć (może być plikiem blank)
Czyli:
1. najpierw wgywam plik blank_1MB.bin pod adres : 0x00000
2. następnie wgrywam
sonoff_gate_ds18b20_noFOTA_1M_eagle.flash.bin ------------->0x00000
sonoff_gate_ds18b20_noFOTA_1M_eagle.irom0text.bin ------->0x40000
oraz esp_init_data_default.bin 0xFC000 .
W takiej kolejności niestety dalej trup. Bez sensu. Pierwszy działa. Dwa pozostałe nie chcą ruszyć.

Re: Sonoff - po wgraniu firmware przestały działać

: ndz lip 30, 2017 8:11 am
autor: slawek
A w ogóle flash przebiega dobrze? Co leci na konsolę przy uruchamianiu?

Re: Sonoff - po wgraniu firmware przestały działać

: ndz lip 30, 2017 9:21 am
autor: jigsaw87
Flash wydaje się być ok, przynajmniej na moje ok. w załączniku zrzut ekranu.

Re: Sonoff - po wgraniu firmware przestały działać

: ndz lip 30, 2017 9:41 am
autor: Zybi
jigsaw87 pisze:
ndz lip 30, 2017 9:21 am
Flash wydaje się być ok, przynajmniej na moje ok. w załączniku zrzut ekranu.
Oj, namieszałeś kolego.
Jak wgrywasz plik boot_v1.5 to adres drugiego pliku nie może być 0x40000, a ponadto, czy aby na pewno prawidłowy to plik do "zestawu" z bootloaderem.

Skorzystaj z firmware z jakiejś paczki z mojego forka:

https://github.com/zchmielak/ESP8266/tr ... ybi/Sonoff

W pliku readme.txt w paczce *.rar masz wszystko opisane.
Możesz również wgrać plik esp_init_data_default, ja obecnie zawsze wgrywam ten plik.

Re: Sonoff - po wgraniu firmware przestały działać

: ndz lip 30, 2017 12:43 pm
autor: jigsaw87
Zybi pisze:
ndz lip 30, 2017 9:41 am
jigsaw87 pisze:
ndz lip 30, 2017 9:21 am
Flash wydaje się być ok, przynajmniej na moje ok. w załączniku zrzut ekranu.
Oj, namieszałeś kolego.
Jak wgrywasz plik boot_v1.5 to adres drugiego pliku nie może być 0x40000, a ponadto, czy aby na pewno prawidłowy to plik do "zestawu" z bootloaderem.

Skorzystaj z firmware z jakiejś paczki z mojego forka:

https://github.com/zchmielak/ESP8266/tr ... ybi/Sonoff

W pliku readme.txt w paczce *.rar masz wszystko opisane.
Możesz również wgrać plik esp_init_data_default, ja obecnie zawsze wgrywam ten plik.
Wgrywałem z twojej paczki przed chwilą i niestety to samo. Wgrywałem z plikiem esp_init_data_default, jak i bez. Efekt ten sam.
Proszę o napisanie instrukcji " jak dla debila", bo już nie wiem co robić. 1 sonoff z innego zamówienia 2 tyg temu poszedł elegancko. Teraz już 2 uwaliłem, został mi jeszcze jeden. Ale tego nie chciałbym już popsuć :( :(

Re: Sonoff - po wgraniu firmware przestały działać

: ndz lip 30, 2017 1:04 pm
autor: slawek
W plikach readme masz podane parametry do flaszowania - sprawdź dokładnie adresy - jeden plik masz zawsze 0x00000, natomiast drugi zależnie od wersji kompilacji może być 0x01000 (jeśli pierwszy plik to boot_v1.2 bądź boot_v1.5) lub 0x4000.
Adres dla pliku esp.init.data.. - zobacz tu: viewtopic.php?f=23&t=2081 Sonoff ma pamięć 8Mbit (czyli 1MB) więc 0xFC000.
Wyczyść przed flaszowaniem. Te moduły naprawdę ciężko uwalić... mnie jak dotąd udało się uwalić jeden ESP01- padła pamięć - ale to inna bajka...