Wgrywanie supli do sonoff

PuteR
Posts: 450
Joined: Wed Dec 06, 2017 10:07 am

Sat Feb 10, 2018 11:47 pm

Ok a w programie ESP Flash Download Toll jaką mam zaznaczyć wielkość pamięci bo najmniejsza jest 2mbity a w nodemcu miałem zaznaczać 1mbit, bo rozumiem że reszta ustawiń ma być tak samo.


size_speed : 10
test fpath: C:\Users\puter\Desktop\SonoffWiFiSmartModule\sonoff\_temp_by_dltool/downloadPanel1
test fname: C:\Users\puter\Desktop\SonoffWiFiSmartModule\sonoff\_temp_by_dltool/downloadPanel1\boot_v1.5.bin_rep
mode : speed:
write bin : C:\Users\puter\Desktop\SonoffWiFiSmartModule\sonoff\_temp_by_dltool/downloadPanel1\boot_v1.5.bin_rep
test running : False
serial port opened
Connecting...
chip sync error.
com closed

tak to wygląda z programu ESP oczywiści FAIL.
Zybi
Posts: 1239
Joined: Sun Jun 26, 2016 4:24 pm

Sat Feb 10, 2018 11:57 pm

Tu masz różności do Sonoff-a, co prawda w wersji v2.0 więc nie dodasz urządzenia do Clouda za pomocą smartfona, tylko będziesz musiał wpisać odpowiednie dane na stronie konfiguracyjnej modułu.

https://github.com/zchmielak/ESP8266/tr ... onoff/v2.0

W każdej paczce jest plik readme.txt, w którym wszystko jest napisane.

Wgraj sobie ten soft na początek:

https://github.com/zchmielak/ESP8266/bl ... 2.0_p5.rar

To tak w ramach ćwiczenia.

I wrzuć screen z wgrywania/ustawienia programu

Pamiętaj też, że po każdej nieudanej próba wgrania softu wyłącz program, odłącz sonoff-a z przejściówką od USB i ponownie wszystko zainicjuj.
PuteR
Posts: 450
Joined: Wed Dec 06, 2017 10:07 am

Sun Feb 11, 2018 12:51 am

hmm o ile wcześniej nie zepsułem modułu tak wydaje mi się że teraz to zrobiłem :( .Niby programem ESP wszystko poszło dobrze
serial port opened
Connecting...
chip sync ok!
chip_flg 1
r1: 71; r2:4e ; r3: 68
MAC AP : 1A-FE-34-71-4E-68
MAC STA: 18-FE-34-71-4E-68
('tttest uuuuuuuuuuart : uart reg: ', 458)
(' baudrate: ', 115200)
get crystal: 26380800
head: 0 ;total: 0
erase size : 0
get flash id : 0x8714405e
manufacturer_id: 0x5e

device_id: 0x4014

vendor: 94
mode: 64
size: 20
filename: C:\Users\puter\Downloads\FLASH_DOWNLOAD_TOOLS_v1.2_150512\FLASH_DOWNLOAD_TOOLS_v1.2_150512\bin_tmp\downloadPanel1\sonoff_ds18b20_1024_eagle.flash.bin_rep
offset : 0
filename: C:\Users\puter\Downloads\FLASH_DOWNLOAD_TOOLS_v1.2_150512\FLASH_DOWNLOAD_TOOLS_v1.2_150512\bin_tmp\downloadPanel1\sonoff_ds18b20_1024_eagle.irom0text.bin
offset : 262144
filename: C:\Users\puter\Downloads\FLASH_DOWNLOAD_TOOLS_v1.2_150512\FLASH_DOWNLOAD_TOOLS_v1.2_150512\bin_tmp\downloadPanel1\esp_init_data_default.bin_rep
offset : 1032192
Erasing flash...
head: 10 ;total: 10
erase size : 20480
Writing at 0x00009c00... (13 %)
Leaving...
Erasing flash...
head: 16 ;total: 61
erase size : 184320
Writing at 0x0007cc00... (99 %)
Leaving...
Erasing flash...
head: 1 ;total: 1
erase size : 4096
Writing at 0x000fc000... (99 %)
Leaving...
com closed

ale po zakonćzeniu dioda już się nie zapala, spróbowałem nawet podłaczyć coś pod urządzenie i nic dioda się nie zapala i nie widać urządzenia.
User avatar
slawek
Posts: 2035
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Sun Feb 11, 2018 1:06 am

PuteR wrote:
Sat Feb 10, 2018 11:47 pm
Ok a w programie ESP Flash Download Toll jaką mam zaznaczyć wielkość pamięci bo najmniejsza jest 2mbity a w nodemcu miałem zaznaczać 1mbit, bo rozumiem że reszta ustawiń ma być tak samo.
Masz ustawić dla sonoffa 1 MB (jeden megabajt) czyli 8Mbit (osiem megabitów) . To dla plików .1024.bin
Analogicznie dla 2048 ustawiasz 16mbit, dla 4096 - 32Mbit - czyli 4 MB (1 bajt = 8 bitów)
MB - megabajt =( 8Mbit - megabitów)
Mbit - megabit

PS. Flaszowaniem ciężko uwalić moduł, nie dotyczy to tylko pewnej serii ESP01, ale to chyba już historia...
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
PuteR
Posts: 450
Joined: Wed Dec 06, 2017 10:07 am

Sun Feb 11, 2018 6:41 am

Hmm więc czy po tym logu wygląda jak by wszystko było ok i supla została wygrana prawidłowo.?
User avatar
slawek
Posts: 2035
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Sun Feb 11, 2018 8:22 am

Powtórzę za @Zybim:
"I wrzuć screen z wgrywania/ustawienia programu"
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
PuteR
Posts: 450
Joined: Wed Dec 06, 2017 10:07 am

Sun Feb 11, 2018 6:48 pm

Ok, nie mam teraz dostępu do komputera, ale w wolnej chwili spróbuję wszystko zrobić jeszcze raz i wrzucić screeny. Czy możliwe że spaliłem bądź uszkodziłem diodę? Na jednym sonoffie z którym się bawiłem działa dalej wszystko na aplikacji ewelink ale dioda nic nie sygnalizuje. Na drogim na którym niby instalacja nowego firmware przeszla dobrze to nie działa dioda i po podłączeniu supla też go nie widzi.
PuteR
Posts: 450
Joined: Wed Dec 06, 2017 10:07 am

Sun Feb 11, 2018 8:03 pm

Wstawiam screeny z wgrywania przed rozpoczęciem, w trakcie i po zakończeniu. Niestety nie wiem czy nie zepsułem kolejnego sonoffa, jeszcze go nie podłączałem ale widzę że dioda nie mruga. :cry:
Attachments
wtrakcie.JPG
wtrakcie.JPG (183.83 KiB) Viewed 671 times
przed.JPG
przed.JPG (136.06 KiB) Viewed 671 times
po.JPG
po.JPG (175.89 KiB) Viewed 671 times
User avatar
slawek
Posts: 2035
Joined: Mon Mar 14, 2016 11:48 pm
Location: Biała Podlaska

Sun Feb 11, 2018 8:31 pm

Spróbuj z SPI MODE: DOUT
Gdy wszystkie możliwe sposoby zawiodą - pozostaje przeczytać instrukcję...
PuteR
Posts: 450
Joined: Wed Dec 06, 2017 10:07 am

Sun Feb 11, 2018 8:47 pm

Ok spróbuję jeszcze tak, ale czy możliwe że sonoff mogły zostać uszkodzone bo obecnie nie mam ich więcej, a na tym pierwszym jak próbowałem ponowne wgrywać soft to nic się działo.
Post Reply