RaspberryPi dev nie działa

admoskal
Posty: 4
Rejestracja: pn gru 25, 2017 11:32 am

pn maja 07, 2018 7:33 pm

Witam.
Mam pytanie - czy przypadkiem wczoraj około południa szanowny Admin nie dokonywał update-u softu? RPi B+ przestało się odzywać, Sonoff-y działają jak zawsze. Przywrócenie obrazu pliku nic nie pomogło, dlatego podejrzewam mocną pracę Admina :D .
Dzięki za odpowiedź.
AM
Awatar użytkownika
pzygmunt
Posty: 9443
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

pn maja 07, 2018 7:44 pm

Który serwer ? Który obraz ?
Awatar użytkownika
pzygmunt
Posty: 9443
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

pn maja 07, 2018 7:55 pm

[edit]
rozwiązanie:

uruchamiasz w konsoli (np po zalogowaniu rzez ssh) polecenie

Kod: Zaznacz cały

curl -sk https://raw.githubusercontent.com/SUPLA/raspberry/master/scripts/dev_bin_update.sh |sudo sh
admoskal
Posty: 4
Rejestracja: pn gru 25, 2017 11:32 am

wt maja 08, 2018 3:42 pm

Dzięki - pomogło.
Awatar użytkownika
Charly
Posty: 26
Rejestracja: śr mar 23, 2016 6:45 pm

pt maja 11, 2018 8:41 pm

Przydałoby się ten wątek podwiesić, lub wręcz zamieścić wiadomość, że zostało coś zrobione co uniemożliwia korzystanie z Supli na smartfonach , tym bardziej że nie działa na wcześniejszych wersjach pod Androidem, póki ktoś nie rozwali sobie całej instalacji.
Na wcześniejszych wersjach jest tylko zielony ekran z napisem Łączenie... i koniec.
Ja sam dopiero dzisiaj od niedzieli natrafiłem na ten wątek. Myślałem że jest jakaś awaria na https://cloud.supla.org/ , bo nie mogłem się tam zalogować.
Awatar użytkownika
pzygmunt
Posty: 9443
Rejestracja: wt sty 19, 2016 9:26 am
Lokalizacja: Paczków
Kontaktowanie:

pt maja 11, 2018 8:53 pm

To nic ze smartfonami nie ma wspólnego, a do wszystkich co mają rasoberry poszedł mail.
Awatar użytkownika
Charly
Posty: 26
Rejestracja: śr mar 23, 2016 6:45 pm

pt maja 11, 2018 9:23 pm

Dzięki za odpowiedź, ale do mnie jeszcze mail nie dotarł.
Sibikk
Posty: 313
Rejestracja: pn lis 07, 2016 12:42 pm
Lokalizacja: Katowice

śr maja 23, 2018 6:36 pm

Trochęo off troche nie ;-)
Pytanie.
RPI 3 Miałem ustawione GPIO8 jako wejście ale cały czas jest stan wysoki przez co supla widzi obwód jako załączony.
I pytanie moje jest czy to uszkodzone gpio czy gdzies w ustawieniach rpi można zmienić ? Próbowałem przez wiringpi ale nic to nie daje :-(

Kod: Zaznacz cały

pi@raspberrypi:~ $ gpio -g write 8 0
pi@raspberrypi:~ $ gpio readall
 +-----+-----+---------+------+---+---Pi 3---+---+------+---------+-----+-----+
 | BCM | wPi |   Name  | Mode | V | Physical | V | Mode | Name    | wPi | BCM |
 +-----+-----+---------+------+---+----++----+---+------+---------+-----+-----+
 |     |     |    3.3v |      |   |  1 || 2  |   |      | 5v      |     |     |
 |   2 |   8 |   SDA.1 |   IN | 1 |  3 || 4  |   |      | 5v      |     |     |
 |   3 |   9 |   SCL.1 |   IN | 1 |  5 || 6  |   |      | 0v      |     |     |
 |   4 |   7 | GPIO. 7 |   IN | 0 |  7 || 8  | 0 | IN   | TxD     | 15  | 14  |
 |     |     |      0v |      |   |  9 || 10 | 1 | IN   | RxD     | 16  | 15  |
 |  17 |   0 | GPIO. 0 |  OUT | 0 | 11 || 12 | 0 | IN   | GPIO. 1 | 1   | 18  |
 |  27 |   2 | GPIO. 2 |  OUT | 0 | 13 || 14 |   |      | 0v      |     |     |
 |  22 |   3 | GPIO. 3 |   IN | 0 | 15 || 16 | 1 | IN   | GPIO. 4 | 4   | 23  |
 |     |     |    3.3v |      |   | 17 || 18 | 0 | IN   | GPIO. 5 | 5   | 24  |
 |  10 |  12 |    MOSI |  OUT | 0 | 19 || 20 |   |      | 0v      |     |     |
 |   9 |  13 |    MISO |  OUT | 0 | 21 || 22 | 0 | IN   | GPIO. 6 | 6   | 25  |
 |  11 |  14 |    SCLK |  OUT | 0 | 23 || 24 | 1 | IN   | CE0     | 10  | 8   |
 |     |     |      0v |      |   | 25 || 26 | 1 | IN   | CE1     | 11  | 7   |
 |   0 |  30 |   SDA.0 |   IN | 1 | 27 || 28 | 1 | IN   | SCL.0   | 31  | 1   |
 |   5 |  21 | GPIO.21 |   IN | 0 | 29 || 30 |   |      | 0v      |     |     |
 |   6 |  22 | GPIO.22 |   IN | 1 | 31 || 32 | 0 | IN   | GPIO.26 | 26  | 12  |
 |  13 |  23 | GPIO.23 |   IN | 0 | 33 || 34 |   |      | 0v      |     |     |
 |  19 |  24 | GPIO.24 |  OUT | 0 | 35 || 36 | 1 | IN   | GPIO.27 | 27  | 16  |
 |  26 |  25 | GPIO.25 |  OUT | 0 | 37 || 38 | 0 | IN   | GPIO.28 | 28  | 20  |
 |     |     |      0v |      |   | 39 || 40 | 0 | IN   | GPIO.29 | 29  | 21  |
 +-----+-----+---------+------+---+----++----+---+------+---------+-----+-----+
 | BCM | wPi |   Name  | Mode | V | Physical | V | Mode | Name    | wPi | BCM |
 +-----+-----+---------+------+---+---Pi 3---+---+------+---------+-----+-----+
ODPOWIEDZ

Wróć do „Pomoc”