Strona 1 z 4

Brak odczytu temperatury

: wt gru 04, 2018 7:02 am
autor: krycha88
Dzisiaj wg historii na cloud wszystkie moje płytki z SUPLą przestały odczytywać temperaturę, a stało się to na każdym urządzeniu o tej samej porze 2018-12-04 00:07:45. Czy też macie taki problem?

Przekaźnik działa, ale brak odczytów z temperatury.

Re: Brak odczytu temperatury

: czw gru 13, 2018 10:15 pm
autor: Akowy
Podłączam się do tematu. Nie wiem z jakiej przyczyny Supla pokazuje temperaturę i wilgotność na ESP 8266 a po ok 1h przestaje. Urządzenia w Supli mają status jako podłączone. Zazwyczaj wyłączenie zasilania na chwilę naprawia sytuację i widać temperatura/wilgotność ale po jakimś czasie znowu przestaje. Myślałem początkowo, że to może jakiś problem sprzętowy, ale dzieje się tak na NodeMcu, Wemos D1, i przy dwóch czujnikach AM2302, więc to raczej nie kwestia sprzętu.

Re: Brak odczytu temperatury

: pt gru 14, 2018 6:24 am
autor: michael
To raczej problem wgranego firmware. Nie wiem jaki masz, ale spróbuj z innym.
Sprawdź z oficjalnych binarek czy problem też występuje.

https://github.com/SUPLA/ESP8266

Re: Brak odczytu temperatury

: pt gru 14, 2018 6:56 pm
autor: Akowy
Czujnik temperatury i wilgotności mam ASAIR AM2302. Próby wykonywałem na firmware do niego, jak i do DHT22 i z tym samym efektem. Natomiast już wiem, że czujnik przestaje pokazywać wartości w momencie zapisu jakichkolwiek zmian dla któregokolwiek urządzenia. Aktualnie w Supli mam podłączone:
- Sonoff z DS18B20
- ESP8266 z DS18B20
- ESP8266 z AM2302
Jeśli dokonam jakiejkolwiek zmiany w supli (np zmiana lokalizacji, zmiana nazwy czujnika, lub korekta wartości), to na chwilę wszystkie urządzenia są rozłączane i ponownie podłączane i to właśnie w tym momencie czujnik AM2302, przestaje pokazywać wartości. Wygląda to tak, jakby ta chwilowa przerwa po zapisie danych nie stanowiła problemu dla Firmware/Supli przy czujnikach DS18B20, ale dla AM2302, czy DHT22 już tak.

Re: Brak odczytu temperatury

: pt gru 14, 2018 7:00 pm
autor: Zybi
Dla DS18B20 też jest problem, ale właśnie testuję soft który sobie już z tym radzi.

Re: Brak odczytu temperatury

: ndz gru 16, 2018 8:26 am
autor: PLF10T
Mam to samo (SONOFF BASIC + DS), ale mam kilka takich urządzeń, z tą samą wersją oprogramowania (2.5.3), a tylko na jednym brak odczytu temperatury.

1) możliwe, że to jednak wina oprogramowania?
2) planowana jest aktualizacja oprogramowania?
3) jeśli pojawi się nowa wersja, czy urządzenie samo się zaktualizuje (ma włączoną opcję automatycznej aktualizacji)?

Re: Brak odczytu temperatury

: pn gru 17, 2018 7:08 am
autor: krycha88
Coś jest narzeczy, tylko restart modułu pomaga aby temperatura się odczytała. Czasami po restarcie odczytuje się temperatura powyżej 50 stopni która w pewnym momencie wraca do normalnych odczytów.

ja używam softu ale z przed 2 tyg:
https://github.com/Espablo/SUPLA_Firmwa ... multiboard

Który firmware nie ma tego problemu z ds18b20??

Re: Brak odczytu temperatury

: pn gru 17, 2018 8:25 am
autor: Zybi
Tydzień czasu poświęciłem na ten problem, ale mam już gotowy soft do Sonoff-a Basic-a.
Chętnych do testów proszę o kontakt na priv.

Re: Brak odczytu temperatury

: pn gru 17, 2018 8:40 am
autor: Duch__
krystianmen pisze:
pn gru 17, 2018 7:08 am
Coś jest narzeczy, tylko restart modułu pomaga aby temperatura się odczytała. Czasami po restarcie odczytuje się temperatura powyżej 50 stopni która w pewnym momencie wraca do normalnych odczytów.

ja używam softu ale z przed 2 tyg:
https://github.com/Espablo/SUPLA_Firmwa ... multiboard

Który firmware nie ma tego problemu z ds18b20??
W moim sofcie nikt nie zgłaszał takiego problemu:
viewtopic.php?f=24&t=4077

Re: Brak odczytu temperatury

: śr lut 27, 2019 9:18 pm
autor: Jarek
mam trzy moduły bramowe z ds18b20, dwa moduły esp01 z am2302 i dwa esp01 z ds18b20

każda zmiana konfiguracji przez stronę powoduje zaprzestanie działania modułów z am2302 (te z ds18b20 po chwilowej przerwie zaczynają działać)
esp01 z am2302 zawieszają się też po godzinie, czasem kilku - reszta modułów działa bez zarzutu

jest jakieś rozwiązanie tego problemu ?