Page 2 of 6

Re: ESP 8266 mod 07

Posted: Fri Mar 25, 2016 6:33 am
by pzygmunt
Podłączcie się terminalem np używając putty z ESP i dajcie znać co leci na konsolę.

Re: ESP 8266 mod 07

Posted: Fri Mar 25, 2016 8:24 am
by besix
Sławek ja zrobiłem trzy rzeczy na raz i teraz jest tak że ta 07 po wgraniu firmware i ponownym odpaleniu często sama wchodzi w tryb AP a jak nie chce to wystarczy zwarcie do masy GPIO5 na 5s i za każdym razem chodzi.
Co zrobiłem:
1 Wgrałem firmware ściągnięte z tej strony http://www.roboremo.com/flashing-nodemcu-firmware-to-esp8266.html dotyczy obsługi serwa ale ja chciałem sprawdzić czy ten moduł jest w stanie wejść w tryb AP i z tym softem wszedł.
2 ponieważ nie działało to stabilnie (raz wchodził w AP a raz nie) dołożyłem na zasilaniu kondensator 100 mikroF elektrolit i już za każdym razem wchodził w AP.
3 Po wgraniu docelowego firmware supla , moduł nie łączył się z serwerem no i na to pomogła zmiana nazwy sieci wifi, miałem nazwę dwu członową z podkreślnikiem pomiędzy wyrazami , zmieniłem na ciąg bez znaków spacji itp i ruszyło wszystko jak trzeba

Re: ESP 8266 mod 07

Posted: Fri Mar 25, 2016 9:01 am
by slawek
Po włączeniu leci kilka linijek jakichś cyferek na przemian z krzaczkami przypominającymi semigrafikę i kończy to napis :don"t use rtc mem data

Re: ESP 8266 mod 07

Posted: Fri Mar 25, 2016 10:13 am
by SebiCo
Wygląda na błędy w flashowaniu modułu, spróbuj jeszcze raz zaprogramować.

Re: ESP 8266 mod 07

Posted: Fri Mar 25, 2016 12:35 pm
by pzygmunt
Wgrałeś firmware dla wroom-a, który jest dla ESP z większym flashem

Re: ESP 8266 mod 07

Posted: Fri Mar 25, 2016 2:11 pm
by slawek
Wgrałem ten: https://github.com/SUPLA/ESP8266/tree/m ... t-firmware więc chyba dobre.
Jedyne odstępstwo od schematu to rezystory 220 zamiast 100, ale to chyba bez znaczenia - po prostu ciemniej świecą...
Zasilanie 2,27 mierzone na module - przylutowane przewody bezpośrednio z zasilacza, dodane 100nF i 100uF, pomierzyłem stany na wszystkich wyprowadzeniach, schemat sprawdzony 121 razy, flaszowałem też opcję dla rolet, bram - bez efektu.
Pozostaje totalny "reset" w święta i zmiana zawodu... kopanie dołków jest prostsze i bardziej przewidywalne.. :)
Próbowałem na 5 szt więc to nie przypadek...nie mam pojęcia gdzie tkwi błąd.

EDIT: udało mi sie na tyle, że bezpośrednio po flaszowaniu uruchamia AP, zapisuje konfig, ale nie mogę wyjść z trybu AP (podobnie jak z ESP-01).
Zflaszowałem dopiero tym programem FLASH_DOWNLOAD_TOOLS_v0.9.3.1 wgrywając jako "podkład" wersję wroom wzorując się na radzie z poprzednich postów. Dwa zflaszowane i zachowują się identycznie. Jak rozumiem dane lokalizacyjne są te same dla wszystkich moich urządzeń tzn.RPi i ESP ?

Re: ESP 8266 mod 07

Posted: Fri Mar 25, 2016 2:42 pm
by 0xFF
slawek wrote: Zasilanie 2,27 mierzone na module
Zasilanie ESP 8266 2,27V ? Powinno być 3.6V

Re: ESP 8266 mod 07

Posted: Fri Mar 25, 2016 4:22 pm
by slawek
Sorry, 3,27 - czeski błąd...

Re: ESP 8266 mod 07

Posted: Fri Mar 25, 2016 5:44 pm
by pzygmunt
Być może to mój błąd i wrzuciłem tam wersję dla wroom-a. Pobierz tą która teraz tam aktualnie jest i ją wgraj.

Re: ESP 8266 mod 07

Posted: Fri Mar 25, 2016 6:46 pm
by slawek
Eureka! jeden gotowy i połaczony z SUPLA. Oczywiście musiałem znowu zmienić program na ESP FLASH_DOWNLOAD_TOOL_V2.4 ale końcu działa jak powinno.
Dzięki wielkie i WESOŁYCH ŚWIĄT wszystkim Twórcom i sympatykom projektu.