[tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

krzychunh
Posty: 24
Rejestracja: pn lip 12, 2021 6:23 am

Witam czy na Malince 4 - jest taki sam tutorial? Po wrzuceniu na kartę pamięci otrzymuje z malinki komunikat "recover4.elf not found" "recovery.elf not found" // ruszyło na wersji Buster


W przypadku problemu z instalacją dockera gdzie występuje "pyrsistent requires Python '>=3.5' but the running Python is 2.7.16" przy poleceniu

Kod: Zaznacz cały

sudo pip install docker-compose
zmieniamy na

Kod: Zaznacz cały

sudo pip3 install docker-compose
Awatar użytkownika
mario026
Posty: 49
Rejestracja: pn sty 11, 2021 9:27 pm

edm pisze: czw maja 19, 2022 5:43 pm Chyba się same odnawiają. Czytaj tutaj https://eko.one.pl/forum/viewtopic.php?id=21942
Tym build unknown się nie sugeruj. U mnie też tak jest i działa ale na starszej wersji systemu o czym pisałem w poście z linka.
Dawno mnie tu nie było ale tak jak napisałem na openwrt jak odkomenduje się linię

Kod: Zaznacz cały

renew_before_expiry = 30 days
to certyfikaty same się odnawiają u mnie 30 dni przed końcem bo tak mam ustawione.
ps.
Ja jak zaczynałem zabawę z własnym serwerem supli to bardzo dużo mi pomógł kolega @lesny8 za co jestem mu bardzo wdzięczny ;-)
teraz na raspberry mam suplę, suplę scripts, homeasistant i serwer minicraft dla dzieciaków :)
Wszyscy mają prawo do szczęścia, ale nie wszyscy mają szczęście do prawa :D
michal13
Posty: 8
Rejestracja: pt wrz 17, 2021 5:30 pm

Pomocy walczę z tym już 2 noc wszystko na czerwono

pi@raspberrypi:~ $ sudo pip3 install docker-compose
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting docker-compose
Downloading https://www.piwheels.org/simple/docker- ... ne-any.whl (114 kB)
|████████████████████████████████| 114 kB 902 kB/s
Collecting PyYAML<6,>=3.10
Downloading https://www.piwheels.org/simple/pyyaml/ ... armv7l.whl (45 kB)
|████████████████████████████████| 45 kB 429 kB/s
Requirement already satisfied: distro<2,>=1.5.0 in /usr/lib/python3/dist-packages (from docker-compose) (1.5.0)
Collecting docopt<1,>=0.6.1
Downloading https://www.piwheels.org/simple/docopt/ ... ne-any.whl (13 kB)
Requirement already satisfied: requests<3,>=2.20.0 in /usr/lib/python3/dist-packages (from docker-compose) (2.25.1)
Collecting docker[ssh]>=5
Downloading https://www.piwheels.org/simple/docker/ ... ne-any.whl (147 kB)
|████████████████████████████████| 147 kB 2.4 MB/s
Collecting jsonschema<4,>=2.5.1
Downloading https://www.piwheels.org/simple/jsonsch ... ne-any.whl (56 kB)
|████████████████████████████████| 56 kB 347 kB/s
Collecting texttable<2,>=0.9.0
Downloading https://www.piwheels.org/simple/texttab ... ne-any.whl (10 kB)
Collecting python-dotenv<1,>=0.13.0
Downloading python_dotenv-0.21.0-py3-none-any.whl (18 kB)
Collecting websocket-client<1,>=0.32.0
Downloading https://www.piwheels.org/simple/websock ... ne-any.whl (67 kB)
|████████████████████████████████| 67 kB 385 kB/s
Collecting dockerpty<1,>=0.4.1
Downloading https://www.piwheels.org/simple/dockerp ... ne-any.whl (16 kB)
Collecting packaging>=14.0
Downloading https://www.piwheels.org/simple/packagi ... ne-any.whl (40 kB)
|████████████████████████████████| 40 kB 367 kB/s
Requirement already satisfied: urllib3>=1.26.0 in /usr/lib/python3/dist-packages (from docker[ssh]>=5->docker-compose) (1.26.5)
Collecting requests<3,>=2.20.0
Downloading https://www.piwheels.org/simple/request ... ne-any.whl (62 kB)
|████████████████████████████████| 62 kB 146 kB/s
Collecting paramiko>=2.4.3
Downloading https://www.piwheels.org/simple/paramik ... ne-any.whl (215 kB)
|████████████████████████████████| 215 kB 1.3 MB/s
Requirement already satisfied: six>=1.3.0 in /usr/lib/python3/dist-packages (from dockerpty<1,>=0.4.1->docker-compose) (1.16.0)
Collecting attrs>=17.4.0
Downloading https://www.piwheels.org/simple/attrs/a ... ne-any.whl (58 kB)
|████████████████████████████████| 58 kB 1.6 MB/s
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from jsonschema<4,>=2.5.1->docker-compose) (52.0.0)
Collecting pyrsistent>=0.14.0
Downloading https://www.piwheels.org/simple/pyrsist ... armv7l.whl (101 kB)
|████████████████████████████████| 101 kB 953 kB/s
Collecting pyparsing!=3.0.5,>=2.0.2
Downloading https://www.piwheels.org/simple/pyparsi ... ne-any.whl (98 kB)
|████████████████████████████████| 98 kB 741 kB/s
Collecting bcrypt>=3.1.3
Downloading bcrypt-4.0.0.tar.gz (25 kB)
Installing build dependencies ... done
Getting requirements to build wheel ... done
Preparing wheel metadata ... done
Collecting cryptography>=2.5
Downloading https://www.piwheels.org/simple/cryptog ... armv7l.whl (2.5 MB)
|████████████████████████████████| 2.5 MB 906 kB/s
Collecting pynacl>=1.0.1
Downloading https://www.piwheels.org/simple/pynacl/ ... armv7l.whl (585 kB)
|████████████████████████████████| 585 kB 11.8 MB/s
Collecting cffi>=1.12
Downloading https://www.piwheels.org/simple/cffi/cf ... armv7l.whl (364 kB)
|████████████████████████████████| 364 kB 905 kB/s
Collecting pycparser
Downloading https://www.piwheels.org/simple/pycpars ... ne-any.whl (119 kB)
|████████████████████████████████| 119 kB 11.7 MB/s
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python3/dist-packages (from requests<3,>=2.20.0->docker-compose) (2020.6.20)
Collecting charset-normalizer<3,>=2
Downloading https://www.piwheels.org/simple/charset ... ne-any.whl (39 kB)
Requirement already satisfied: idna<4,>=2.5 in /usr/lib/python3/dist-packages (from requests<3,>=2.20.0->docker-compose) (2.10)
Building wheels for collected packages: bcrypt
Building wheel for bcrypt (PEP 517) ... error
ERROR: Command errored out with exit status 1:
command: /usr/bin/python3 /tmp/tmp3oyjllzt_in_process.py build_wheel /tmp/tmpiq9zj0tb
cwd: /tmp/pip-install-v_q4jv9g/bcrypt_772f9ac234d142aa95229d2b942635b4
Complete output (58 lines):
running bdist_wheel
running build
running build_py
creating build
creating build/lib.linux-armv7l-cpython-39
creating build/lib.linux-armv7l-cpython-39/bcrypt
copying src/bcrypt/__about__.py -> build/lib.linux-armv7l-cpython-39/bcrypt
copying src/bcrypt/__init__.py -> build/lib.linux-armv7l-cpython-39/bcrypt
running egg_info
writing src/bcrypt.egg-info/PKG-INFO
writing dependency_links to src/bcrypt.egg-info/dependency_links.txt
writing requirements to src/bcrypt.egg-info/requires.txt
writing top-level names to src/bcrypt.egg-info/top_level.txt
reading manifest file 'src/bcrypt.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
warning: no previously-included files found matching 'requirements.txt'
warning: no previously-included files found matching 'release.py'
warning: no previously-included files found matching 'mypy.ini'
warning: no previously-included files matching '*' found under directory '.github'
warning: no previously-included files matching '*' found under directory '.circleci'
warning: no previously-included files found matching 'src/_bcrypt/target'
warning: no previously-included files matching '*' found under directory 'src/_bcrypt/target'
adding license file 'LICENSE'
writing manifest file 'src/bcrypt.egg-info/SOURCES.txt'
copying src/bcrypt/_bcrypt.pyi -> build/lib.linux-armv7l-cpython-39/bcrypt
copying src/bcrypt/py.typed -> build/lib.linux-armv7l-cpython-39/bcrypt
running build_ext
running build_rust

=============================DEBUG ASSISTANCE=============================
If you are seeing a compilation error please try the following steps to
successfully install bcrypt:
1) Upgrade to the latest pip and try again. This will fix errors for most
users. See: https://pip.pypa.io/en/stable/installing/#upgrading-pip
2) Ensure you have a recent Rust toolchain installed. bcrypt requires
rustc >= 1.56.0.

Python: 3.9.2
platform: Linux-5.10.63-v7l+-armv7l-with-glibc2.31
pip: n/a
setuptools: 65.3.0
setuptools_rust: 1.5.2
rustc: n/a
=============================DEBUG ASSISTANCE=============================

error: can't find Rust compiler

If you are using an outdated pip version, it is possible a prebuilt wheel is available for this package but pip is not able to install from it. Installing from the wheel would avoid the need for a Rust compiler.

To update pip, run:

pip install --upgrade pip

and then retry package installation.

If you did intend to build this package from source, try installing a Rust compiler from your system package manager and ensure it is on the PATH during installation. Alternatively, rustup (available at https://rustup.rs) is the recommended way to download and update the Rust compiler toolchain.

This package requires Rust >=1.56.0.
----------------------------------------
ERROR: Failed building wheel for bcrypt
Failed to build bcrypt
ERROR: Could not build wheels for bcrypt which use PEP 517 and cannot be installed directly
Awatar użytkownika
lesny8
Posty: 2272
Rejestracja: pn gru 11, 2017 9:43 pm

michal13 pisze: pn wrz 19, 2022 8:17 pm Pomocy walczę z tym już 2 noc wszystko na czerwono

...
error: can't find Rust compiler
...
https://www.rust-lang.org/tools/install
michal13
Posty: 8
Rejestracja: pt wrz 17, 2021 5:30 pm

lesny8 pisze: pn wrz 19, 2022 8:24 pm
michal13 pisze: pn wrz 19, 2022 8:17 pm Pomocy walczę z tym już 2 noc wszystko na czerwono

...
error: can't find Rust compiler
...
https://www.rust-lang.org/tools/install
rust zainstalowany
rustc 1.63.0 (4b91a6ea7 2022-08-08)
ale problem z instalacją docker compose pozostał
teraz mam błąd "This package requires Rust >=1.56.0.
Building wheel for bcrypt (PEP 517) ... error
ERROR: Failed building wheel for bcrypt
Failed to build bcrypt
ERROR: Could not build wheels for bcrypt which use PEP 517 and cannot be installed directly"
Awatar użytkownika
klimasstudio
Posty: 692
Rejestracja: śr sie 28, 2019 9:35 pm
Lokalizacja: localhost
Kontakt:

Zainstaluj Dockera, na to Poitainera: https://docs.portainer.io/v/ce-2.9/star ... cker/linux
Poitainer rozwiąrze problem braku/niemożności instalacji docker compose. Możesz pominąć instalację docker-compose bo przy instalacji Portainera wszystko się pojawi ;)

PAMIĘTAJ aby w plikach .sh supla-docker i supla-scripts przed uruchomieniem zmienić "docker-compose" na "docker compose" dopiero potem wystartuj skrypty

Po instalacji Portainera przejdz do kroku

#4
SUPLA-DOCKER

następnie do kroku

#5
SUPLA-SCRIPTS

Po zalogowaniu do portainera możesz podejrzeć LOGi ado bazy danych mozesz port wystawić i zarządzać bazą z zewnętrznej aplikacji.
Więc chodź OSUPLUJE Ci dom :mrgreen:
michal13
Posty: 8
Rejestracja: pt wrz 17, 2021 5:30 pm

klimasstudio pisze: śr wrz 21, 2022 8:47 am Zainstaluj Dockera, na to Poitainera: https://docs.portainer.io/v/ce-2.9/star ... cker/linux
Poitainer rozwiąrze problem braku/niemożności instalacji docker compose. Możesz pominąć instalację docker-compose bo przy instalacji Portainera wszystko się pojawi ;)

PAMIĘTAJ aby w plikach .sh supla-docker i supla-scripts przed uruchomieniem zmienić "docker-compose" na "docker compose" dopiero potem wystartuj skrypty

Po instalacji Portainera przejdz do kroku

#4
SUPLA-DOCKER

następnie do kroku

#5
SUPLA-SCRIPTS

Po zalogowaniu do portainera możesz podejrzeć LOGi ado bazy danych mozesz port wystawić i zarządzać bazą z zewnętrznej aplikacji.
Jutro to przetestuję
michal13
Posty: 8
Rejestracja: pt wrz 17, 2021 5:30 pm

wykonałem instalacja zgodnie z instrukcją teraz przy uruchomieniu mam komunikat
"./supla-docker/supla.sh: line 37: docker-compose: command not found"
plik .env
# Where the SUPLA Cloud will be accessible? Put domain or IP address here with port.
CLOUD_DOMAIN=xxxxxx

# Initial user account details; delete these settings after the first launch
FIRST_USER_EMAIL=xxxxxxx
FIRST_USER_PASSWORD=xxxxxx

# Google ReCaptcha settings
RECAPTCHA_ENABLED=false
RECAPTCHA_PUBLIC_KEY=
RECAPTCHA_PRIVATE_KEY=

# Mailer settings (SMTP)
MAILER_HOST=10.0.75.1
MAILER_PORT=465
MAILER_USER=
MAILER_PASSWORD=
MAILER_ENCRYPTION=ssl
MAILER_FROM=

# If you want to be notified about some server errors, set this
ADMIN_EMAIL=xxx

# Where to store SUPLA Cloud's data
VOLUME_DATA=./var

# On which ports the SUPLA Cloud should listen (only if standalone mode)
PORT_HTTP=80
PORT_HTTPS=443

REQUIRE_REGULATIONS_ACCEPTANCE=false
REQUIRE_COOKIE_POLICY_ACCEPTANCE=false
BRUTE_FORCE_AUTH_PREVENTION_ENABLED=true
ACCOUNTS_REGISTRATION_ENABLED=true

# MQTT Broker settings (you have to run the broker yourself)
MQTT_BROKER_ENABLED=false
MQTT_BROKER_HOST=
MQTT_BROKER_PORT=8883
MQTT_BROKER_TLS=true
MQTT_BROKER_USERNAME=
MQTT_BROKER_PASSWORD=
MQTT_BROKER_CLIENT_ID=

# These options protect your application
DB_PASSWORD=xxxxxx
SECRET=xxxx

COMPOSE_PROJECT_NAME=supla
COMPOSE_PATH_SEPARATOR=:
COMPOSE_FILE=docker compose.yml:docker compose.standalone.yml:docker compose.arm32v7.yml
Ostatnio zmieniony pt wrz 23, 2022 7:43 am przez michal13, łącznie zmieniany 1 raz.
Awatar użytkownika
klimasstudio
Posty: 692
Rejestracja: śr sie 28, 2019 9:35 pm
Lokalizacja: localhost
Kontakt:

klimasstudio pisze: śr wrz 21, 2022 8:47 am PAMIĘTAJ aby w plikach .sh supla-docker i supla-scripts przed uruchomieniem zmienić "docker-compose" na "docker compose" dopiero potem wystartuj skrypty
A co pisałem !? Edytuj pliki .sh zanim odpalisz !!
Więc chodź OSUPLUJE Ci dom :mrgreen:
michal13
Posty: 8
Rejestracja: pt wrz 17, 2021 5:30 pm

chyba coś mi ucieka "./supla-docker/supla.sh
nano supla-docker/.env" ????
ODPOWIEDZ

Wróć do „FAQ / Jak to zrobić”