[tutorial] Raspberry Pi – Docker, Proxy, Let’s Encrypt, SUPLA, SUPLA-Scripts...

User avatar
lesny8
Posts: 535
Joined: Mon Dec 11, 2017 9:43 pm

Tue Feb 19, 2019 10:36 am

milion81 wrote:
Mon Feb 18, 2019 8:56 pm
odpowiedź jak w załączniku,
wcześniej miałem to samo, pomógł downgrade dockera do wersji 18.06.01
Dziwne, spróbuj zrobić downgrade. W sumie masz inna architekturę niż ja, ale może faktycznie coś jest nie tak z tą wersją dockera na armv6l...
PuteR wrote:
Tue Feb 19, 2019 9:31 am
Noni znowu mam problem... 😐 Wczoraj jeszcze wszystko było ok, a dziś nie mogę się zalogować ani na clouda ani na supla scripts. Aplikacja działa prawidłowo moduły również są połączone, a zalogować się nie można wyskakuje błąd

502 Bad Gateway nginx/1.15.8

Restart maliny nie pomaga, o co może chodzić?

A robiłeś coś? Problem masz z dostępem do cloud, supla-server działa. Jeśli z WAN i z LAN masz problem z dostaniem się do chmury to na pewno nie jest to problem Twojego DNS, a raczej proxy. Zatrzymaj i usuń nginx-web a potem uruchom jeszcze raz skrypt. Może się pogubił.

Code: Select all

docker stop nginx-web && docker rm nging-web
cd ~/docker-compose-letsencrypt-nginx-proxy-companion
./start.sh
Last edited by lesny8 on Tue Feb 19, 2019 11:18 am, edited 1 time in total.
PuteR
Posts: 517
Joined: Wed Dec 06, 2017 10:07 am

Tue Feb 19, 2019 10:58 am

Ok, sam już widzę że coś jest nie tak 😁 ale co tam się porobiło skoro sam nic nie zmieniałem.

Code: Select all


pi@raspberrypi:~ $ docker stop nginx-web && docker rm nging-web
nginx-web
Error: No such container: nging-web
pi@raspberrypi:~ $ docker ps
CONTAINER ID        IMAGE                                                   COMMAND                  CREATED             STATUS              PORTS                                                  NAMES
1d0df52bebe9        supla/supla-server:arm32v7                              "/usr/bin/server-ent…"   3 days ago          Up 2 hours          0.0.0.0:2015-2016->2015-2016/tcp                       supla-server
fb31c6ee0cd4        supla/supla-cloud:arm32v7                               "docker-php-entrypoi…"   3 days ago          Up 7 seconds        80/tcp                                                 supla-cloud
da528f5a9bc9        suplascripts_suplascripts                               "docker-php-entrypoi…"   5 days ago          Up About an hour    80/tcp                                                 suplascripts
dffec9b16b0d        hypriot/rpi-mysql:5.5                                   "/entrypoint.sh mysq…"   3 weeks ago         Up 2 hours          3306/tcp                                               supla-db
ac2f9f1f23fe        sameersbn/bind:latest                                   "/sbin/entrypoint.sh…"   3 weeks ago         Up 2 hours          53/tcp, 0.0.0.0:53->53/udp, 0.0.0.0:10000->10000/tcp   bind
90b9dbccdc6c        hypriot/rpi-mysql:5.5                                   "/entrypoint.sh mysq…"   3 weeks ago         Up 2 hours          3306/tcp                                               suplascripts-db
e3739bcdc8ea        wouterds/rpi-docker-letsencrypt-nginx-proxy-companion   "/bin/bash /app/entr…"   3 weeks ago         Up 2 hours                                                                 nginx-letsencrypt
pi@raspberrypi:~ $ cd ~/docker-compose-letsencrypt-nginx-proxy-companion
pi@raspberrypi:~/docker-compose-letsencrypt-nginx-proxy-companion $ .start.sh
-bash: .start.sh: nie znaleziono polecenia
pi@raspberrypi:~/docker-compose-letsencrypt-nginx-proxy-companion $ 
W pierwszym poleceniu była tylko literówka, ale jak próbuję wykonać .start.sh to wywala mimo wszystko że nie znaleziono polecenia

Code: Select all

pi@raspberrypi:~/docker-compose-letsencrypt-nginx-proxy-companion $ .start.sh
-bash: .start.sh: nie znaleziono polecenia
User avatar
lesny8
Posts: 535
Joined: Mon Dec 11, 2017 9:43 pm

Tue Feb 19, 2019 11:19 am

Brakuje /, z rozpędu nie napisałem

Code: Select all

./start.sh
PuteR
Posts: 517
Joined: Wed Dec 06, 2017 10:07 am

Tue Feb 19, 2019 11:43 am

He tego już sam nie wyłapałem niestety dalej coś nie tak powyższe komendy wykonały się prawidłowo ale teraz jest tak

Code: Select all

clear
pi@raspberrypi:~ $ docker ps
CONTAINER ID        IMAGE                                                   COMMAND                  CREATED             STATUS                          PORTS                                                  NAMES
53f5903302d1        nginx                                                   "nginx -g 'daemon of…"   5 minutes ago       Up 4 minutes                    0.0.0.0:80->80/tcp, 0.0.0.0:443->443/tcp               nginx-web
1d0df52bebe9        supla/supla-server:arm32v7                              "/usr/bin/server-ent…"   3 days ago          Up 2 hours                      0.0.0.0:2015-2016->2015-2016/tcp                       supla-server
fb31c6ee0cd4        supla/supla-cloud:arm32v7                               "docker-php-entrypoi…"   3 days ago          Restarting (1) 31 seconds ago                                                          supla-cloud
da528f5a9bc9        suplascripts_suplascripts                               "docker-php-entrypoi…"   5 days ago          Up 2 hours                      80/tcp                                                 suplascripts
dffec9b16b0d        hypriot/rpi-mysql:5.5                                   "/entrypoint.sh mysq…"   3 weeks ago         Up 2 hours                      3306/tcp                                               supla-db
ac2f9f1f23fe        sameersbn/bind:latest                                   "/sbin/entrypoint.sh…"   3 weeks ago         Up 2 hours                      53/tcp, 0.0.0.0:53->53/udp, 0.0.0.0:10000->10000/tcp   bind
90b9dbccdc6c        hypriot/rpi-mysql:5.5                                   "/entrypoint.sh mysq…"   3 weeks ago         Up 2 hours                      3306/tcp                                               suplascripts-db
e3739bcdc8ea        wouterds/rpi-docker-letsencrypt-nginx-proxy-companion   "/bin/bash /app/entr…"   3 weeks ago         Up 2 hours                                                                             nginx-letsencrypt
5444646b35c3        wouterds/rpi-docker-gen                                 "/usr/local/bin/dock…"   3 weeks ago         Up 4 minutes                                                                           nginx-gen
pi@raspberrypi:~ $  
Czemu Cloud się restartuje?

Supla scripts niby działa, można się zalogować, ale sypie błędami i z automat wyświetlają się powiadomienia że niby światło włączone chociaż nie jest włączone 😐, podejrzewam że to już wina braku połączenia z supla Cloud.

Po restarcie supla dalej tak samo

Code: Select all

./supla-docker/supla.sh restart 
User avatar
lesny8
Posts: 535
Joined: Mon Dec 11, 2017 9:43 pm

Tue Feb 19, 2019 1:46 pm

PuteR wrote:
Tue Feb 19, 2019 11:43 am
Czemu Cloud się restartuje?

Supla scripts niby działa, można się zalogować, ale sypie błędami i z automat wyświetlają się powiadomienia że niby światło włączone chociaż nie jest włączone 😐, podejrzewam że to już wina braku połączenia z supla Cloud.

Po restarcie supla dalej tak samo
Nie wiem, możesz zobaczyć w logach o co krzyczy.
Potem możesz zapodać jeszcze raz upgrade. @fracz wypuścił wczoraj Cloud v2.3.1.
edm
Posts: 135
Joined: Mon Jan 15, 2018 6:18 pm

Tue Feb 19, 2019 1:57 pm

lesny8 wrote:
Tue Feb 19, 2019 1:46 pm
@fracz wypuścił wczoraj Cloud v2.3.1.
Jest gdzieś historia zmian, aby wiedzieć co się zmieniło?
User avatar
michael
Posts: 845
Joined: Wed Nov 09, 2016 8:00 am
Location: Wojkowice

Tue Feb 19, 2019 1:59 pm

Kabel ucięty na miarę zawsze jest za krótki...
PuteR
Posts: 517
Joined: Wed Dec 06, 2017 10:07 am

Tue Feb 19, 2019 2:12 pm

Takie coś tylko wyrzuca log

Code: Select all

clear
pi@raspberrypi:~ $ source supla-docker/.env
pi@raspberrypi:~ $ docker logs --tail=50 supla-cloud
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
standard_init_linux.go:207: exec user process caused "no such file or directory"
pi@raspberrypi:~ $  

Upgrade zrobię jak wrócę do domu. Może coś pomoże.
milion81
Posts: 100
Joined: Mon May 07, 2018 8:34 am

Tue Feb 19, 2019 4:11 pm

lesny8 wrote:
Tue Feb 19, 2019 10:36 am
milion81 wrote:
Mon Feb 18, 2019 8:56 pm
odpowiedź jak w załączniku,
wcześniej miałem to samo, pomógł downgrade dockera do wersji 18.06.01
Dziwne, spróbuj zrobić downgrade. W sumie masz inna architekturę niż ja, ale może faktycznie coś jest nie tak z tą wersją dockera na armv6l...
po downgrade do dockera w wersji 18.06.01 odpowiedź jak niżej (czyli dla armv6, coś nie tak z najnowszym docker'em)
ale dalej mam cos źle bo w mojej odpowiedzi w kolumnie PORTS brakuje 0.0.0.0:80->80/tcp, 0.0.0.0:443->443/tcp
Attachments
C.png
C.png (110 KiB) Viewed 271 times
PuteR
Posts: 517
Joined: Wed Dec 06, 2017 10:07 am

Tue Feb 19, 2019 4:48 pm

No i lipa zrobiłem upgrade, reaotowalem malinie od nowa startowalem dockera ciągle to samo.

Code: Select all

.clear
pi@raspberrypi:~ $ docker ps
CONTAINER ID        IMAGE                                                   COMMAND                  CREATED             STATUS                          PORTS                                                  NAMES
0abf9abb7c96        supla/supla-server:arm32v7                              "/usr/bin/server-ent…"   19 minutes ago      Up 6 minutes                    0.0.0.0:2015-2016->2015-2016/tcp                       supla-server
b29c8edb8396        supla/supla-cloud:arm32v7                               "docker-php-entrypoi…"   20 minutes ago      Restarting (1) 22 seconds ago                                                          supla-cloud
53f5903302d1        nginx                                                   "nginx -g 'daemon of…"   5 hours ago         Up 7 minutes                    0.0.0.0:80->80/tcp, 0.0.0.0:443->443/tcp               nginx-web
da528f5a9bc9        suplascripts_suplascripts                               "docker-php-entrypoi…"   5 days ago          Up 5 minutes                    80/tcp                                                 suplascripts
dffec9b16b0d        hypriot/rpi-mysql:5.5                                   "/entrypoint.sh mysq…"   3 weeks ago         Up 6 minutes                    3306/tcp                                               supla-db
ac2f9f1f23fe        sameersbn/bind:latest                                   "/sbin/entrypoint.sh…"   3 weeks ago         Up 13 minutes                   53/tcp, 0.0.0.0:53->53/udp, 0.0.0.0:10000->10000/tcp   bind
90b9dbccdc6c        hypriot/rpi-mysql:5.5                                   "/entrypoint.sh mysq…"   3 weeks ago         Up 6 minutes                    3306/tcp                                               suplascripts-db
e3739bcdc8ea        wouterds/rpi-docker-letsencrypt-nginx-proxy-companion   "/bin/bash /app/entr…"   3 weeks ago         Up 7 minutes                                                                           nginx-letsencrypt
5444646b35c3        wouterds/rpi-docker-gen                                 "/usr/local/bin/dock…"   3 weeks ago         Up 7 minutes                                                                           nginx-gen
pi@raspberrypi:~ $  
lesny8 masz może jakiś pomysł czego można jeszcze spróbować poza stawianiem wszystkiego od nowa 😐
Post Reply